Mailinglist Archive: opensuse-factory (520 mails)

< Previous Next >
[opensuse-factory] Leap 42.3 Build 0253 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=42.3&build=0253&groupid=28
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Distribution&query_format=advanced&resolution=---&version=Leap%2042.3

When you reply to discuss some issues, make sure to change the subject.
Please use the test plan at
https://docs.google.com/spreadsheets/d/1AGKijKpKiJCB616-bHVoNQuhWHpQLHPWCb3m1p6gXPc/edit#gid=298435253
to record your testing efforts and use bugzilla to report bugs.

Packages changed:
akonadi-calendar (17.04.0 -> 17.04.1)
akonadi-calendar-tools (17.04.0 -> 17.04.1)
akonadi-contact (17.04.0 -> 17.04.1)
akonadi-mime (17.04.0 -> 17.04.1)
akonadi-notes (17.04.0 -> 17.04.1)
akonadi-search (17.04.0 -> 17.04.1)
akonadi-server (17.04.0 -> 17.04.1)
akregator (17.04.0 -> 17.04.1)
amarok
ark (17.04.0 -> 17.04.1)
autofs
baloo5-widgets (17.04.0 -> 17.04.1)
calendarsupport (17.04.0 -> 17.04.1)
dolphin (17.04.0 -> 17.04.1)
dragonplayer (17.04.0 -> 17.04.1)
eventviews (17.04.0 -> 17.04.1)
grantleetheme (17.04.0 -> 17.04.1)
incidenceeditor (17.04.0 -> 17.04.1)
k3b (17.04.0 -> 17.04.1)
kaccounts-integration (17.04.0 -> 17.04.1)
kaddressbook (17.04.0 -> 17.04.1)
kalarmcal (17.04.0 -> 17.04.1)
kamera (17.04.0 -> 17.04.1)
kate (17.04.0 -> 17.04.1)
kcalc (17.04.0 -> 17.04.1)
kcalcore (17.04.0 -> 17.04.1)
kcalutils (17.04.0 -> 17.04.1)
kcharselect (17.04.0 -> 17.04.1)
kcolorchooser (17.04.0 -> 17.04.1)
kcontacts (17.04.0 -> 17.04.1)
kdav (17.04.0 -> 17.04.1)
kdebase4-runtime (17.04.0 -> 17.04.1)
kdelibs4 (4.14.31 -> 4.14.32)
kdenetwork4-filesharing (17.04.0 -> 17.04.1)
kdepim-addons (17.04.0 -> 17.04.1)
kdepim-apps-libs (17.04.0 -> 17.04.1)
kdepim-runtime (17.04.0 -> 17.04.1)
kdnssd (17.04.0 -> 17.04.1)
kernel-firmware (20170404 -> 20170522)
kexec-tools
kget (17.04.0 -> 17.04.1)
kgpg (17.04.0 -> 17.04.1)
khelpcenter5 (17.04.0 -> 17.04.1)
kholidays (17.04.0 -> 17.04.1)
kidentitymanagement (17.04.0 -> 17.04.1)
kimap (17.04.0 -> 17.04.1)
kio-extras5 (17.04.0 -> 17.04.1)
kio_audiocd (17.04.0 -> 17.04.1)
kldap (17.04.0 -> 17.04.1)
kleopatra (17.04.0 -> 17.04.1)
kmag (17.04.0 -> 17.04.1)
kmahjongg (17.04.0 -> 17.04.1)
kmail (17.04.0 -> 17.04.1)
kmail-account-wizard (17.04.0 -> 17.04.1)
kmailtransport (17.04.0 -> 17.04.1)
kmbox (17.04.0 -> 17.04.1)
kmime (17.04.0 -> 17.04.1)
kmines (17.04.0 -> 17.04.1)
kmousetool (17.04.0 -> 17.04.1)
kompare (17.04.0 -> 17.04.1)
konqueror (17.04.0 -> 17.04.1)
konsole (17.04.0 -> 17.04.1)
kontact (17.04.0 -> 17.04.1)
kontactinterface (17.04.0 -> 17.04.1)
konversation (1.6.2 -> 1.7.2)
kopete (17.04.0 -> 17.04.1)
korganizer (17.04.0 -> 17.04.1)
kpat (17.04.0 -> 17.04.1)
kpimtextedit (17.04.0 -> 17.04.1)
kreversi (17.04.0 -> 17.04.1)
kruler (17.04.0 -> 17.04.1)
krusader (2.5.0 -> 2.6.0)
kscd (17.04.0 -> 17.04.1)
ksudoku (17.04.0 -> 17.04.1)
ktnef (17.04.0 -> 17.04.1)
ktp-common-internals (17.04.0 -> 17.04.1)
kwalletmanager5 (17.04.0 -> 17.04.1)
libgravatar (17.04.0 -> 17.04.1)
libkcddb (17.04.0 -> 17.04.1)
libkcompactdisc (17.04.0 -> 17.04.1)
libkdcraw (17.04.0 -> 17.04.1)
libkdegames (17.04.0 -> 17.04.1)
libkdepim (17.04.0 -> 17.04.1)
libkexiv2 (17.04.0 -> 17.04.1)
libkface (17.04.0 -> 17.04.1)
libkgapi (17.04.0 -> 17.04.1)
libkgeomap (17.04.0 -> 17.04.1)
libkipi (17.04.0 -> 17.04.1)
libkleo (17.04.0 -> 17.04.1)
libkmahjongg (17.04.0 -> 17.04.1)
libkomparediff2 (17.04.0 -> 17.04.1)
libksane (17.04.0 -> 17.04.1)
libksieve (17.04.0 -> 17.04.1)
libpsm2
libsndfile
mailcommon (17.04.0 -> 17.04.1)
mailimporter (17.04.0 -> 17.04.1)
marble (17.04.0 -> 17.04.1)
messagelib (17.04.0 -> 17.04.1)
mobipocket (17.04.0 -> 17.04.1)
okular (17.04.0 -> 17.04.1)
os-prober
osc (0.155.0 -> 0.158.0)
pimcommon (17.04.0 -> 17.04.1)
postgresql95 (9.5.6 -> 9.5.7)
postgresql96 (9.6.2 -> 9.6.3)
postgresql96-libs (9.6.2 -> 9.6.3)
rp-pppoe (3.11 -> 3.12)
spectacle (17.04.0 -> 17.04.1)
sweeper (17.04.0 -> 17.04.1)
syndication (17.04.0 -> 17.04.1)
xf86-input-libinput (0.19.1 -> 0.25.1)
yast2-installation (3.2.39 -> 3.2.40)
yast2-storage (3.2.11 -> 3.2.12)

=== Details ===

==== akonadi-calendar ====
Version update (17.04.0 -> 17.04.1)
Subpackages: akonadi-calendar-lang libKF5AkonadiCalendar5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix mem leak

==== akonadi-calendar-tools ====
Version update (17.04.0 -> 17.04.1)
Subpackages: akonadi-calendar-tools-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== akonadi-contact ====
Version update (17.04.0 -> 17.04.1)
Subpackages: akonadi-contact-lang libKF5AkonadiContact5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix Bug 375296 - unable to use kdeconnect-cli to send an sms (kde#375296)
* Keep margin

==== akonadi-mime ====
Version update (17.04.0 -> 17.04.1)
Subpackages: akonadi-mime-lang libKF5AkonadiMime5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== akonadi-notes ====
Version update (17.04.0 -> 17.04.1)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== akonadi-search ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Translations fixes (untranslatable messages, pot name)
* Fix contact UID indexing and search
* Make sure that directory is created
- Drop upstreamed patches:
* fix_uid_search.patch

==== akonadi-server ====
Version update (17.04.0 -> 17.04.1)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix mem leak
* avoid qCWarning in ETM for items never inserted
* Increase timeout in ResourceSynchronizationJob
* Fix possible crash in CollectionCopyJob when tracing Jobs
* Prevent sending multiple error messages from a single Handler
* Fix trx deadlock when updating Search collection
* On error, still send answer via DBUS, avoiding clients waiting forever
(kde#378189)
* Fix clearing Item flags (kde#375146)
* Use toModelIndex
* This variable is unused
* use qAsConst
* Use qAsconst
* Minor optimization
* Fix emit or not keyword
* Remove unused variable
* Remove compile warning
* Minor optimization

==== akregator ====
Version update (17.04.0 -> 17.04.1)
Subpackages: akregator-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Keep cookies
* Don't complexify code for creating path
* Fix Bug 378757 - Archive: Archive folder not created if missing, articles
not saved (kde#378757)

==== amarok ====
Subpackages: amarok-lang

- Revert kde4_runtime_requires change
- Recommend kio_audiocd4 for playback of AudioCDs, the standard
kio_audiocd package is KF5 based now
- Expand macro kde4_runtime_requires only when its available
to fix quilt setup

==== ark ====
Version update (17.04.0 -> 17.04.1)
Subpackages: ark-lang libkerfuffle17

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Don't repeat work of KAboutData::setupCommandLine()
* Call KAboutData::setApplicationData() earlier, in common place
* Call kdoctools_install in addition to ki18n_install

==== autofs ====

- Fix adding of the wildcard key to the negative cache (bsc#1031533)
* Add autofs-5.1.0-dont-add-wildcard-to-negative-cache.patch
- Make interaction with negative cache more robust (bsc#1031533)
* Add
autofs-5.1.0-make-negative-cache-update-consistent-for-all-lookup-modules.patch
* Add autofs-5.1.0-ensure-negative-cache-isnt-updated-on-remount.patch

==== baloo5-widgets ====
Version update (17.04.0 -> 17.04.1)
Subpackages: baloo5-widgets-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Sort tags alphabetically in the metadata widget (kde#377589)
* Rename the translation catalog (avoid conflicts)
* Move ECMAddTests after KDEFrameworkCompilerSettings

==== calendarsupport ====
Version update (17.04.0 -> 17.04.1)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== dolphin ====
Version update (17.04.0 -> 17.04.1)
Subpackages: dolphin-lang dolphin-part libdolphinvcs5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Don't ignore tag clicks in the tooltips
* Sort the tag-values alphabetically in the "Tags" column (kde#377589)

==== dragonplayer ====
Version update (17.04.0 -> 17.04.1)
Subpackages: dragonplayer-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== eventviews ====
Version update (17.04.0 -> 17.04.1)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix enable/disable button. Don't crash when currentItem is empty (during
removing items)

==== grantleetheme ====
Version update (17.04.0 -> 17.04.1)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== incidenceeditor ====
Version update (17.04.0 -> 17.04.1)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix Bug 379510 - Event templates do not work (kde#379510)
* Minor optimization
* Use default constructor

==== k3b ====
Version update (17.04.0 -> 17.04.1)
Subpackages: k3b-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kaccounts-integration ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kaddressbook ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kaddressbook-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kalarmcal ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kalarmcal-lang libKF5AlarmCalendar5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kamera ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kamera-lang kio_kamera

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kate ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kate-lang kate-plugins

- Add patch to defuse root block:
* 0001-Defuse-root-block.patch
- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Don't repeat work of KAboutData::setupCommandLine()
* Don't repeat work of KAboutData::setApplicationData()
* Enable numericMode for sorting document list in filetree (kde#375676)
- Drop upstreamed patches:
* enable-numericMode-in-filetree.patch

==== kcalc ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kcalc-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kcalcore ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kcalutils ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* not necessary to translate it.

==== kcharselect ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kcharselect-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kcolorchooser ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kcolorchooser-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kcontacts ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* VCardParser: gain 1% of performance by using indexOf+mid instead of
split('\n')
* Add missing include (make it happy jenkins)
* VCardParser: rewrite parser to use a state machine instead of split()
* VCardParser: extract class for parsing the current line
* Revert 1760aca (which commented out some unittests...).

==== kdav ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKPimKDAV5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Use same variable name, so it's more easy to change version

==== kdebase4-runtime ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kdelibs4 ====
Version update (4.14.31 -> 4.14.32)
Subpackages: kdelibs4-core kdelibs4-doc libkde4 libkde4-devel libkdecore4
libkdecore4-devel libksuseinstall1

- Update to 4.14.32
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 4.14.31:
* Verify that whoever is calling us is actually who he says he is
* Prepare for 4.14.32
* http slave: send error page after authorization failure (kde#373323)
- Drop upstreamed patches:
* fix-kauth-bypass-CVE-2017-8422.patch
- Add fix-kauth-bypass-CVE-2017-8422.patch to fix an exploit
against kauth that would allow to bypass it (bsc#1036244,
CVE-2017-8422)

==== kdenetwork4-filesharing ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kdenetwork4-filesharing-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kdepim-addons ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kdepim-addons-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Add debug + update copyright
* Fix mem leak
* Minor optimization
* Use nullptr
* Allow catching signal when we start eventLoop not before it. Otherwise we
can exist from this code
* USe nullptr
* Verify that qstring is really empty
* use isEmpty here
* Fix split emails
* Fix multi emails
* Add debug info
* Fix kmail documentation

==== kdepim-apps-libs ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kdepim-apps-libs-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kdepim-runtime ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kdepim-runtime-lang

- Add add-missing-include.patch and
fix-crash-when-configuring-IMAP-resources.patch to fix IMAP
resources crashing when trying to open settings
(kde#379155, boo#1040086)
- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix build with CMake 3.8.
* [IMAP] Fix migration to new Gmail authentication
* [IMAP] Disable the Gmail special cases when compiled without XOAUTH
* hide doc help item.
* [IMAP] Fix missing connect() when restarting IDLE job
* [IMAP] Fix IDLE support with GSSAPI authentication (kde#311456)
- Drop upstreamed patches:
* disable-gmail-when-compiled-without-xoauth.patch
* fix-idle-support-with-gssapi.patch
* fix-migration-to-new-gmail-authentication.patch
* fix-missing-connect-when-restarting-idle.patch

==== kdnssd ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kernel-firmware ====
Version update (20170404 -> 20170522)
Subpackages: ucode-amd

- Update to version 20170522 (commit df40d15d6ad6) (bsc#1039785):
* linux-firmware: liquidio: update firmware to v1.5.1
* linux-firmware: update Marvell SD8887 firmware image
* linux-firmware: update Marvell SD8897-B0 firmware image
* rtl_bt: Update firmware for BT part of rtl8822be
* cxgb4: update firmware to revision 1.16.43.0
* linux-firmware: add Marvell USB8997 firmware image
* iwlwifi: update -22 firmware for 3168
* Update firmware for 3168
* qed: Add firmware 8.20.0.0
* Update Intel OPA hfi1 firmware

==== kexec-tools ====

- kexec-tools-xen-static.patch: xen breaks kexec-tools build
(bsc#1037779)
See also matching fix in xen-devel package
- Update to version 2.0.12 (FATE#320915, bsc#980545)
Changelog:
http://git.kernel.org/cgit/utils/kernel/kexec/kexec-tools.git/log/?id=refs/tags/v2.0.5..v2.0.12
Drop following patches (upstream):
kexec-tools-Provide-an-option-to-use-new-kexec-system-call.patch
kexec-tools-fs2dt-fix-endianess-issue-with-initrd-base-and-size.patch
kexec-tools-i386-bzimage_efi.patch
kexec-tools-kdump-fix-elf-header-endianess.patch
kexec-tools-load-crash-kernel-high.patch

kexec-tools-ppc64-purgatory-device-tree-values-should-be-read-stored-in-big-endian.patch
kexec-tools-zero-efi-info.patch
Refresh following patches for SLE12 (context):
kexec-tools-vmcoreinfo-in-xen.patch
kexec-tools-xen-balloon-up.patch
kexec-tools-xen-e820-redefinition.patch
kexec-tools-xen-static.patch
Temporarily disable following SGI patch pending further analysis
kexec-tools-set-mmconf-reserved.patch
- kexec-tools-ppc64-reduce-elf-loads.patch: ppc64: Reduce number of
ELF LOAD segments (bsc#981339).
- Adjust linking to libxenctrl to xen-4.7 API (fate#319989)
- kexec-tools-vmcoreinfo-in-xen.patch: Store XEN_VMCOREINFO in
panic kernel ELF notes.
(bsc#951740)
- kexec-tools-xen-inhibit-file-based-syscall.patch: To inhibit file
based syscall on XEN, using old syscall to load crash kernel.
(bsc#947172)
- kexec-tools-load-crash-kernel-high.patch: Load crash kernel high
on x86 (bsc#946365).
- Add
'kexec-tools/kexec-tools-Provide-an-option-to-use-new-kexec-system-call.patch'
to support kdump on secure boot. (fate#315018, bnc#884453)
- custom autoconf action was no longer setting HAVE_LIBXENCTRL (bnc#886873)
- Do not package kdump.8 as it is only a placeholder, full man page is provided
by kdump package (bnc#892090)
- Fix ELF header endianess for ppc64le kdump (bnc#888150)
New patch: kexec-tools-kdump-fix-elf-header-endianess.patch
- Remove insserv dependency; the package doesn't provide any sysvinit
script
- Device tree values should be big endian for ppc64le (bnc#875485)
New patch:
kexec-tools-ppc64-purgatory-device-tree-values-should-be-read-stored-in-big-endian.patch
- Expose flattened device trees (ppc64le) to new kexec'd kernel in Big Endian
format (bnc#873169)
New patch:
kexec-tools-fs2dt-fix-endianess-issue-with-initrd-base-and-size.patch
- Update patch headers to reflect upstream commit id's:
Change patch:
kexec-tools-ppc64-purgatory-disabling-gcc-stack-protection.patch
Change patch: kexec-tools-zero-efi-info.patch
- Reserve mmconf areas for kdump kernel via memmap=X$Y in cmdline
(bnc#819777 [original: bnc#804800]: fix still needed for SGI UV systems).
New patch: kexec-tools-set-mmconf-reserved.patch
- Disable stack protector for ppc64le (bnc#869161)
New patch: kexec-tools-ppc64-purgatory-disabling-gcc-stack-protection.patch
- Disable erroneous (efi memory descriptor version) message (bnc#867785c5)
New patch: kexec-tools-zero-efi-info.patch
- Drop obsolete /etc/init.d/kexec (bnc# 862143).
- Handle btrfs root subvolume (bnc# 862143c35)
- Create kexec-load.service (bnc# 862143)
- Update kexec-bootloader manpage (document reboot using kexec)
- Remove old 11.1 conditionals
- Update kexec-tools-i386-bzimage_efi.patch and
kexec-tools-xen-e820-redefinition.patch with upstream commit ids
- Update to version 2.0.5
Drop patch 'device-tree-buffer-overflows.patch' (upstream)
Drop patch '0001-kexec-fs2dt-fix-endianess-conversion.patch' (upstream)
- Rename aarch64 patch to 'kexec-tools-enable-aarch64.patch' and rebase to
version from Linaro git.
- Add 'kexec-tools-enable-aarch64-fixup.patch' to solve arm libfdt breakage
with Linaro patch.
- Enable ppc64le
- Refresh patches for context.
- Add following patches (pending upstream):
'kexec-tools-i386-bzimage_efi.patch' to fix i386 breakage.
'kexec-tools-xen-e820-redefinition.patch' to fix xen/820 breakage.
- add 0001-kexec-fs2dt-fix-endianess-conversion.patch:
* fix ppc64 and arm
- refresh device-tree-buffer-overflows.patch with the version
that went upstream
- enable build for arm / aarch64
- add kexec-aarch64.patch
- add device-tree-buffer-overflows.patch
- Update to version 2.0.4
- Drop patches (mainline):
kexec-tools-fix-makefile-binaries.patch (aaedd532)
kexec-tools-fix-strncat.patch (d5efc524)
kexec-tools-no-vga-output.patch (f1facd4b)
- xen 4.4 is exclusive to 64bit archs, so don't require it
- Remove double-packaging of /etc/init.d/kexec-tools, fixing build
errors on some targets, e.g. SLE-11.
- Added url as source.
Please see http://en.opensuse.org/SourceUrls
- Update to kexec 2.0.3. Drop unneeded patches.
- Fix xen cpuid() inline asm to not clobber stack's red zone
See xen-unstable changeset 24344:72f4e4cb7440
- Balloon up in a Xen PVonHVM guest before kexec (bnc#694863)
- Update xen_present check for xenfs in pv_ops kernel (bnc#694863)
- Change xen_present hv check (bnc#658413)
- place binaries into /usr tree (UsrMerge project)
- add automake as buildrequire to avoid implicit dependency
- fixed strncat sizse argument on ppc
- fix build with gcc that doesn't understand --no-undefined
- Update to kexec-tools 2.0.2 (bug fix release). The complete
changelog can be viewed at

http://git.kernel.org/?p=utils/kernel/kexec/kexec-tools.git;a=shortlog;h=refs/tags/v2.0.2.
- Drop kexec-tools-increase-kernel-text-size.diff: Mainline.
- disable autoreconf to fix build
- drop obsolete patch ARM_kexec-zImage-arm_page_to_unistd.diff
- Add ExclusiveArch to specfile according to source capabilities
- Update to kexec-tools 2.0.1 (bug fix release).
- Drop following patches because they are upstream now (or the
problem is fixed otherwise upstream):
o kexec-tools-ia64-uncached-memory.diff
o kexec-tools-ia64-PA.diff
o kexec-tools-build-warnings.diff
o kexec-tools-ppc64-build-warnings.diff
o kexec-tools-ppc64-IBM-QS2x-blades.diff
o kexec-tools-ia64-kdump-PT_LOAD-order.diff
o kexec-tools-crash-memory-ranges-drconf.diff
o kexec-tools-add-usable-drconf-memory-node-to-device-tree.diff
o kexec-tools-get-details-dynamic-reconfiguration-memory-node.diff
o kexec-tools-get-details-dynamic-reconfiguration-memory-node.diff
o kexec-tools-device-tree-return.diff
o kexec-tools-ppc-check-flags.diff
o kexec-tools-spell.diff
o kexec-tools-proc-iomem-xen.diff
o kexec-tools-parse-iomem-single-warning.diff
o kexec-tools-exclude-gart.diff
o kexec-tools-ppc64-memory-ranges-dynamic.diff
o kexec-tools-ppc64-dynamic-fix-1.diff
o kexec-tools-ppc64-dynamic-fix-2.diff
o kexec-tools-ppc64-dynamic-fix-3.diff
o kexec-tools-ppc64-reinit.diff
- fix build on arm. kexec-zImage-arm needed s#asm/page.h#unistd.h#
- increase kernel text size to fix for 2.6.31 kernel (bnc#530240)
- disable as-needed to fix build

==== kget ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kgpg ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kgpg-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== khelpcenter5 ====
Version update (17.04.0 -> 17.04.1)
Subpackages: khelpcenter5-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Rename the translation catalog (avoid conflicts)

==== kholidays ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Remove GPL-licensed file

==== kidentitymanagement ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Simplify create folder

==== kimap ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kimap-lang libKF5IMAP5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kio-extras5 ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kio-extras5-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Add set_package_properties for Qt5WebEngineWidgets
* Rename almost all the translation template (conflicts)

==== kio_audiocd ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kio_audiocd-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kldap ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kldap-lang libKF5Ldap5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kleopatra ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kleopatra-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix selftest for gpgsm installation (kde#378772)

==== kmag ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kmahjongg ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kmahjongg-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kmail ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kmail-application-icons kmail-lang

- Add 0001-Add-missing-helper_p-include.patch: upstream patch
to fix building with Qt 5.6
- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Use a mCurrentCollection variable as discussed with david.
* Clean stylesheet when we select a valid folder
* Allow to add more file after --attach

==== kmail-account-wizard ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kmail-account-wizard-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kmailtransport ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Update license of the files to LGPLv2.1+
* Update license to LGPLv2.1+

==== kmbox ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kmime ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kmime-lang libKF5Mime5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kmines ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kmines-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kmousetool ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kompare ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kompare-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== konqueror ====
Version update (17.04.0 -> 17.04.1)
Subpackages: konqueror-plugins

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix build with Qt 5.9 (kde#377490)

==== konsole ====
Version update (17.04.0 -> 17.04.1)
Subpackages: konsole-lang konsole-part

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Add check for valid container (possible crash fix)
* Correct ANSI string terminator (kde#231405)

==== kontact ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kontact-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Take vertical scrollbar into account when calculating navbar width
* Fix the link to handbook on Kontact introduction screen
- Drop upstreamed patches:
* 0001-Take-vertical-scrollbar-into-account-when-calculatin.patch

==== kontactinterface ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== konversation ====
Version update (1.6.2 -> 1.7.2)
Subpackages: konversation-lang

- Specify minimum KF5 version for build requirements
- Remove no longer used/necessary sonnet-devel BuildRequires
- Change package summary: it's "by" KDE, not "for" KDE
- Update to 1.7.2:
* no code changes
* incomplete and badly maintained translations removed that were
accidentally included with the v1.7.1 release
- Update to 1.7.1:
* Fixed requesting the znc.in/server-time-iso capability from the server.
* Fixed SASL EXTERNAL authentication without an account name set in the
Identity settings.
* Fixed clicking on nickname links containing the ` character.
* Fixed the Highlight page in the Configure Konversation dialog
not enabling/disabling the Apply button correctly.
* Minor cleanups in application metadata setup code.
- No need to define _kf5_appstreamdir any more, it doesn't build on
42.1 anyway as it requires newer KDE Frameworks
- Update Qt build requirements to 5.5.0 or higher
- Update to 1.7:
* Two-finger scroll on the vertical channel list is now less sensitive.
* Fixed execution of bundled scripts showing an error about locating
translation files when running on a system without kde4-config installed.
* Fixed a bug in executable command line parsing for passed URLs.
* Fixed Konversation failing to start on Windows systems without D-Bus
(it would previously exit if it failed to initialize its D-Bus service).
* Ported from deprecated KDE Frameworks APIs to 5.24+ API
(v1.7 requires Frameworks 5.25 or higher).
* Improved support for CAP negotiation
* Output for CAP LS and CAP LIST is now shown in the server status view
* Added support for IRCv3 CAP MULTI-PREFIX
* Added support for IRCv3 CAP AWAY-NOTIFY
* Added support for IRCv3 CAP ACCOUNT-NOTIFY
* Added support for IRCv3 CAP EXTENDED-JOIN
* Added support for IRCv3 CAP USERHOST-IN-NAMES
* Added support for extended WHO
* Added support for server-time and message tags
* Added support for znc.in/server-time-iso, making buffer playback from ZNC
much nicer
* Added support for the SASL EXTERNAL authentication mechanism,
e.g. needed for using Tor with freenode.
* Redesigned search bar in chat views
* Added support for font zooming to chat views
* Improved bi-di text handling in chat views
* The --restart command line argument works again
* Fixed command line argument parsing when Konversation is already running
* Fixed tab completion not working when pressing tab after a full
existing nickname as prefix
* Fixed the topic editor not updating when the topic changes
* Fixed nickname links including the pipe character
* Fixed the Invite dialog not closing on OK
* Fixed angle bracket display in OSD message bubbles
* Fixes to core protocol handling, e.g. in prefix parsing
* Fixed crash on close when the nick menu has been shown
* Fixed crash on quit
* Fixed crash when closing views
* Fixed crash in DCC resume dialogs without a Retry button
* Fixed incorrect icon for the global away action
* Minor UI layout cleanups, e.g. in the Behavior -> Chat Window settings
page and fixes to tooltips
* Code cleanups, e.g. removal of unused settings and related code paths,
porting away from deprecated API, and more
* Overhauled and corrected handbook & refreshed handbook screenshots to
Frameworks 5 version
* Build fixes for Windows (MSVC compatibility and winsock linking)
* The Windows and Mac builds now have app icons
* Improved code portability by using different byte swapping routines
* Updated AppStream metadata
* Konversation now depends on Qt 5.5+ and KDE Frameworks 5.25+
- Drop fix-crash-on-quit.patch, fixed upstream
- Add upstream patch to fix crash on exit:
* fix-crash-on-quit.patch

==== kopete ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Prepare for 17.04.1

==== korganizer ====
Version update (17.04.0 -> 17.04.1)
Subpackages: korganizer-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kpat ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kpat-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* install manpage, else only translated manpages get installed and us poor
English speakers have no idea how to run kpat

==== kpimtextedit ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix license of the file
* Fix some clazy warninbg

==== kreversi ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kruler ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kruler-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== krusader ====
Version update (2.5.0 -> 2.6.0)
Subpackages: kio_iso

- Add org.kde.krusader.root-mode.desktop, it got removed in 2.6.0
- Add fix-build-with-gcc48.patch to fix build on Leap 42
- Update to 2.6.0
* FIXED: (kde#335993) save checksum does not work as expected
* FIXED: (kde#375639) Allow typing special characters (e.g. with
accent or acute) in search bar
* FIXED: (kde#328068) Send SIGINT before own input command to
embedded terminal
* FIXED: (kde#375135) segfault on viewing html files with Generic
viewer
* FIXED: (kde#269820) Fullscreen terminal emulator shows empty
window when terminal emulator was minimized
* FIXED: (kde#374813) Multi rename with KRename does not work
when selecting non-local files/folders (ftp, smb, virt, ...)
* FIXED: (kde#309300) Esc as the default shortcut of "Set Focus
to The Panel" is problematic for the embedded terminal
* FIXED: (kde#374175) wrong date format parsing using date filter
in search dialog
* FIXED: (kde#293370) After a file deletion old file name is
still shown in the status bar
* FIXED: (kde#374322) Visually indicated shortcut ALT+o not
working in copy/F5 and move/F6 KrDialog
* FIXED: (kde#374238) Handle left/right arrow key press in brief
view (previously filtered by search bar).
* FIXED: when dragged from list panel use correct drop action if
invoked with modifier keys
* FIXED: added save/restore or toolbar positions in mainwindow
* FIXED: (kde#372231) Added KDE's service actions again to
right-click popup menu
* ADDED: new undo action to job manager for undoing KIO job
operations
* FIXED: (kde#372067) Wrong path when showing non local files and
folders from search dialog in panel
* ADDED: job manager as replacement for queue manager. Part of
cleaning VFS
* FIXED: (kde#365105) Workaround for bug in KF5+QSystemTrayIcon
* ADDED: Reimplementation of "minimize to system tray" feature.
* FIXED: Krusader does not show the new file in a directory that
is a symbolic link until is not refresh directory
* FIXED: Wrong window position after restart in fluxbox
* FIXED: Error on opening file folder after clicking on any file
result of a remote search (FTP / smb)
* FIXED: Terminal opens in full window
* FIXED: copy location/path bar (feature request)
* FIXED: krusader cannot calculate size of remote directory (ftp
or sftp)
* FIXED: Some files with weird characters (non UTF) cause krusader
to miscalculate folder size
* FIXED: No way to focus fullscreen embedded terminal emulator.
* FIXED: Don't delete first letter in "new folder" dialog (F7)
* FIXED: Use Shift+Delete for delete or move selected files to
trash
* FIXED: Dialog "File" -> "Verify checksum" improvement
* FIXED: Option for show copy/move progress in dialog (not in
notifications)
* FIXED: Documents suddenly open as archives
* CHANGED: Avoiding root mode
* CHANGED: Duplicated tab should not be locked
* CHANGED: New PagePanel: do not refresh until panel becomes
visible
* CHANGED: Change suggested command for "edit as root" user
action to a more secure alternative
* CHANGED: Do not configure kdesu path and remove kdesudo support
again
* CHANGED: Panel: Do not select .. in a filtered view if there
are other entries
* CHANGED: Duplicate tab settings when duplicating tabs
* CHANGED: Some fixes and simpifying startup settings.
- Drop upstream patches:
* krusader-2.5.0-generate-manpage.patch
* 0001-Don-t-hardcode-appdata-location.patch
* Remove-non-archive-mimetypes-from-krarc-archive-mime-type-list.patch
* add-service-actions-to-right-click-popup-menu.patch
* Handle-arrow-key-press-in-brief-view.patch

==== kscd ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== ksudoku ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== ktnef ====
Version update (17.04.0 -> 17.04.1)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== ktp-common-internals ====
Version update (17.04.0 -> 17.04.1)
Subpackages: ktp-common-internals-lang ktp-icons

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== kwalletmanager5 ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kwalletmanager5-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libgravatar ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libkcddb ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libkcompactdisc ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix linking with ALSA

==== libkdcraw ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5KDcraw5 libkdcraw-devel

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libkdegames ====
Version update (17.04.0 -> 17.04.1)
Subpackages: kdegames-carddecks-default libkdegames-devel libkdegames-lang
libkf5kdegames6

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libkdepim ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix some clazy warning

==== libkexiv2 ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5KExiv2-15_0_0 libkexiv2-devel

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libkface ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5KFace10_0_0 libkface-devel

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libkgapi ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Prepare 5.5.1
* Auth: add URL bar and SSL indicator to the authentication page
* Auth: don't store cookies
* Auth: Adapt to changes in Google OAuth token retrieval process
* Use same variable as other lib. It's more easy to upgrade version
* Fix some clazy warning
- Drop upstreamed patches:
* adapt-to-changes-in-google-oauth.patch

==== libkgeomap ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5KGeoMap10_0_0 libkgeomap-devel

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libkipi ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5Kipi32_0_0 libkipi-data libkipi-devel

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libkleo ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix filtering for S/MIME certificates (kde#378755)
- Add patch to fix build with GCC7:
* fix-build-gcc7.patch

==== libkmahjongg ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5KMahjongglib5 libkmahjongg-devel libkmahjongg-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libkomparediff2 ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libksane ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5Sane5 libksane-devel libksane-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libksieve ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libksieve-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== libpsm2 ====
Subpackages: libpsm2-2 libpsm2-compat

- libpsm2-2 provides libpsm2 (bsc#1039855)

==== libsndfile ====
Subpackages: libsndfile-devel libsndfile1 libsndfile1-32bit

- Fix a memory leak at error path (bsc#1038856):
0003-src-flac.c-Fix-another-memory-leak.patch
- Fix FLAC buffer overflows (CVE-2017-8361 CVE-2017-8363
CVE-2017-8365 CVE-2017-8362 bsc#1036944 bsc#1036945 bsc#1036946
bsc#1036943):
0001-FLAC-Fix-a-buffer-read-overrun.patch
0002-src-flac.c-Fix-a-buffer-read-overflow.patch

==== mailcommon ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== mailimporter ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== marble ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libastro1 libmarblewidget-qt5-27 marble-data marble-devel
marble-doc marble-kde marble-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Fix installation folder for qm files in KDE Apps release settings
* Support also translated doc added in the KDE Application tarball
* let releaseme know to skip po install in it's builds, (used by KDE neon)
* Update update-version-number to include install/windows/marble-common.iss
* Add missing include of CMakeFindDependencyMacro
* Version bump to 0.27.1 (stable release)
* Support translation catalogs added in KDE Application release tarball
* Use windeployqt instead of manual Qt dependency hunting
* Update version number for latest stable release
* Move win/mac installation files to common dir. Split iss files.
* Use a Marble start menu folder, install website link
* Sync windows installer version
* Switch from NSIS to Inno Setup
* Fix MSVC compilation (fails with C2308, concatenating mismatched strings)
* No need for fabs (fixes MSVC compilation)
* Remove extra qualification

==== messagelib ====
Version update (17.04.0 -> 17.04.1)
Subpackages: messagelib-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Use base64 encoding for all non-text attachments (kde#95733)
* crypto unittests can't be run in parallel since they start/stop gpg-agent
* Don't break i18n
* Fix Bug 379066 - Bug in Grantlee template when viewing SMIME Msg: plain
HTML code is shown (kde#379066)
* Handle help:/ URLs through QDesktopServices
* [autotests] repair mailwebenginescripttest after my changes in 37b99257

==== mobipocket ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== okular ====
Version update (17.04.0 -> 17.04.1)
Subpackages: okular-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* Don't repeat work of KAboutData::setApplicationData(), set window icon
* Fix typo
* Drop unused DBusAddons

==== os-prober ====

- The wildcard test for ld.so is inaccurate, slow and sometimes hangs a
long time with grub2-mount. Disable it becuase it does quite opposite
it was intended to do, that is having an inital quick filter for non
linux partition to speed things up. (bsc#1008444)
* modified os-prober-linux-distro-avoid-expensive-ld-file-test.patch
* refresh os-prober-linux-distro-parse-os-release.patch
- Handle /etc/os-release symlink (bsc#997465)
* refresh os-prober-linux-distro-parse-os-release.patch
- Parse /etc/os-release for openSUSE Tumbleweed (bsc#997465)
* os-prober-linux-distro-parse-os-release.patch

==== osc ====
Version update (0.155.0 -> 0.158.0)

- 0.158.0
- cat/less/blame command: default to expand to stay in sync with checkout
- add support for highly experimental native appimage.yml support
- show package status when repository configuration is broken
- add '--blame' option to osc meta command
- try to autodetect local package when running 'osc build'
- comment requests in interactive mode
- fix github issue #236 (--no-cleanup not working)
- fix wipebinaries to prevent wiping of complete repository
- add '--build-opt' to osc build command
- fix requests codebase to fit old obs versions
- 0.157.2
- add compat code for older apis that do not support multibuild
- fix ssl.connection instantiation in case of old M2Crypto
- highly experimental support for appimage
- fix local service run for non-existent (server-side) package
- 0.157.1
- fix local build of kiwi images using obsrepositories://
- 0.157
- add unpublish command (requires OBS 2.8)
- add blame command (requires OBS 2.9)
- results: show multibuild results by default
- getbinaries: make .AppImage files executable
- support operation in checked out package for cat/less/blame
- add comment command
- improved build recipe selection
- added multibuild (-M) to commands:
buildlog, remotebuildlog, buildinfo, build, buildhistory, jobhistory,
rebuild, restartbuild/abortbuild, wipebinaries, getbinaries
- add checkconstraints command
- add workerinfo command
- 0.156.0
- highlight scheduled jobs with dispatch problems (due to constraints)
- allow to specify a log message in lock command
- Add '--wipe' option to osc chroot for deleting buildroots
- Add '--vm-memory' option to osc build
- add --multibuild to results command for showing all packages
of a multibuild config
- add --multibuild-package option to results command for showing
only one package of the multibuild config
- Install bash completion in the debian package
- 0.155.1
- fixed "osc add" of new package container

==== pimcommon ====
Version update (17.04.0 -> 17.04.1)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== postgresql95 ====
Version update (9.5.6 -> 9.5.7)

- Update to version 9.5.7:
* https://www.postgresql.org/docs/9.4/static/release-9-5-7.html
* CVE-2017-7486, bsc#1037624: Restrict visibility of
pg_user_mappings.umoptions, to protect passwords stored as
user mapping options.
!!! Manual action is needed to fix this in existing databases
!!! See upstream release notes for details.
* CVE-2017-7485, bsc#1038293: recognize PGREQUIRESSL variable
again.
* CVE-2017-7484, bsc#1037603: Prevent exposure of statistical
information via leaky operators.
* Obsoletes postgresql-9.5.6-fix-timezone-tests.patch
- Add "Requires: timezone" to Server Package (bsc#973660).
- Sync spec file with postgresql96.

==== postgresql96 ====
Version update (9.6.2 -> 9.6.3)

- Replace krb5-devel BuildRequires with pkgconfig(krb5): allow OBS
to deliver krb5-mini when applicable.
- Update to version 9.6.3:
* https://www.postgresql.org/docs/9.6/static/release-9-6-3.html
* CVE-2017-7486, bsc#1037624: Restrict visibility of
pg_user_mappings.umoptions, to protect passwords stored as
user mapping options.
!!! Manual action is needed to fix this in existing databases
!!! See upstream release notes for details.
* CVE-2017-7485, bsc#1038293: recognize PGREQUIRESSL variable
again.
* CVE-2017-7484, bsc#1037603: Prevent exposure of statistical
information via leaky operators.
* Obsoletes postgresql-9.6.2-fix-timezone-tests.patch
- Added "Requires: timezone" to Server Package (bsc#973660)
- Submit postgresql96 to SLE-12 (bsc#1038474, fate#321481).

==== postgresql96-libs ====
Version update (9.6.2 -> 9.6.3)
Subpackages: libecpg6 libpq5

- Replace krb5-devel BuildRequires with pkgconfig(krb5): allow OBS
to deliver krb5-mini when applicable.
- Update to version 9.6.3:
* https://www.postgresql.org/docs/9.6/static/release-9-6-3.html
* CVE-2017-7486, bsc#1037624: Restrict visibility of
pg_user_mappings.umoptions, to protect passwords stored as
user mapping options.
!!! Manual action is needed to fix this in existing databases
!!! See upstream release notes for details.
* CVE-2017-7485, bsc#1038293: recognize PGREQUIRESSL variable
again.
* CVE-2017-7484, bsc#1037603: Prevent exposure of statistical
information via leaky operators.
* Obsoletes postgresql-9.6.2-fix-timezone-tests.patch
- Added "Requires: timezone" to Server Package (bsc#973660)
- Submit postgresql96 to SLE-12 (bsc#1038474, fate#321481).

==== rp-pppoe ====
Version update (3.11 -> 3.12)

- Fix patches and script for version 3.12.
- dropped logger-path.diff
- Add net-tools support. net-tools-deprecated is no longer required.
- Update to version 3.12.
- Fix patch release-buildsystem.diff for 3.12 version.
- Add to Requires net-tools-deprecated package.
- Reordered patch positions.
- Formated all the variables in the spec-file to macro style.
- Use systemd instead of sysvinit; add pppoe-server.service
- Install fixed versions of rp-pppoe scripts for openSUSE > 11.4
most of fixes are about paths, because of /usr move
Added: pppoe-setup, ,pppoe-start, pppoe-connect, pppoe-status ,
pppoe-stop

==== spectacle ====
Version update (17.04.0 -> 17.04.1)
Subpackages: spectacle-lang

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== sweeper ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== syndication ====
Version update (17.04.0 -> 17.04.1)

- Update to 17.04.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.04.1.php
- Changes since 17.04.0:
* None

==== xf86-input-libinput ====
Version update (0.19.1 -> 0.25.1)

- Leap 42.3 merge
* boo#1039812
- Update to version 0.25.1
* Just one patch that's been sitting on master for a while now -
after a proximity event we immediately post a motion event.
This avoids the lines between the last known point before
proximity out and the new point.
- Update to version 0.25.0
* fixing two bugs with tablet pad modes on kernel 4.9 and later.
First, we never successfully opened the sysfs files representing
the LEDs, so they didn't update as the kernel would change them.
Second, had we opened them correctly we would've likely crashed
as the property update would have been sent from within the
input thread. Both issues are fixed now, together with a fix
for a test case failure for ppc64/aarch64.
- Update to version 0.24.0:
+ Tablets now support a configurable pressure curve.
+ Tablets now have a 'area ratio' setting to be able to match the
tablet aspect ratio with that of the screen.
+ The mouse wheel's click angle now (correctly) affects how fast
the scroll wheel triggers. In particular, if you have a wheel
with a very small click angle, it won't trigger for every click
anymore.
- Update to version 0.23.0:
A couple of cleanups, no big features added. Most of this was in
the property handling code. The most visible fix is that we now
handle addition of initially disabled devices correctly, i.e.
when a device is plugged in while the server is VT-switched
away. In the non-logind case this previously caused a segfault.
Our tablet support is good enough that we now match against
tablets too. The xorg.conf.d sort order means that if you have
the wacom driver installed, that driver will take over.
Otherwise, libinput will handle tablets.
- Update to version 0.22.0:
+ Fix the new tap button map option handling.
+ When the first device was removed (and subsequently freed by
the server) the input thread would continue to call that
device's read_input() func, eventually causing a crash.
- Drop
U_xf86-input-libinput-Fix_tap_button_map_option_handling.patch:
Fixed upstream.
- Add upstream patch to fix touchpad when lmr option is used:
U_xf86-input-libinput-Fix_tap_button_map_option_handling.patch.
Fixes fdo#97989.
- Update to version 0.20.0:
+ Most important fix is the use of input_lock() instead of the
old SIGIO stuff to handle the input thread in server 1.19.
+ This version now supports tablet pads and exposes properties
for changing the tap button mapping and the rotation.
- Rebase n_enable-tapping.patch.
- Pass --with-xorg-conf-dir to configure and modify spec following
upstream changes.

==== yast2-installation ====
Version update (3.2.39 -> 3.2.40)

- Fixed push button label ("Configure Online Repositories")
(bsc#1039988)
- 3.2.40

==== yast2-storage ====
Version update (3.2.11 -> 3.2.12)

- During installation, mount efivarfs in /mnt/sys/firmware/efivars
if present in inst-sys (bsc#1037495)
- 3.2.12


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages