Mailinglist Archive: opensuse-factory (520 mails)

< Previous Next >
[opensuse-factory] Leap 42.3 Build 0251 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=42.3&build=0251&groupid=28
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Distribution&query_format=advanced&resolution=---&version=Leap%2042.3

When you reply to discuss some issues, make sure to change the subject.
Please use the test plan at
https://docs.google.com/spreadsheets/d/1AGKijKpKiJCB616-bHVoNQuhWHpQLHPWCb3m1p6gXPc/edit#gid=298435253
to record your testing efforts and use bugzilla to report bugs.

Packages changed:
MozillaThunderbird (52.1.0 -> 52.1.1)
alsa (1.1.3 -> 1.1.4)
alsa-plugins (1.1.1 -> 1.1.4)
alsa-tools
alsa-utils (1.1.2 -> 1.1.4)
autoyast2 (3.2.14 -> 3.2.15)
git (2.12.2 -> 2.13.0)
kcmutils
kdbg (2.5.5 -> 2.9.0)
kdump (0.8.15 -> 0.8.16)
kguiaddons
lightdm
yast2 (3.2.28 -> 3.2.31)
yast2-installation (3.2.38 -> 3.2.39)
yast2-network (3.2.24 -> 3.2.26)

=== Details ===

==== MozillaThunderbird ====
Version update (52.1.0 -> 52.1.1)
Subpackages: MozillaThunderbird-translations-common

- update to Thunderbird 52.1.1
* fixed crash when compacting IMAP folder (boo#1038753)
* Some attachments could not be opened or saved if the message
body is empty
* Unable to load full message via POP if message was downloaded
partially (or only headers) before
* Large attachments may not be shown or saved correctly if the
message is stored in an IMAP folder which is not synchronized
for offline use

==== alsa ====
Version update (1.1.3 -> 1.1.4)
Subpackages: alsa-devel libasound2 libasound2-32bit

- Update to alsa-lib 1.1.4: including most of previous fixes,
in addition to topology API updates
- Upstream fix for building with old glibc:
0001-build-Define-__USE_UNIX98-for-old-glibc.patch
- Obsoleted patches:
0001-ucm-Add-ATTRIBUTE_UNUSED-for-unused-parameters-of-ex.patch
0002-ucm-parser-needs-limits.h.patch
0003-pcm-direct-allow-users-to-configure-different-period.patch
0004-pcm-dshare-enable-silence.patch
0005-pcm-rate-fix-the-hw_ptr-update-until-the-boundary-av.patch
0006-plugin-dynamically-update-avail_min-on-slave.patch
0007-rate-dynamic-update-avail_min-on-slave.patch
0008-topology-fix-unused-const-variable-warning.patch
0009-seq-improve-documentation-about-new-get-pid-card-fun.patch
0010-pcm-direct-returning-semop-error-code-for-semaphore-.patch
0011-pcm-direct-Fix-for-sync-issue-on-xrun-recover.patch
0012-pcm-direct-check-state-before-enter-poll-on-timer.patch
0013-pcm-direct-don-t-return-bogus-buffer-levels-in-xrun-.patch
0014-conf-ucm-broxton-add-broxton-rt298-conf-files.patch
0015-pcm-direct-Fix-deadlock-in-poll_descriptors.patch
0016-ucm-Assure-the-user-input-card-name-not-to-exceed-ma.patch
0017-ucm-Load-device-specific-configuration-file-based-on.patch
0018-ucm-Add-command-get-_file-to-get-the-config-file-nam.patch
0019-topology-Fix-incorrect-license-in-source-comments.patch
0020-conf-cards-add-support-for-pistachio-card.patch
0021-pcm-multi-Drop-the-fixed-slave_map-in-snd_pcm_multi_.patch
0022-conf-Add-card-config-for-Intel-HDMI-DP-LPE-audio.patch
0023-pcm-Avoid-lock-for-snd_pcm_nonblock.patch
0024-pcm-Disable-locking-in-async-mode.patch
0025-pcm-dmix-Allow-disabling-x86-optimizations.patch
0026-pcm-dmix_rewind-corrupts-application-pointer-fix.patch
0027-pcm-direct-fix-race-on-clearing-timer-events.patch
0028-pcm-file-Enable-file-writing-for-capture-path.patch
0029-pcm-status-dump-fix-timestamp-formatting.patch
0030-pcm-extplug-refinement-of-masks-in-extplug.patch
0031-pcm-rate-Add-capability-to-pass-configuration-node-t.patch
0032-Drop-ppc64-specific-workaround-for-versioned-symbols.patch
0033-pcm_plugin-unify-the-snd_pcm_mmap_begin-result-value.patch
0034-always-handle-return-value-from-snd_config_get_id-co.patch
0035-pcm-file-plugin-handle-snd_pcm_mmap_begin-error-path.patch
0036-topology-coverity-remove-dead-code.patch
0037-ucm-parser-fix-possible-string-overflow-in-uc_mgr_im.patch
0038-dmix-plugin-fix-drain-for-nonblock-mode.patch
0039-dmix-plugin-drain-quickfix-for-the-previous-patch.patch
0040-rawmidi-virtual-fix-reading-into-a-small-buffer.patch
0041-conf-cards-add-VC4-HDMI-card.patch
0042-pcm-plug-save-converter-config.patch
0043-pcm-file-delegate-htimestamping-to-slave-instead-of-.patch
0096-conf-Remove-dmix.direct_memory_access-setup.patch
0097-pcm-dmix-Disable-var_periodsize-as-default.patch

==== alsa-plugins ====
Version update (1.1.1 -> 1.1.4)
Subpackages: alsa-plugins-32bit alsa-plugins-pulse alsa-plugins-pulse-32bit

- Update to alsa-plugins 1.1.4:
* extend configure script to disable more stuff
* including previous fix for libavcodec
- Obsoleted patch:
0001-configure-Fix-detection-of-avcodec.h.patches

==== alsa-tools ====

- Really bump the version number to 1.1.3 (sorry, forgot to change
in Version tag).
- Update to alsa-tools-1.1.3:
just including the previous gcc6 fix.
- Dropped patch: 0001-gcc6-narrowing-error.patch
- Upstream fix for gcc6 compile error on ppc:
0001-gcc6-narrowing-error.patch

==== alsa-utils ====
Version update (1.1.2 -> 1.1.4)

- Update to alsa-utils 1.1.4:
* alsactl: Remove standard output definition in systemd unit
* alsa-info: provide more DMI information
* alsa-info: add ACPI device status
* amidi: optarg might be NULL, fix 't' argument parsing
* aplay: Introduce and use xwrite helper
- Really bump the version number to 1.1.3 (sorry, forgot to change
in Version tag).
- Update to alsa-utils 1.1.3:
* a couple of amidi fixes
* a few alsabat extensions
* alsaloop cpu hog fix,
* a fix for suspend/resume with aplay
* fix chmap selection in speaker-test WAV mode
* alsaucm man pages,
* fix potential NULL dereferences in alsactl daemon mode
- Add python-docutils to build dependency (for rst2man)
- Fix missing alsaucm man page file in the 1.1.3 tarball

==== autoyast2 ====
Version update (3.2.14 -> 3.2.15)
Subpackages: autoyast2-installation

- clone system: Checking if snapshots have been enabled.
(bnc#1039268)
- 3.2.15

==== git ====
Version update (2.12.2 -> 2.13.0)
Subpackages: git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk

- git 2.13.0:
* empty string as a pathspec element for 'everything matches'
is still warned, for future removal.
* deprecated argument order "git merge <msg> HEAD <commit>..."
was removed
* default location "~/.git-credential-cache/socket" for the
socket used to communicate with the credential-cache daemon
moved to "~/.cache/git/credential/socket".
* now avoid blindly falling back to ".git" when the setup
sequence indicated otherwise
* many workflow features, improvements and bug fixes
- git 2.12.3:
* CVE-2017-8386: On a server running git-shell as login shell to
restrict user to git commands, remote users may have been able
to have git service programs spawn an interactive pager
and thus escape the shell restrictions. (bsc#1038395)

==== kcmutils ====
Subpackages: kcmutils-devel libKF5KCMUtils5 libKF5KCMUtils5-lang

- Don't apply kguiaddons-use-susehelp.patch on TW and Leap 42 >= 42.3

==== kdbg ====
Version update (2.5.5 -> 2.9.0)
Subpackages: kdbg-doc kdbg-lang

- Update to 2.9.0:
* Enhancements
- A brand new application icon.
- There is now a command to detach from a program being debugged.
Thanks to Daniel Black.
- Pointing on a variable shows a value in a popup in more cases.
Thanks to Max Tomilov.
- C++11 keywords are highlighted. Thanks to Michael Hansen.
* Bug fixes
- Line breaks of status bar messages produced by GDB are now trimmed
to avoid that the text is only visible partially. Fix by Gilles Allard.
- (Action and application) icons are installed in an application neutral
location because the launcher menu of modern KDE desktops does not show
the icon otherwise.
- Fixed a typo in the pretty-printer of std::vector<>.
- Drop susepatches.diff, applied upstream
- Revert kde4_runtime_requires change
- Expand macro kde4_runtime_requires only when its available
to fix quilt setup
- Update to 2.5.6:
* A popup shows the complete value of variables.
* The values printed by GDB for uninitialized references and
pointer-to-member variables no longer truncate the variable list.
* A few more C++ keywords are now highlighted.
* The CMakeLists.txt file was adjusted for newer cmake.
- Removed fix-build-with-cmake-3_4_3.diff, it's no longer necessary

==== kdump ====
Version update (0.8.15 -> 0.8.16)

- kdump-x86_64-kexec-file-syscall.patch: add -s on x86_64 for
signature verification of kernel. (fate#315018, bsc#884453)
- kdump-bind-mount-sysroot.patch: Convert sysroot to a bind mount
in kdump initrd (bsc#976864).
- kdump-pre-generate-mount-units.patch: Pre-generate kdump mount
units (bsc#942895).
- kdump-always-pass-kernelver-to-dracut.patch: Always pass kernel
version to dracut (bsc#900418).
- kdump-no-xen-secondary-kernel.patch: Avoid Xenlinux (aka
traditional, Xenified or SUSE) kernels as kdump kernel
(bsc#900418, bsc#974270).
- kdump-KDUMP_SSH_IDENTITY.patch: Add KDUMP_SSH_IDENTITY config
option (FATE#321583).
- kdump-KDUMP_SSH_IDENTITY-cfg.patch: Add KDUMP_SSH_IDENTITY to the
config file template (FATE#321583).
- Don't require insserv if we use systemd

==== kguiaddons ====
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Don't apply kguiaddons-use-susehelp.patch on TW and Leap 42 >= 42.3

==== lightdm ====
Subpackages: liblightdm-gobject-1-0 lightdm-lang

- Add patch to support new autologin mechanism needed for the
role-based desktop selection (boo#1030873):
* ignore-known-symlink-sessions.patch
- Use "default" instead of "twm" as default session

==== yast2 ====
Version update (3.2.28 -> 3.2.31)

- Added CWM::Table (boo#1039901)
- 3.2.31
- Translation fix: Ruby gettext cannot extract translatable texts
from interpolated strings (bsc#1038077)
- 3.2.30
- Added cwm/rspec with shared_examples for CWM::AbstractWidget
and its children (boo#1039302)
- 3.2.29

==== yast2-installation ====
Version update (3.2.38 -> 3.2.39)

- Don't crash if the regurl provided by linuxrc is invalid using
the one provided by the control file as fallback (bsc#1035908).
- 3.2.39

==== yast2-network ====
Version update (3.2.24 -> 3.2.26)

- bnc#1038521
- do not raise an internal error during installation when
multiple static device and hostname configurations were
provided
- 3.2.26
- bsc#1035908
- Moved inst_install_inf client to yast2-installation.
- 3.2.25


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages