Mailinglist Archive: opensuse-factory (807 mails)

< Previous Next >
Re: [opensuse-factory] Session switching not possible - getty-service not activated
  • From: Daniel Morris <danielm@xxxxxxxxxxxxxxx>
  • Date: Tue, 7 Feb 2017 14:00:22 +0000
  • Message-id: <20170207135859.u2ryuamap2dcmro3@chunk>
On Tue, Feb 07, 2017 at 12:14:02AM +0100, Matthias Kurz wrote:
Hey,

after upgrading to TW snapshot 20170131 it is not possible to switch between
user accounts in KDE Plasma anymore. When I try to change the user account,
the "New Session" plus-icon appears, but nothing happens when I click the
"switch" button.

I see the same, it certainly worked fine a few weeks ago. Also I thought
Ctrl-Alt-F8 similarly spawned a whole new graphical login session before.
Did the plus-icon have a list of alternate users to pick from prior to
hitting the "switch" button?


A guy from the german openSUSE Mailinglist asked me to check if the
getty-service is running. This service is not activated and if try to
activate it, the following message is displayed: "Writing the configuration
failed: getty@ can not be enabled. Failed to get properties: Unit name
getty@ .service is missing the instance name"

Can anyone confirm this?

'systemctl status getty.target getty@tty1.service' were active for me,
getty@tty3.service & getty@tty7.service were "Inactive (dead)", but
curiously the process of asking the status caused tty3 (but not tty7) to
start. I thought if you have getty@tty1.service active then a Virtual
Terminal will be attached to it and then your login manager will take
it from them once kde starts.

Daniel
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References