Mailinglist Archive: opensuse-factory (807 mails)

< Previous Next >
Re: [opensuse-factory] upscaled/blurry icons in libreoffice 5.3


Am 2017-02-03 um 10:36 schrieb Dominique Leuenberger / DimStar:
On Fri, 2017-02-03 at 10:22 +0100, Rainer Klier wrote:


currently i reverted back to libreoffice 5.2.3.3.
icons are fine in this version.

By testing LO from the LO/Factory repo you went ahead and tested what
will be submitted (or actually, IS submitted) to Tumbleweed - such
tests are very valuable.

ok, then i did nothing wrong, but the opposite. ;-)

Even though we test the distro using openQA, there is only a limited
set of tests possible. It's mainly virtualized, there is no HiDPI

yes, i have a HiDPI environment, i think.
this week, after also updating firefox to 51.0.1, i also ran into the issue about new GTK3 based firefox does not work correctly on iDPI environments.
i had to workaround this as felix miata answered in thread "Re: [opensuse-factory][UI regression] switch Firefox to Gtk3 for Tumbleweed (was: New Tumbleweed snaps...)"

the workaround was to create a .Xdefaults/.Xresources file in my home dir, which contains a line like this:
Xft.dpi: 130

i found the used DPI from my /var/log/Xorg.0.log
now the firefox problem is solved.

If you can give some more info about the environment you run
(KDE/GNOME/XFCE/LXDE), the hardware used, eventual visual config
changes (used icon theme for example comes to mind; check the possible
icon themes inside LO as well) others might try to compare as well. And
as far as I know there is also a bug filed for something alike this
already (likely by you!?)

no, not by me.
i already searched bugzilla, but didn't find anything.
maybe i searched thw wrong way.


i can give you every info i know:
software:
tumbleweed x86_64
KDE plasma 5.9.0
KDE frameworks 5.30.0
QT 5.7.1
kernel 4.9.7

hardware:
notebook: ASUSTeK COMPUTER INC. G750JW/G750JW, BIOS G750JW.208
Intel(R) Core(TM) i7-4700HQ CPU @ 2.40GHz
24 GiB memory
nvidia gtx 765m gfx card
latest proprietary nvidia driver 378.09


these are the currently installed libreoffice packages:
libreoffice-5.2.3.3-2.5.x86_64
libreoffice-math-5.2.3.3-2.5.x86_64
libreoffice-writer-5.2.3.3-2.5.x86_64
libreoffice-share-linker-1-7.4.noarch
libreoffice-filters-optional-5.2.3.3-2.5.x86_64
libreoffice-icon-theme-tango-5.2.3.3-2.5.noarch
libreoffice-gnome-5.2.3.3-2.5.x86_64
libreoffice-draw-5.2.3.3-2.5.x86_64
libreoffice-calc-extensions-5.2.3.3-2.5.x86_64
libreoffice-pyuno-5.2.3.3-2.5.x86_64
libreoffice-impress-5.2.3.3-2.5.x86_64
libreoffice-icon-theme-oxygen-5.2.3.3-2.5.noarch
libreoffice-officebean-5.2.3.3-2.5.x86_64
libreoffice-icon-theme-breeze-5.2.3.3-2.5.noarch
libreoffice-writer-extensions-5.2.3.3-2.5.x86_64
libreoffice-base-5.2.3.3-2.5.x86_64
libreoffice-base-drivers-mysql-5.2.3.3-2.5.x86_64
libreoffice-mailmerge-5.2.3.3-2.5.x86_64
libreoffice-icon-theme-sifr-5.2.3.3-2.5.noarch
libreoffice-calc-5.2.3.3-2.5.x86_64
libreoffice-icon-theme-galaxy-5.2.3.3-2.5.noarch
libreoffice-kde4-5.2.3.3-2.5.x86_64
libreoffice-branding-upstream-5.2.3.3-2.5.noarch
libreoffice-gtk3-5.2.3.3-2.5.x86_64
libreoffice-icon-theme-hicontrast-5.2.3.3-2.5.noarch
libreoffice-l10n-en-5.2.3.3-2.5.noarch
libreoffice-l10n-de-5.2.3.3-2.5.noarch

i have a /etc/profile.d/libreoffice.sh with the following content:
export SAL_USE_VCLPLUGIN=kde4

but changing or removing the SAL_USE_VCLPLUGIN env-variable didn't help in any way.
also changing the icontheme inside LO didn't help.
currently i use the breeze icon theme.
in KDE i also use the breeze icons.

and with LO 5.2.3.3 everything is ok.

--


Best Regards | Freundliche Grüße | Cordialement | Cordiali Saluti |
Atenciosamente | Saludos Cordiales

*DI Rainer Klier*

Research & Development, DevOps

namirialLogo

_________________________________________________________



Namirial GmbH

Phone: +43 7229 88 0 60 - 758 | Mobile: +43 664 610 17 06

Haiderstraße 23 | 4052 Ansfelden | Austria

Website: https://www.xyzmo.com/

Support: https://www.xyzmo.com/contact/support



The sender of this email disclaims any intent to be bound hereby, except
where the sender clearly and explicitly provides otherwise.



namirialAd

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >