Mailinglist Archive: opensuse-factory (807 mails)

< Previous Next >
Re: [opensuse-factory] ANNOUNCE: transactional updates for Tumbleweed
On Tue, Jan 31, Martin Wilck wrote:

From a practical perspective - is there a list of RPMs that are known
be (non-)compliant with this tool (in the sense that trying to update
thre system with "transational-update" will (not) break these RPMS), or
is it up to users to find out?

openSUSE Tumbleweed has far too many RPMs as it would be possible
for me to verify, which will work and which not.
A quick way to check if the RPMs you have installed are fine from
a package list view: if the RPMs don't install anything into subvolumes,
they are fine. If they install something into subvolumes, they are not.
Additional you have to verify the pre/post install sections, what they
are doing and if they access data in subvolumes during upgrade. This
will fail.

Likewise, as the tool seems to make certain assumptions about the
subvolume structure of the root FS, is there a set of "minimum
requirements" for the way the system is set up?

As written, you need a recent installation of openSUSE/SLE with
btrfs and snapshots enabled. The assuption the script makes it,
that snapshots and rollback with btrfs on your system works.
Nothing more. If you include /opt or /usr/local into your snapshot,
you need to adjust the script (or send me a patch to autodetect this :) ).
But that should be all.

Thorsten

--
Thorsten Kukuk, Distinguished Engineer, Senior Architect SLES & CaaSP
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
GF: Felix Imendoerffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nuernberg)
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages