Mailinglist Archive: opensuse-factory (458 mails)

< Previous Next >
Re: [opensuse-factory] Re: KDE 4.12.2 is now in Tumbleweed
* Greg KH <gregkh@xxxxxxxxx> [02-06-14 14:56]:
On Thu, Feb 06, 2014 at 08:42:15PM +0100, Achim Gratz wrote:
Greg KH writes:
I can't duplicate this here, how are you updating? You have to use:
zypper dup
to use Tumbleweed, with no priority differences for any repo or
anything else odd.

How are you updating?

After another reboot and temporarily removing the locks again: zypper
dup keeps the current installation, but zypper patch would do the
rollback to KDE 4.11.5 if I let it. Locking the patches prevents this
from happening and both dup and patch agree that they don't need to do
anything.

Don't mess with patches, just do 'zypper dup' and make all your repos
the same level and all should be fine.

Tumbleweed is not "tricky", don't try to make it harder than it really
is :)

No, it is not "tricky", but some of the manipulations make the use
somewhat tricky. You just moved 4.12 into Tumbleweed standard as
4.12.2-2.1 or greater in a few instances, but the last last version in
Tumbleweed Testing was 4.12.2-4.1 so "zypper dup" wants to downgrade 143
pkgs on my box to 4.12.2-1.

So anyone who was using Tumbelweed_Testing should pay particular attention
to the actions "zypper dup" propose until Tumbleweed_standard has caught
up. I tend to revert to "zypper up" during these times.

ps: the locks do me *no* good.
--
(paka)Patrick Shanahan Plainfield, Indiana, USA @ptilopteri
http://en.opensuse.org openSUSE Community Member facebook/ptilopteri
http://wahoo.no-ip.org Photo Album: http://wahoo.no-ip.org/gallery2
Registered Linux User #207535 @ http://linuxcounter.net
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >