Mailinglist Archive: opensuse-factory (1029 mails)

< Previous Next >
Re: [opensuse-factory] USB installation instrucctions issues.
just verified this, and the usb key is a fat device with the help of
these pendrivelinux guys or some software currently called or named
"Universal-USB-Installer-1.9.4.7", and this creates some isolinux
and/or syslinux folders on the top rootlevel of the fat formatted usb
devices and then puts all sorts of configs (depending on which distro
and what kind of linux and supported system it is dealing with) and
then the usb device or disk is being made bootable and the actual
content files in this case the ones from inside the tails .iso are
extracted onto this usb disk device and then everything works fine.

at least for tails it works this way, your milage may vary and results
may differ if Universal-USB-Installer-1.9.4.7 is working on the other
near infinite number of distros supposedly being supported by it.

sample contents of disk toplevel:
xxxx.xx.xx 00:14 <DIR> .disk
xxxx.xx.xx 00:14 <DIR> live
xxxx.xx.xx 00:55 49.070 Uni-USB-Installer-Copying.txt
xxxx.xx.xx 00:55 17.888 Uni-USB-Installer-Readme.txt
xxxx.xx.xx 00:42 18.092 license.txt
xxxx.xx.xx 00:02 <DIR> syslinux
xxxx.xx.xx 00:24 <DIR> uui
xxxx.xx.xx 00:14 <DIR> isolinux
3 File(s) 85.050 bytes

give it a try

On Mon, Nov 18, 2013 at 11:59 PM, cagsm <cumandgets0mem00f@xxxxxxxxx> wrote:
isnt there some project guys who are methinks with these pendrivelinux
website or stuff who offer their tiny installer/handler for a great
number of distros, amongst them also suse methinks but i know for sure
for example linux based tails (tor) distro. that pendrivelinux
installer stack extracts the files from inside the tails .iso file
(with 7zip commandline) and then puts it on a
fat(fat12/16/32/whatever) usb disk or usb stick or usb key even and
then adds some isolinux binary and config files and folders and some
bootloader and bootsector onto this fat usb device and then all is
running happily and tails tor distro can boot up and you can for
example bootstrap into tor or upgrade some other tails usb stick with
the more recent release.

isolinux hybridlinux and other buzzwords come to my mind.

On Mon, Nov 18, 2013 at 11:53 PM, Bernhard Voelker
<mail@xxxxxxxxxxxxxxxxxxx> wrote:
On 11/18/2013 11:43 PM, Carlos E. R. wrote:
On 2013-11-18 23:27, Bernhard Voelker wrote:
IIRC that was the "short read" issue, right?

No, not that one. The starting point was some new user asking for help
on the forums about how to create the usb stick, using another Linux
distro (thus, no Bugzillas here). The dd command failed, writeimage
also failed, unet??? also failed. Googling or asking elsewhere, it was
advised to use a plain "cp" or "cat" to create the image, and this
finally worked. Some other people corroborated that it worked.

Then I started a thread on the mail list asking how was it possible
that "cp" worked. It was a long thread, which concluded, IIRC, that
"cp" was also a valid command to use in order to create the image. We
talked about adding this new information to the wiki, and I finally
added it, and Rajko validated it. Some other incorrect advice was removed.

Thanks for the summary.
However, I cannot imagine a case for copying the content of a single file
(or device) with "cp" which would not work with "dd" (plus the correct
options).
Would you like to shed some light on this (and dig in the archives),
or should we draw the curtain over this case?

Have a nice day,
Berny
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups