Mailinglist Archive: opensuse-factory (564 mails)

< Previous Next >
Re: [opensuse-factory] firstboot and systemd
Le vendredi 02 décembre 2011 à 10:23 +0100, Frederic Crozat a écrit :
Le jeudi 01 décembre 2011 à 15:27 -0500, Robert Schweikert a écrit :
Hi,

This is not directly factory related, but really a systemd question and
a difference w.r.t. behavior after firstboot action.

I have a script that after collecting some data through a YaST module at
first boot sets up a few things and then adds a service to the init
process (insserv < 12.1, systemctl enable >= 12.1).

The problem now is that prior to 12.1 after firstboot was completed and
I had added the services, these services were started by init. However,
in 12.1 with systemd the services do no longer get started after
firstboot is complete. If I insert an explicit 'systemctl start ....'
into the script that enables the service then things hang as the service
wants multi user mode and during first boot we are still in single user
mode. Therefore I trigger a deadlock, not very pleseant when one wants
the system to actually do something "useful".

Question now is, how do I manage this with systemd such that the service
is actually started after firstboot is complete and multiuser mode is
entered?

Not tested as all, but I'd use something like :

After=YaST-Firstboot.service multi-user.target
RequiresOverridable=YaST-Firstboot.service

My bad, Use
Requisite=YaST-Firstboot.service
not RequiresOverridable=

--
Frederic Crozat <fcrozat@xxxxxxxx>
SUSE

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >