Mailinglist Archive: opensuse-factory (1176 mails)

< Previous Next >
Re: [opensuse-factory] in Milestone 3 missing in Milestone 5 - libpulse updates
On 01/09/11 21:16, Sid Boyce wrote:
On 01/09/11 16:01, Sid Boyce wrote:
On 01/09/11 08:42, Vincent Untz wrote:
Le jeudi 01 septembre 2011, à 03:19 +0100, Sid Boyce a écrit :
Milestone 3
-----------------
sepulot:~ # rpm -qf /usr/lib64/libpulse-browse*
libpulse-devel-0.9.23-1.3.x86_64
libpulse-browse0-0.9.23-1.3.x86_64
libpulse-browse0-0.9.23-1.3.x86_64

# cat /etc/SuSE-release
openSUSE 12.1 Milestone 3 (x86_64)
VERSION = 12.1
CODENAME = Asparagus

Milestone 5
-----------------
# zypper in padevchooser
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libpulse-browse.so.0()(64bit) needed by
padevchooser-0.9.4-147.3.x86_64
Solution 1: do not install padevchooser-0.9.4-147.3.x86_64
Solution 2: break padevchooser by ignoring some of its dependencies
It would certainly help to write sentences in your mail to help people
decrypt your question/issue :-)

It's likely that padevchooser either needs to be updated to a new
version or, if the code is dead upstream (I think it is), removed.

Cheers,

Vincent

I've been told that sometimes a picture tells a thousand words.
What I wrote was as I had just discovered whilst trying to get padevchooser installed to alter some settings I had made to enable network audio some days ago at Milestone 3. This is needed to see if these settings are now the problem why a particular application reports hw:0 busy after upgrading to Milestone 5.

Looking further today at the problem.
All the uplevel pulseaudio packages are in the factory oss but they won't upgrade - zypper, satsolver-tools are all at the latest levels checking against http://download.opensuse.org/factory/repo/oss/suse/x86_64/
zypper clean -a
zypper ref
The above 2 commands run.
# cat /etc/zypp/repos.d/openSUSE:Factory.repo
[openSUSE_Factory]
name=openSUSE Factory
enabled=1
autorefresh=1
baseurl=http://download.opensuse.org/factory/repo/oss
type=yast2
gpgcheck=1
keeppackages=0

# zypper up -t pattern pulseaudio*
Loading repository data...
Reading installed packages...
'pulseaudio-0.9.23-1.3.x86_64.rpm' not found in package names. Trying capabilities.
No provider of 'pattern:pulseaudio-0.9.23-1.3.x86_64.rpm' found.
'pulseaudio-utils-0.9.23-1.3.x86_64.rpm' not found in package names. Trying capabilities.
No provider of 'pattern:pulseaudio-utils-0.9.23-1.3.x86_64.rpm' found.
Resolving package dependencies...

Nothing to do.

The Milestone 3 box is at 0.9.23-1.3 and the Milestone 5 boxes are at 0.9.22-1.1.
# zypper up -t package pulseaudio
Loading repository data...
Reading installed packages...
No update candidate for 'pulseaudio-0.99.2-1.1.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.

Hope this explains more clearly the problem.
Regards
Sid.

I did "zypper rm pulseaudio"
slipstream:/usr/src # zypper in alsa-plugins-pulse paprefs paprefs-lang pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-jack pulseaudio-module-lirc pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
alsa-plugins-pulse paprefs paprefs-lang pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-jack pulseaudio-module-lirc pulseaudio-module-x11 pulseaudio-module-zeroconf
pulseaudio-utils

The following recommended packages were automatically selected:
alsa-plugins-pulse paprefs-lang

The following packages are recommended, but will not be installed:
bundle-lang-common-ar bundle-lang-gnome-extras-ar

12 new packages to install.

Installing: pulseaudio-utils-0.99.2-1.1 [done]
Installing: pulseaudio-module-zeroconf-0.99.2-1.1 [done]
Installing: pulseaudio-module-lirc-0.99.2-1.1 [done]
Installing: pulseaudio-module-jack-0.99.2-1.1 [done]
Installing: pulseaudio-module-gconf-0.99.2-1.1 [done]
Installing: pulseaudio-module-bluetooth-0.99.2-1.1 [done]
Installing: pulseaudio-esound-compat-0.99.2-1.1 [done]
Installing: alsa-plugins-pulse-1.0.24-12.1 [done]
Installing: pulseaudio-module-x11-0.99.2-1.1 [done]
Installing: paprefs-0.9.9-16.3 [done]
Installing: paprefs-lang-0.9.9-16.3 [done]

slipstream:/usr/src # zypper clean -a
All repositories have been cleaned up.
slipstream:/usr/src # zypper ref
Retrieving repository 'Crosscompiling Toolchain for ATMEL AVR microcontrollers (openSUSE_Factory)' metadata [done]
Building repository 'Crosscompiling Toolchain for ATMEL AVR microcontrollers (openSUSE_Factory)' cache [done]
Retrieving repository 'Short title of NewProject (Factory)' metadata [done]
Building repository 'Short title of NewProject (Factory)' cache [done]
Retrieving repository 'arduino' metadata [done]
Building repository 'arduino' cache [done]
Retrieving repository 'google-chrome' metadata [done]
Building repository 'google-chrome' cache [done]
Retrieving repository 'google-earth' metadata [done]
Building repository 'google-earth' cache [done]
Retrieving repository 'google-talkplugin' metadata [done]
Building repository 'google-talkplugin' cache [done]
Retrieving repository 'HAM-radio software packages (openSUSE_11.4)' metadata [done]
Building repository 'HAM-radio software packages (openSUSE_11.4)' cache [done]
Retrieving repository 'mod-pagespeed' metadata [done]
Building repository 'mod-pagespeed' cache [done]
Retrieving repository 'openSUSE Factory' metadata [done]
Building repository 'openSUSE Factory' cache [done]
Retrieving repository 'openSUSE Factory-non-oss' metadata [done]
Building repository 'openSUSE Factory-non-oss' cache [done]
Retrieving repository 'Software for Scientists and Engineers (openSUSE_11.4)' metadata [done]
Building repository 'Software for Scientists and Engineers (openSUSE_11.4)' cache [done]
Retrieving repository 'VirtualBox for openSUSE 11.4' metadata [done]
Building repository 'VirtualBox for openSUSE 11.4' cache [done]
All repositories have been refreshed.

"zypper in pulseaudio" still install 0.99.2.

Regards
Sid.

I thought, hell with it, nothing to lose so I downloaded them, later libpulse0 installed.
Disabled network sound with padevchooser and my application is happy with sound again.

slipstream:/home/lancelot/ftp/aug11 # l *.x86_64.rpm
-rw-r--r-- 1 lancelot users 19490 Sep 1 13:08 libpulse-browse0-0.9.23-1.3.x86_64.rpm
-rw-r--r-- 1 lancelot users 261719 Sep 1 13:08 libpulse-devel-0.9.23-1.3.x86_64.rpm
-rw-r--r-- 1 lancelot users 573792 Sep 1 13:11 pulseaudio-0.9.23-1.3.x86_64.rpm
-rw-r--r-- 1 lancelot users 17456 Sep 1 21:23 pulseaudio-module-gconf-0.9.23-1.3.x86_64.rpm
-rw-r--r-- 1 lancelot users 23323 Sep 1 21:20 pulseaudio-module-jack-0.9.23-1.3.x86_64.rpm
-rw-r--r-- 1 lancelot users 22177 Sep 1 21:20 pulseaudio-module-x11-0.9.23-1.3.x86_64.rpm
-rw-r--r-- 1 lancelot users 38366 Sep 1 21:21 pulseaudio-module-zeroconf-0.9.23-1.3.x86_64.rpm
-rw-r--r-- 1 lancelot users 50024 Sep 1 13:13 pulseaudio-utils-0.9.23-1.3.x86_64.rpm
slipstream:/home/lancelot/ftp/aug11 # rpm -Uvh --nodeps --force *.x86_64.rpm
Preparing... ########################################### [100%]
1:pulseaudio ########################################### [ 13%]
Updating /etc/sysconfig/sound...
2:libpulse-browse0 ########################################### [ 25%]
3:pulseaudio-utils ########################################### [ 38%]
4:pulseaudio-module-x11 ########################################### [ 50%]
5:libpulse-devel ########################################### [ 63%]
6:pulseaudio-module-gconf########################################### [ 75%]
7:pulseaudio-module-jack ########################################### [ 88%]
8:pulseaudio-module-zeroc########################################### [100%]
slipstream:/home/lancelot/ftp/aug11 # zypper in padevchooser
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
padevchooser

1 new package to install.
Overall download size: 28.0 KiB. After the operation, additional 72.0 KiB will be used.
Continue? [y/n/?] (y):
Retrieving package padevchooser-0.9.4-147.3.x86_64 (1/1), 28.0 KiB (72.0 KiB unpacked)
Retrieving: padevchooser-0.9.4-147.3.x86_64.rpm [done]
Installing: padevchooser-0.9.4-147.3 [done]
slipstream:/home/lancelot/ftp/aug11 #

Regards
Sid.

--
Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
Senior Staff Specialist, Cricket Coach
Microsoft Windows Free Zone - Linux used for all Computing Tasks

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >