Mailinglist Archive: opensuse-factory (600 mails)

< Previous Next >
Re: [opensuse-factory] ATI drivers with 11.2 M8
  • From: Juan Erbes <jerbes@xxxxxxxxx>
  • Date: Fri, 16 Oct 2009 08:59:36 -0300
  • Message-id: <61ec494a0910160459u9035004y385c343ef9f3a07a@xxxxxxxxxxxxxx>
2009/10/8 Doctor Who <whodoctor@xxxxxxxxx>:
Is it possible to get ATI video drivers working with 11.2 M8 so I can
use compiz/desktop effects?  If so, where do I get the driver from?


It depends of the model of Your ATI video card. If the model is <2400,
the latest driver You can use, is Catalyst 9.3. If the model video
card is >2400, You can use the latest driver, but for example for 9.8,
it need a few retouching of a source file:

https://bugzilla.novell.com/show_bug.cgi?id=535216#c6

After a install atempt with sh ati-driver-installer-9-8-x86.x86_64.run, to
recreate the files in /lib/modules/fglrx, I removed the if rutine related to "p
= find_task_by_vpid(pid);"
The source file to edit is:
/lib/modules/fglrx/build_mod/firegl_public.c

deletting the if routine "p = find_task_by_vpid(pid);"

they was about four lines, and remaked the kernel
module with
/lib/modules/fglrx/build_mod # ./make.sh

And later called:

/lib/modules/fglrx # ./make_install.sh

I try to load the module:

modprobe fglrx

I got no errors.

Then I configured the driver with the aticonfig command.

Regards,
Juan
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
References