Mailinglist Archive: opensuse-factory (279 mails)

< Previous Next >
Re: [opensuse-factory] Openoffice 3.0.0.16 for x86_64
  • From: Markus Koßmann <mkossmann_ml1@xxxxxx>
  • Date: Tue, 3 Mar 2009 19:34:37 +0100
  • Message-id: <200903031934.37758.mkossmann_ml1@xxxxxx>
Am Dienstag, 3. März 2009 schrieb Stephan Kulow:
Am Dienstag 03 März 2009 schrieb Joerg Mayer:

Is it unrealistic to add such a rule or at least keep the old packages
until the dependencies for the new packages are fulfilled?

You can keep the old packages on your factory installation just fine. Just
tell yast/zypper to take that solution.
Keeping the old version is really hard work in that case ( needs twenty
questions to answer) :-(.

Problem: OpenOffice_org-l10n-extras-3.0.0.16-2.2.noarch requires
OpenOffice_org= 3.0.0.16, but this requirement cannot be provided
uninstallable providers: OpenOffice_org-3.0.0.16-2.1.i586[factory-oss]
Solution 1: Following actions will be done:
keep OpenOffice_org-l10n-extras-3.0.0.13-1.9.noarch
keep OpenOffice_org-help-en-US-3.0.0.13-1.8.noarch
keep OpenOffice_org-help-de-3.0.0.13-1.8.noarch
keep OpenOffice_org-ure-3.0.0.13-1.10.x86_64
Solution 2: install OpenOffice_org-3.0.0.16-2.1.i586 despite the inferior
architecture
Solution 3: ignore some dependencies of OpenOffice_org-l10n-extras

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: digikam-0.9.4-52.16.x86_64 requires libkdcraw.so.3()(64bit), but
this requirement cannot be provided
deleted providers: libkdcraw3-0.1.4-52.2.x86_64[@System]
Solution 1: deinstallation of digikam-0.9.4-52.16.x86_64
Solution 2: keep libkdcraw3-0.1.4-52.2.x86_64
Solution 3: ignore some dependencies of digikam

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 2

Problem: digikam-0.9.4-52.16.x86_64 requires libkdcraw.so.3()(64bit), but
this requirement cannot be provided
deleted providers: libkdcraw3-0.1.4-52.2.x86_64[@System]
Solution 1: deinstallation of digikam-lang-0.9.4-52.16.x86_64
Solution 2: keep kipi-plugins-0.1.6-1.9.x86_64
Solution 3: ignore some dependencies of digikam

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 2

Problem: libkdcraw3-0.1.4-52.2.x86_64 requires libkdcraw3-lang = 0.1.4, but
this requirement cannot be provided
deleted providers: libkdcraw3-lang-0.1.4-52.2.x86_64[@System]
Solution 1: deinstallation of digikamimageplugins-0.9.4-52.16.x86_64
Solution 2: keep libkdcraw3-lang-0.1.4-52.2.x86_64
Solution 3: ignore some dependencies of libkdcraw3

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 2

Resolving dependencies...
Computing distribution upgrade...
5 Problems:
Problem: OpenOffice_org-base-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-l10n-de-3.0.0.16-2.2.noarch requires
OpenOffice_org-ure = 3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-calc-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-help-de-3.0.0.13-1.8.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided
Problem: OpenOffice_org-help-en-US-3.0.0.13-1.8.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided

Problem: OpenOffice_org-base-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
uninstallable providers: OpenOffice_org-3.0.0.16-2.1.i586[factory-oss]
Solution 1: Following actions will be done:
keep OpenOffice_org-base-3.0.0.13-1.9.x86_64
keep OpenOffice_org-icon-themes-3.0.0.13-1.9.noarch
Solution 2: install OpenOffice_org-3.0.0.16-2.1.i586 despite the inferior
architecture
Solution 3: ignore some dependencies of OpenOffice_org-base

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-l10n-de-3.0.0.16-2.2.noarch requires
OpenOffice_org-ure = 3.0.0.16, but this requirement cannot be provided
uninstallable providers: OpenOffice_org-ure-3.0.0.16-2.2.i586[factory-oss]
OpenOffice_org-ure-3.0.0.16-2.2.x86_64[factory-oss]
Solution 1: Following actions will be done:
keep OpenOffice_org-l10n-de-3.0.0.13-1.9.noarch
keep OpenOffice_org-libs-extern-3.0.0.13-1.10.x86_64
Solution 2: do not keep OpenOffice_org-ure-3.0.0.13-1.10.x86_64 installed
Solution 3: ignore some dependencies of OpenOffice_org-l10n-de

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-calc-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
uninstallable providers: OpenOffice_org-3.0.0.16-2.1.i586[factory-oss]
Solution 1: Following actions will be done:
keep OpenOffice_org-calc-3.0.0.13-1.9.x86_64
keep OpenOffice_org-icon-themes-3.0.0.13-1.9.noarch
keep OpenOffice_org-libs-core-3.0.0.13-1.10.x86_64
keep OpenOffice_org-libs-extern-3.0.0.13-1.10.x86_64
Solution 2: do not keep OpenOffice_org-l10n-extras-3.0.0.13-1.9.noarch
installed
Solution 3: ignore some dependencies of OpenOffice_org-calc

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-help-de-3.0.0.13-1.8.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided
deleted providers: OpenOffice_org-ure-3.0.0.13-1.10.x86_64[@System]
Solution 1: Following actions will be done:
keep OpenOffice_org-libs-gui-3.0.0.13-1.10.x86_64
keep OpenOffice_org-libs-core-3.0.0.13-1.10.x86_64
keep OpenOffice_org-libs-extern-3.0.0.13-1.10.x86_64
Solution 2: do not keep OpenOffice_org-help-de-3.0.0.13-1.8.noarch
installed
Solution 3: ignore some dependencies of OpenOffice_org-help-de

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-help-en-US-3.0.0.13-1.8.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided
deleted providers: OpenOffice_org-ure-3.0.0.13-1.10.x86_64[@System]
Solution 1: Following actions will be done:
keep OpenOffice_org-pyuno-3.0.0.13-1.10.x86_64
keep OpenOffice_org-libs-core-3.0.0.13-1.10.x86_64
keep OpenOffice_org-impress-3.0.0.13-1.7.x86_64
keep OpenOffice_org-libs-extern-3.0.0.13-1.10.x86_64
Solution 2: do not keep OpenOffice_org-help-en-US-3.0.0.13-1.8.noarch
installed
Solution 3: ignore some dependencies of OpenOffice_org-help-en-US

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1
Resolving dependencies...
Computing distribution upgrade...
13 Problems:
Problem: OpenOffice_org-draw-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-base-extensions-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-base = 3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-filters-optional-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-calc = 3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-impress-extensions-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-impress = 3.0.0.16, but this requirement cannotbe provided
Problem: OpenOffice_org-filters-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-libs-core = 3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-mailmerge-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-pyuno = 3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-components-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-libs-core = 3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-gnome-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-kde-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-math-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
Problem: OpenOffice_org-help-de-3.0.0.13-1.8.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided
Problem: OpenOffice_org-help-en-US-3.0.0.13-1.8.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided
Problem: OpenOffice_org-l10n-de-3.0.0.13-1.9.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided

Problem: OpenOffice_org-draw-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
uninstallable providers: OpenOffice_org-3.0.0.16-2.1.i586[factory-oss]
Solution 1: keep OpenOffice_org-draw-3.0.0.13-1.7.x86_64
Solution 2: install OpenOffice_org-3.0.0.16-2.1.i586 despite the inferior
architecture
Solution 3: ignore some dependencies of OpenOffice_org-draw

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-base-extensions-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-base = 3.0.0.16, but this requirement cannot be provided
uninstallable providers:
OpenOffice_org-base-3.0.0.16-2.2.i586[factory-oss]
OpenOffice_org-base-3.0.0.16-2.2.x86_64[factory-oss]
Solution 1: keep OpenOffice_org-base-extensions-3.0.0.13-1.9.x86_64
Solution 2: do not keep OpenOffice_org-base-3.0.0.13-1.9.x86_64 installed
Solution 3: ignore some dependencies of OpenOffice_org-base-extensions

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-filters-optional-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-calc = 3.0.0.16, but this requirement cannot be provided
uninstallable providers:
OpenOffice_org-calc-3.0.0.16-2.2.i586[factory-oss]
OpenOffice_org-calc-3.0.0.16-2.2.x86_64[factory-oss]
Solution 1: keep OpenOffice_org-filters-optional-3.0.0.13-1.9.x86_64
Solution 2: do not keep OpenOffice_org-calc-3.0.0.13-1.9.x86_64 installed
Solution 3: ignore some dependencies of OpenOffice_org-filters-optional

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-impress-extensions-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-impress = 3.0.0.16, but this requirement cannotbe provided
uninstallable providers:
OpenOffice_org-impress-3.0.0.16-2.2.i586[factory-oss]
OpenOffice_org-impress-3.0.0.16-2.2.x86_64[factory-oss]
Solution 1: keep OpenOffice_org-impress-extensions-3.0.0.13-1.9.x86_64
Solution 2: do not keep OpenOffice_org-impress-3.0.0.13-1.7.x86_64
Solution 3: ignore some dependencies of OpenOffice_org-impress-extensions

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]:1
Problem: OpenOffice_org-filters-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-libs-core = 3.0.0.16, but this requirement cannot be provided
uninstallable providers:
OpenOffice_org-libs-core-3.0.0.16-2.2.i586[factory-oss]
OpenOffice_org-libs-core-3.0.0.16-2.2.x86_64[factory-oss]
Solution 1: keep OpenOffice_org-filters-3.0.0.13-1.9.x86_64
Solution 2: do not keep OpenOffice_org-libs-core-3.0.0.13-1.10.x86_64
installed
Solution 3: ignore some dependencies of OpenOffice_org-filters

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-mailmerge-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-pyuno = 3.0.0.16, but this requirement cannot be provided
uninstallable providers:
OpenOffice_org-pyuno-3.0.0.16-2.2.i586[factory-oss]
OpenOffice_org-pyuno-3.0.0.16-2.2.x86_64[factory-oss]
Solution 1: keep OpenOffice_org-mailmerge-3.0.0.13-1.10.x86_64
Solution 2: do not keep OpenOffice_org-pyuno-3.0.0.13-1.10.x86_64 installed
Solution 3: ignore some dependencies of OpenOffice_org-mailmerge

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-components-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-libs-core = 3.0.0.16, but this requirement cannot be provided
uninstallable providers:
OpenOffice_org-libs-core-3.0.0.16-2.2.i586[factory-oss]
OpenOffice_org-libs-core-3.0.0.16-2.2.x86_64[factory-oss]
Solution 1: keep OpenOffice_org-components-3.0.0.13-1.9.x86_64
Solution 2: ignore some dependencies of OpenOffice_org-components

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/C]:
1

Problem: OpenOffice_org-gnome-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
uninstallable providers: OpenOffice_org-3.0.0.16-2.1.i586[factory-oss]
Solution 1: keep OpenOffice_org-gnome-3.0.0.13-1.10.x86_64
Solution 2: do not keep OpenOffice_org-icon-themes-3.0.0.13-1.9.noarch
installed
Solution 3: ignore some dependencies of OpenOffice_org-gnome

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-kde-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
uninstallable providers: OpenOffice_org-3.0.0.16-2.1.i586[factory-oss]
Solution 1: keep OpenOffice_org-kde-3.0.0.13-1.10.x86_64
Solution 2: do not keep OpenOffice_org-l10n-extras-3.0.0.13-1.9.noarch
installed
Solution 3: ignore some dependencies of OpenOffice_org-kde

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-math-3.0.0.16-2.2.x86_64 requires OpenOffice_org =
3.0.0.16, but this requirement cannot be provided
uninstallable providers: OpenOffice_org-3.0.0.16-2.1.i586[factory-oss]
Solution 1: keep OpenOffice_org-math-3.0.0.13-1.9.x86_64
Solution 2: do not keep OpenOffice_org-ure-3.0.0.13-1.10.x86_64 installed
Solution 3: ignore some dependencies of OpenOffice_org-math
hoose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1
Problem: OpenOffice_org-help-de-3.0.0.13-1.8.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided
deleted providers: OpenOffice_org-ure-3.0.0.13-1.10.x86_64[@System]
Solution 1: keep OpenOffice_org-writer-3.0.0.13-1.9.x86_64
Solution 2: do not keep OpenOffice_org-help-de-3.0.0.13-1.8.noarch
installed
Solution 3: ignore some dependencies of OpenOffice_org-help-de

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-help-en-US-3.0.0.13-1.8.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided
deleted providers: OpenOffice_org-ure-3.0.0.13-1.10.x86_64[@System]
Solution 1: keep OpenOffice_org-calc-extensions-3.0.0.13-1.9.x86_64
Solution 2: do not keep OpenOffice_org-help-en-US-3.0.0.13-1.8.noarch
installed
Solution 3: ignore some dependencies of OpenOffice_org-help-en-US

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1

Problem: OpenOffice_org-l10n-de-3.0.0.13-1.9.noarch requires
OpenOffice_org-ure = 3.0.0.13, but this requirement cannot be provided
deleted providers: OpenOffice_org-ure-3.0.0.13-1.10.x86_64[@System]
Solution 1: keep OpenOffice_org-writer-extensions-3.0.0.13-1.9.x86_64
Solution 2: do not keep OpenOffice_org-l10n-de-3.0.0.13-1.9.noarch
installed
Solution 3: ignore some dependencies of OpenOffice_org-l10n-de

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/C]: 1
Resolving dependencies...
Computing distribution upgrade...

Problem: OpenOffice_org-draw-extensions-3.0.0.16-2.2.x86_64 requires
OpenOffice_org-draw = 3.0.0.16, but this requirement cannot be provided
uninstallable providers:
OpenOffice_org-draw-3.0.0.16-2.2.i586[factory-oss]
OpenOffice_org-draw-3.0.0.16-2.2.x86_64[factory-oss]
Solution 1: Following actions will be done:
do not keep OpenOffice_org-draw-3.0.0.13-1.7.x86_64 installed
do not keep OpenOffice_org-filters-optional-3.0.0.13-1.9.x86_64 installed
do not keep OpenOffice_org-components-3.0.0.13-1.9.x86_64 installed
do not keep OpenOffice_org-filters-3.0.0.13-1.9.x86_64 installed
do not keep OpenOffice_org-icon-themes-3.0.0.13-1.9.noarch installed
do not keep OpenOffice_org-l10n-extras-3.0.0.13-1.9.noarch installed
do not keep OpenOffice_org-help-de-3.0.0.13-1.8.noarch installed
do not keep OpenOffice_org-l10n-de-3.0.0.13-1.9.noarch installed
do not keep OpenOffice_org-mailmerge-3.0.0.13-1.10.x86_64 installed
do not keep OpenOffice_org-writer-extensions-3.0.0.13-1.9.x86_64 installed
do not keep OpenOffice_org-math-3.0.0.13-1.9.x86_64 installed
do not keep OpenOffice_org-kde-3.0.0.13-1.10.x86_64 installed
do not keep OpenOffice_org-impress-extensions-3.0.0.13-1.9.x86_64
installed
do not keep OpenOffice_org-gnome-3.0.0.13-1.10.x86_64 installed
do not keep OpenOffice_org-calc-extensions-3.0.0.13-1.9.x86_64 installed
do not keep OpenOffice_org-base-3.0.0.13-1.9.x86_64 installed
do not keep OpenOffice_org-base-extensions-3.0.0.13-1.9.x86_64 installed
Solution 2: keep OpenOffice_org-draw-extensions-3.0.0.13-1.9.x86_64
Solution 3: ignore some dependencies of OpenOffice_org-draw-extensions

Choose from above solutions by number or cancel [1/2/3/C]: 2

.... now it could resolve all dependencies and started the update

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups