Mailinglist Archive: opensuse-factory (420 mails)

< Previous Next >
[opensuse-factory] Missing kernel-modules for update-kernel
  • From: Manfred Tremmel <Manfred.Tremmel@xxxxxx>
  • Date: Sat, 13 Oct 2007 13:53:46 +0200
  • Message-id: <200710131353.48187.Manfred.Tremmel@xxxxxx>
Hello,

in the update/10.3 directory of the openSUSE server there is a 
kernel-update to version 2.6.22.9-0.4 availaible. But it looks like all 
the *-kmp-* Packages with the additional kernel modules (like the 
VirtualBox Modules) aren't there.

And shouldn't be there a dependency to the kernel version:
 
manfred@marvin2:~> rpm -q --requires virtualbox-kmp-default
rpmlib(VersionedDependencies) <= 3.0.3-1
kernel-default
/bin/sh
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadIsBzip2) <= 3.0.5-1
manfred@marvin2:~> rpm -ql virtualbox-kmp-default
/lib/modules/2.6.22.5-31-default
/lib/modules/2.6.22.5-31-default/updates
/lib/modules/2.6.22.5-31-default/updates/vboxdrv.ko

it doesn't work after the update, so the dependency should point 
to "kernel-default = 2.6.22.5-31" and not only "kernel-default" I 
think.

PS: DSDT-Reload (ACPI_DSDT in /etc/sysconfig/kernel) is broken in
    the 10.3 kernels, 2.6.22.5-31 and 2.6.22.9-0.4. I'll open a
    bugreport.

-- 
Machs gut    | http://www.iivs.de/schwinde/buerger/tremmel/
             | http://packman.links2linux.de/
Manfred      | http://www.knightsoft-net.de
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >