Mailinglist Archive: opensuse-factory (824 mails)

< Previous Next >
Re: [opensuse-factory] Encrypted filesystem problem in 10.3 [solved]
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Sun, 23 Sep 2007 18:57:46 +0200
  • Message-id: <46F69B0A.2080909@xxxxxxxxxxxxxx>
Richard (MQ) wrote:
>> The problem now is that mount fails in 10.3 and not in 10.2. That is the
>> problem at hand.
> 
> I'll leave the udev stuff to those who understand it - meanwhile:

Thanks :-)

> 1. Symptoms are of mismatched data / password (modules are loaded now!)
> 
> Do you have the md5 sum or similar for the encrypted file (see below)?
> It may be corrupt / dirty. Try cleaning & re-inserting?

I have dozens of those encrypted dvds, I can try another. That one in
particular I read from 10.2 without problems a week ago.

[...]

Ok... it works. All of them. It was my fault. Between two of the tests I
forgot I had replaced the encrypted dvd with the 10.3 dvd.

The problem were the kernel modules. I had to reboot due to a kernel
update this morning, and after that I went right away to this thing, and
forgot to exchange the dvd. Ough.


> 2. Try manually mounting. As root, something like:
> 
> mkdir /mnt/dvd
> mount /dev/dvd /mnt/dvd (maybe needs -t iso9660 -o ro as well?)
> losetup -e twofish256 /dev/loop0 /mnt/dvd (or /mnt/filename ?)
> mount -o ro -t xfs /dev/loop0 /mnt/dvd.crypta.x

Yes, good idea. I have done that other times and it helps a lot in
determining the problem. It just didn't occur to me this time. I must be
tired.

Mine are not iso images, but xfs images, burnt directly.



> I use encrypted CDs and DVDs too, usually I generate a random file and
> loop-mount it, & save an accompanying md5 to check if it refuses a
> mount. Usually it's because it's scratched or dirty, or I have the wrong
> password.

I don't follow this part :-?

-- 
Cheers,
      Carlos E. R.
      (from RC1)
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups