Mailinglist Archive: opensuse-factory (509 mails)

< Previous Next >
[opensuse-factory] Factory update remains impossible?
I've not been able to update factory for a while now. I expected it to
return to a sane state once beta1 was available, but I'm still getting
nowhere. Is it still inconsistent, or am I hitting a bug I've missed
while looking through bugzilla? Relevant excerpt from a zypper update;
        
        Problem: No valid solution found with only resolvables of best
        architecture.
        Problem: Can't satisfy requirement /usr/bin/awk for
        openldap2-2.3.35-12.i586
        
        Problem: RealPlayer-10.0.8-97.i586[opensuse_non_oss] cannot be
        installed due to missing dependencies
        Problem: java-1_6_0-sun-1.6.0.u1-16.i586[opensuse_non_oss]
        cannot be installed due to missing dependencies
        Problem: hp-officeJet-0.91-183.i586 cannot be installed due to
        missing dependencies
        Problem: Can't satisfy requirement pilot-link == 0.12.1 for
        pilot-link-devel-0.12.1-73.i586
        
        Problem: Can't satisfy requirement /sbin/update-bootloader for
        kernel-kdump-2.6.22_rc4-2.i586
        
        Problem: Can't satisfy requirement /usr/bin/gconftool-2 for
        planner-0.14.2-7.i586[opensuse_oss]
        
        Problem: Can't satisfy requirement /sbin/isserial for
        setserial-2.17-645.i586[opensuse_oss]
        
        Problem: kdebluetooth-1.0_beta5-8.i586[opensuse_oss] cannot be
        installed due to missing dependencies
        Problem: metamail-2.7.19-1123.i586[opensuse_oss] cannot be
        installed due to missing dependencies
        Problem: Can't satisfy requirement /usr/bin/gconftool-2 for
        gnome-presence-applet-0.3.1-113.i586[opensuse_oss]
        
        Problem: java-1_4_2-gcj-compat-1.4.2.0-140.i586[opensuse_oss]
        cannot be installed due to missing dependencies
        Problem: kdegraphics3-scan-3.5.7-31.i586[opensuse_oss] cannot be
        installed due to missing dependencies
        Problem: yudit-2.7.8-83.i586[opensuse_oss] cannot be installed
        due to missing dependencies
        Problem: Can't satisfy requirement /usr/bin/wish for
        convert-1.3-867.i586[opensuse_oss]
        
        Problem: Can't satisfy requirement /usr/bin/gconftool-2 for
        tomboy-0.7.3-5.i586[opensuse_oss]
        
        Problem: Can't satisfy requirement /etc/init.d/network for
        klogd-1.4.1-622.i586[opensuse_oss]
        
        Problem: Can't satisfy requirement /sbin/mkdosfs for
        kdeutils3-3.5.7-32.i586[opensuse_oss]
        
        Problem: openct-0.6.12-6.i586[opensuse_oss] cannot be installed
        due to missing dependencies
        
        Problem: No valid solution found with only resolvables of best
        architecture.
         With this run only resolvables with the best architecture has
        been regarded.
        Regarding all possible resolvables takes time but can come to a
        valid result.
         Solution 1: Make a solver run with ALL possibilities.
          Regarding all resolvables with compatible architecture.
        number, (r)etry or (c)ancel> 1
        Applying solution 1
        
        Problem: Can't satisfy requirement /usr/bin/awk for
        openldap2-2.3.35-12.i586
        
         === openldap2-2.3.35-12.i586 ===
            gawk-3.1.5g-12.i586 provides /usr/bin/awk, but is scheduled
        to be uninstalled.
            openldap2-2.3.35-12.i586 depends on binutils
            openldap2-2.3.35-12.i586 is missing the
        requirement /usr/bin/strings
        
         Solution 1: delete openldap2
          delete openldap2-2.3.35-12.i586
         Solution 2: Ignore this requirement just here
         Solution 3: Ignore this requirement generally
        number, (r)etry or (c)ancel>

Followed by lots of similar dependency problems with core packages,
which I'm loath to blow through without some reassurance that I'll have
a usable system at the end.

Using the opensuse ftp site for updates;

        zypper> sl
        Got: sl
        # | Enabled | Refresh | Type   | Name               |
        URI                       
        --+---------+---------+--------+--------------------+-----------------------------------------------------------------------------------------------
        1 | Yes     | Yes     | rpm-md | opensuse_non_oss   |
        http://ftp.opensuse.org/pub/opensuse/distribution/SL-Factory-non-oss/inst-source-extra/suse
        2 | Yes     | Yes     | rpm-md | opensuse_oss       |
        http://ftp.opensuse.org/pub/opensuse/distribution/SL-OSS-factory/inst-source/suse
        3 | Yes     | Yes     | rpm-md | opensuse_oss_debug |
        http://ftp.opensuse.org/pub/opensuse/distribution/SL-OSS-factory-debug/inst-source-debug/suse/

Manually installed the latest zypp packages;

        # rpm -qa zypper libzypp
        libzypp-3.13.13-2
        zypper-0.8.9-2

Thanks,

Jason
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References