Mailinglist Archive: opensuse-factory (393 mails)

< Previous Next >
[opensuse-factory] Dependency problem
  • From: Anders Norrbring <lists@xxxxxxxxxxxx>
  • Date: Wed, 21 Mar 2007 11:06:58 +0100
  • Message-id: <460103C2.6000101@xxxxxxxxxxxx>
I don't know where to start looking.. I'm trying to use PHP 5.2.1 from the repositaries, but I run into some problems, look at this;

# rpm -qa | grep php5
php5-pear-net_url-1.0.14-11.1
php5-pear-http_request-1.4.0-4.1
php5-pear-db-1.7.6-42
php5-mhash-5.2.1-41.1
php5-curl-5.2.1-41.1
php5-ctype-5.2.1-41.1
php5-iconv-5.2.1-41.1
php5-dom-5.2.1-41.1
php5-soap-5.2.1-41.1
php5-devel-5.2.1-41.1
php5-xsl-5.2.1-41.1
php5-pear-auth_sasl-1.0.2-29
php5-5.2.1-41.1
php5-bz2-5.2.1-41.1
php5-json-5.2.1-41.1
...

Looks pretty good, right? Then I'm trying to install the pecl memcache module, also from repositary;

Problems
Can't satisfy requirement php5 == 5.2.1 for php5-mhash-5.2.1-41.1.i586
Can't satisfy requirement php5 == 5.2.1 for php5-curl-5.2.1-41.1.i586
Can't satisfy requirement php5 == 5.2.1 for php5-ctype-5.2.1-41.1.i586
Can't satisfy requirement php5 == 5.2.1 for php5-iconv-5.2.1-41.1.i586
Can't satisfy requirement php5 == 5.2.1 for php5-dom-5.2.1-41.1.i586
Can't satisfy requirement php5 == 5.2.1 for php5-soap-5.2.1-41.1.i586
Can't satisfy requirement php5 == 5.2.1 for php5-devel-5.2.1-41.1.i586
Can't satisfy requirement php5 == 5.2.1 for php5-xsl-5.2.1-41.1.i586
Can't satisfy requirement php5 == 5.2.1 for php5-pdo-5.2.1-41.1.i586
....

Where should I start looking? Seems like php5 doesn't (somehow) report itself to be 5.2.1, although it shows 5.2.1 everywhere in yast.
--

Anders Norrbring
Norrbring Consulting
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups