Mailinglist Archive: opensuse-factory (1165 mails)

< Previous Next >
Re: [opensuse-factory] Linux-Kernel-Headers outdated
  • From: Vahis <waxborg@xxxxxxxxx>
  • Date: Mon, 13 Nov 2006 19:15:21 +0200
  • Message-id: <4558A829.7070807@xxxxxxxxx>
Dominique Leuenberger wrote:
>
>
> >>> Reply on 13-11-2006 16:00:21 <<<> Dominique Leuenberger wrote:
> > > Hi everybody,
> > >
> > > I just posted bugzilla
> > > https://bugzilla.novell.com/show_bug.cgi?id=220384
> > > ####################################################
> > > Just installed Beta 2 in a VMware.
> > >
> > > In order to compile the Tools, the Kernel Header include files are
> > > quired.
> > > Installed the package 'linux-kernel-headers', but they are from an
> > > older kernel
> > > (2.6.18-13, while installed kernel is 2.6.18.2-4)
> > >
> > > Also in factroy tree, linux-kernel-headers is at 2.6.18-13
> > > ####################################################
> > >
> > > Severity is set to normal at the moment, even though it should be
> > much
> > > higher (but I assume as reporter I should not change that)
> > >
> > > OR: Did I miss something completely different? (that would render
> > that
> > > bugzilla report invalid?
> > >
> > > Regards,
> > > Dominique
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
> > > For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx
> > >
> > >
> > >
> > I have seen this vmware-tools/kernel header not matching -problem
> > discussed in several groups and forums concerning several distros in
> > addition to SUSE. And not just rpm based ones. As for SUSE it has been
> > discussed already during the 9.x series.
> >
> > But I have still not found a solutions for it. I sure would like to see
> > a solution how to install the vmwaretools properly :)
> >
> > Although this is obviously not quite the right place, I'd like to use
> > the opportunity to ask for any pointers to this matter.
> >
> Vahis,
>
> please read the Bugzilla Followup. I'm sorry for the noise I did. But
> it seems it's not the package linux-kernel-headers that is required,
> but the whole kernel-source.
>
> After installing that package, I was able to run
> vmware-config-tools.pl without any problems.
>
> Regards,
> Dominique

The steps I've made are the ones here:
http://en.opensuse.org/Setting_up_SUSE_Linux_as_a_VMware_Guest#Set_Up_VMware_Tools_on_a_SUSE_Linux_Guest

Everything is as It's says there. But the script keeps coming to this:

The directory of kernel headers (version @@VMWARE@@ UTS_RELEASE) does
not match
your running kernel (version 2.6.18.2-4-default). Even if the module
were to
compile successfully, it would not load into the running kernel.

--
Vahis
Sometimes I reply to top posters. Seldom. And usually just once.
Motorcycling, Boating and SUSE Linux: http://waxborg.servepics.com

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups