Mailinglist Archive: opensuse-factory (599 mails)

< Previous Next >
Re: [opensuse-factory] X.Org 7 for Factory
  • From: "Ain Vagula" <avagula@xxxxxxxxx>
  • Date: Mon, 7 Aug 2006 21:34:12 +0300
  • Message-id: <daaaeae00608071134o757ef292h64b59ce3fe2f878c@xxxxxxxxxxxxxx>
On 8/7/06, Stefan Dirsch <sndirsch@xxxxxxx> wrote:
On Mon, Aug 07, 2006 at 10:06:06AM -0300, Juan Erbes wrote:
> 2006/8/7, Stefan Dirsch <sndirsch@xxxxxxx>:
> >On Sun, Aug 06, 2006 at 05:32:40PM -0300, Juan Erbes wrote:
> >> Yesterday I have updated my box to Xorg 7, and got some problems to
> >> start kde, many of them resolved with the instructions from Stefan.
> >
> >Hmm ... this should not happen. How did you update to X.Org 7? Which
> >packages did you install from which repository?
>
> I made the update via smart upgrade.

Well, this answers only my first question. :-(

> I recommend to simply
> >install all packages of
> >
> >SUSE 10.1:
> >http://software.opensuse.org/download/xorg7/Java_Sun-Java-1.5_SUSE_Linux_10.1/
> >
> >Factory:
> >http://software.opensuse.org/download/xorg7/SUSE_Factory/
> >
> >> One of the problems was with sax2 that configures the font path as
> >> /usr/lib/X11/fonts,
> >
> >sax2/Factory already uses /usr/share/fonts, sax2/10.1 still uses
> >/usr/X11R6/lib/X11/fonts. BTW, reconfiguration with sax2 should not
> >have been required, since xorg.conf is already patched in %post of
> >xorg-x11-server package to use the new font path.
> >
> >> when I have moved the fonts from
> >> /usr/X11R6/lib/X11/fonts to /usr/share/fonts. I resolved this problem
> >> with a symlink.
> >
> >I cannot recommend to do so. Did you run SuSEconfig (--module fonts)
> >after the packages update?
>
> Yes, I runned it.

Good!

> >> The other problem related to the fonts is in kde, because any qt
> >> application loads any text (such as konsole). Only the gtk
> >> applications loads partially the fonts to show the text and menus.
> >
> >Sounds like a completely messed up font setup.
>
> /usr/share/fonts is the right font path for all the fonts?
>
> How detects kde the right font path, and how can configure it, when I
> do'nt see any text in the Control Panel?

KDE uses client side font rendering via fontconfig/freetype and
/usr/share/fonts as well as /usr/X11R6/lib/X11/fonts is in
/etc/fonts/fonts.conf since quite some time. So it doesn't matter,
which font paths are configured in /etc/X11/xorg.conf.


Hi, Stefan,

I can reproduce this problem with missing fonts in KDE and blinking
fonts in Gnome when nvidia driver is enabled, after switching to
nv-driver back problem is gone.
I installed driver with --x-module-path=/usr/lib/xorg/modules/, as
otherways didnt driver work at all. Using SLED 10 on x86.

Ain

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-factory-unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-factory-help@xxxxxxxxxxxx


< Previous Next >
Follow Ups