Mailinglist Archive: opensuse-es (403 mails)

< Previous Next >
Re: [opensuse-es] Re: Problemas con apache o virtual host o DNS
Gracias Camaleón,

algo que me olvide mencionar es que cuando me da ese problema también pierdo la posibilidad de conectarme vía ssh, dura unos minutos... y luego todo normal.

El problema me pasa con los dos dominios virtuales. En cuanto al default-server.conf tiene la misma configuración que uno de los virtual host, el mismo DocumentRoot y archivos de logs, etc.

El probelema es mas evidente desde la red interna y muy poco sucede cuando me conecto a los sitios desde otra red fuera de la oficina. Creo que vale la pena mencionar que cuento con un servidor DNS interno que lo utilizo para resolver direcciones privadas para una intranet, y que aprovecho para indicarles a las estaciones a traves de este DNS interno cómo y en donde ubicar los sitios web publicos a través de la red interna (ip privado).

Los logs los he revisado pero no encuentro nada relacionado al problema, mas que las visitas y errores por broken links.

Bayardo.


El 18/02/2011 05:21 a.m., Camaleón escribió:
El Thu, 17 Feb 2011 19:40:09 -0600, Bayardo Rivas - Open Soluciones
escribió:

(...)

El problema:

El servidor web deja de publicar el contenido que esta definido, y me
muestra el banner por defecto de apache (It Works !!). Esto lo hace
muchas veces en el día. En un momento estas navegando sin problemas por
el sitio y de repente, aparece el banner o despliega un error que dice
que no "No hay conexión".
(...)

¿Te pasa con ambos (el dominio principal y el subdominio) o sólo con uno
de ellos? ¿Sucede siempre conectando desde fuera de la red local (e
nremoto) o también te da el mismo problema cuando accedes en local?

Creo que podría tratarse de un problema puntual con la conexión o con la
configuración del servicio DNS (o una mezcla de ambos).

¿En qué ocasiones muestra Apache2 la página predeterminada? Pues supongo
que cuando no puede "localizar" a los dominios virtuales, no sabe dónde
enrutar el tráfico y lo dirige al sitio predeterminado (por cierto, no te
asustes, aunque no lo tengas definido en los contenedores virtuales, el
sitio predeterminado está configurado en el archivo "/etc/apache2/
httpd.conf" cuya platilla esta en "/etc/apache2/default-server.conf")

Ahora bien... ¿qué sucede para que Apache no pueda localizar los sitios
virtuales? Pues el hecho de que se trate de un error "puntual" (si
sucediera siempre apuntaría más bien a un problema con la configuración
de los sitios virtuales del apache) me hace pensar en un fallo del
servidor dns o con la conexión.

Entiendo que tú mismo te estás proporcionando los servicios de resolución
de nombres pero quizá te convendría más tirar de algo como DynDNS
(independientemente de que tengas IP fija o dinámica, al menos para
ponerlo como servidor dns secundario por si tu bind está ko).

Otra cosa, revisa los registros de apache para ver si te da alguna pista
de por qué está sirviendo contenido desde el sitio predeterminado.

Saludos,


--
Para dar de baja la suscripción, mande un mensaje a:
opensuse-es+unsubscribe@xxxxxxxxxxxx
Para obtener el resto de direcciones-comando, mande
un mensaje a:
opensuse-es+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups