Mailinglist Archive: opensuse-es (1152 mails)

< Previous Next >
Re: [opensuse-es] Re: Generando avis - ffmpeg
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Mon, 21 Dec 2009 03:04:52 +0100 (CET)
  • Message-id: <alpine.LSU.2.00.0912210259440.4905@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



El 2009-12-20 a las 20:10 -0000, Camaleón escribió:

El Sun, 20 Dec 2009 17:36:58 +0100, Carlos E. R. escribió:

El 2009-12-20 a las 16:07 -0000, Camaleón escribió:

Pues me parece que sigues sin entenderlo, por lo que dices abajo.

Entiendo lo que dices, pero no puedo reproducir tu error, al menos con
el vídeo que tengo de prueba, ese japonés.

Pues entonces alucino.


Yo le estoy pasando la opción de "-sameq", quizá sea por eso :-?

Eso es sólo para la calidad, que use la misma que el original.


De todos modos, mira mi otro mensaje, ya he conseguido solucionarlo. Es cambiando el aspecto al valor exacto que calcule yo que tiene que tener.


Tiene que reducir el tamaño vertical en el número de lineas que le
quito. Eso es lo que hace el avidemux, y eso es lo que entiende
cualquiera.

Sí, tiene que reducirlo, pero el cálculo debe ser automático.

Pues no lo es. Absurdo.


Pues a lo mejor ese el problema, que no mantiene una relación de tamaño
estándar y se deforma porque le pasas unos valores incompatibles :-)

Eso no tiene sentido.


A saber... si le estás pasando "-qscale", "-croptop" y "-s" es posible
que alguna de esas te esté generando ese problema de deformación.

- -qscale no tiene que ver. Los otros dos, sí, claro.


Usa el WinFF, a ver qué argumentos aplica :-?

¿Tiene filtro "crop"?

Tiene el del tamaño, el otro lo puedes pasar como parámetro manual :-)

Ugh.



¿El artefacto ese que dices también es perceptible en el vídeo original
o sólo cuando lo pasas a AVI comprimido?

Se percibe en el original sabiendo donde está y pasando foto a foto, con
avidemux. A velocidad normal no se nota. Y no afecta al sonido, debe
tener marcas de tiempo.

¿Has probado a usar una codificación constante (CBR) en lugar de
variable (VBR)? :-?

La codificación por defecto que hace el ffmpeg es de esas. Y el
transcode también.

Si usas "-qscale" (o "-sameq") me parece que no, que lo estás forzando a
usar VBR.

Me refiero a no pasar ningún parametro:

ffmpeg -i entrada.mpeg salida.avi.

- -- Saludos
Carlos E. R.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEARECAAYFAksu19MACgkQtTMYHG2NR9WNzwCbB6XkFKs66XpXPJ7DQjF9u3gZ
t14AnR9eHnnYv/4WhMwJSPrcTvltyqJj
=KaWv
-----END PGP SIGNATURE-----
< Previous Next >
This Thread
Follow Ups