Mailinglist Archive: opensuse-es (1152 mails)

< Previous Next >
Re: [opensuse-es] Re: Generando avis - ffmpeg
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Sun, 20 Dec 2009 17:36:58 +0100 (CET)
  • Message-id: <alpine.LSU.2.00.0912201727360.4905@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



El 2009-12-20 a las 16:07 -0000, Camaleón escribió:

El Sun, 20 Dec 2009 16:08:55 +0100, Carlos E. R. escribió:

Pues me parece que sigues sin entenderlo, por lo que dices abajo.

Entiendo lo que dices, pero no puedo reproducir tu error, al menos con el
vídeo que tengo de prueba, ese japonés.

Pues entonces alucino.


Pero el tamaño TIENE que variar. Le estoy quitando lineas, no
substituyendo por negro. Quitando lineas. Quito 122+112 = 234 lineas. Si
a las 576 lineas le quito 234 quedan 342 lineas.

Pero el cálculo lo tendría que hacer el programa automáticamente, no
tener que definirlo con la opción de "-s". De lo contrario no tendría
sentido :-?

Claro que no tiene sentido.

Tiene que reducir el tamaño vertical en el número de lineas que le quito. Eso es lo que hace el avidemux, y eso es lo que entiende cualquiera.



`-croptop size'
Set top crop band size (in pixels).

`-cropbottom size'
Set bottom crop band size (in pixels).

Estas dos opciones sí hacen referencia a las bandas negras,
exclusivamente.

Lo que entiendo es que modificando estos valores de "crop" no se modifica
el tamaño (aspecto) del vídeo sino que recortas las zonas negras,
ajustando el tamaño y la relación de aspecto automáticamente.

Pero es que no ajusta el tamaño. Lo deja igual, expandiendo las lineas anamórficamente para que las lineas que quedan, que son menos, ocupen lo mismo que las antiguas.


Además, el aspecto buscado es 720/342 = 2.105, mientras que 16/9 es
1.77. No me vale.

Pues a lo mejor ese el problema, que no mantiene una relación de tamaño
estándar y se deforma porque le pasas unos valores incompatibles :-)

Eso no tiene sentido.


Por cierto ¿se visualiza mal (deformado) con todos los reproductores?

Que yo recuerde, si.


No, EL lo hace mal. No me corta esas lineas. Las quita y luego expande
el resultado en vertical, deformando las figuras una barbaridad. El
avidemux lo hace perfecto.

Usa el WinFF, a ver qué argumentos aplica :-?

¿Tiene filtro "crop"?


Prueba con otros vídeos, a ver si hace lo mismo...

Todos los que tengo son del mismo aparato y grabados con el mismo proceso: aparato -> cridmanager -> projectX -> ffmpeg o equivalente.

Estoy pensando en tocar el resultado con avifix. A ver si es eso.



Tendré que experimentar con los filtros de transcode, a ver si ese
habla en cristiano.

Ese hablará "arameo", por lo menos :-P

Pues he conseguido sacar un video o dos... con el mismo fallo del salto
de sonido, con dos codecs distintos.

¿El artefacto ese que dices también es perceptible en el vídeo original o
sólo cuando lo pasas a AVI comprimido?

Se percibe en el original sabiendo donde está y pasando foto a foto, con avidemux. A velocidad normal no se nota. Y no afecta al sonido, debe tener marcas de tiempo.


¿Has probado a usar una codificación constante (CBR) en lugar de variable
(VBR)? :-?

La codificación por defecto que hace el ffmpeg es de esas. Y el transcode también.

- -- Saludos
Carlos E. R.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEARECAAYFAksuUrAACgkQtTMYHG2NR9XpfACfSSWCAbU+QCBz1Krc1w8IZwCp
wHEAn0wFvyRwooXQ1/hbxUs++2xxa2/f
=II/3
-----END PGP SIGNATURE-----
< Previous Next >
This Thread
Follow Ups