Mailinglist Archive: opensuse-es (1168 mails)

< Previous Next >
Re: [opensuse-es] no inicia secion correctamente
  • From: Karl García Gestido <karlggest@xxxxxxxxxxx>
  • Date: Fri, 24 Apr 2009 15:01:22 +0200
  • Message-id: <200904241501.22981.karlggest@xxxxxxxxxxx>
O Venres 24 Abril 2009 14:11:30 Carlos E. R. escribiu:
El 2009-04-24 a las 13:57 +0200, Camaleón escribió:
El 2009-04-24 a las 13:45 +0200, Carlos E. R. escribió:
Vamos a ver, el zypper es una herramienta de consola, es decir, para
administradores que saben lo que hacen, y que trabajan sin barreras, en
plan chulo >:-P
zypper es una herramienta para gestionar sistemas de paquetes, más o menos
equivalente a apt.
¿Y qué tiene que ver?

El problema era que al intentar eliminar gnome (supongo que lo haría
desde yast) se le quitó el zypper y medio sistema.
Al eliminar gnome quita gnome (ni siquiera todo); algo más eliminaría. Es
posible que un paquete informe que libzypp o zypper dependen de él, pero no
creo que sea fácil.
Quitaría un patrón. Los patrones incluyen muchas cosas.

Veamos...

Hay muchas herramientas propias del sistema gráfico de turno (algunas incluso
de difícil justificación).

Por ejemplo, si tú seleccionas por patrones->GNOME (Base) Paquetes->Todos los
de esta lista->Borrar eliminarás cosas como hplip y otros elementos que, aún
formando parte del sistema base de KDE, figuran en esa lista.

La cosa se complica a la hora de resolver las dependencias. Por ejemplo, la
segunda en mi lista (estoy probando cómo se resuelven en el caso de GNOME) es
MPlayer. Al estar eliminando gnome, YAST indica que mplayer depende de libgdk-
pixbuf. De las opciones (sugerencias) para resolver esto, la primera opción
implica desinstalar 577 paquetes (en mi instalación): desde xfce hasta cosas
más peregrinas, como mysql, códecs, incluso plasmoides y al menos un buen
puñado de aplicaciones KDE 4 (no he verificado si desinstalaría todo KDE 4,
pero no creo).

Si en lugar de por patrones filtras por grupos, puedes seleccionar GNOME
(Desktop) y ahí sí están todos los que hay que eliminar. Aún así, hay que
tener en cuenta que se deben de resolver las dependencias a mano y hay que
fijarse bien (por supuesto, quitar cosas con gtk incluye programas como
openOffice). Visto esto, no veo una forma trivial de eliminar el escritorio, y
mucho menos de eliminar el escritorio y dejar las aplicaciones (como no sea
volver a marcarlas para instalación).

Un paquete que no debe desinstalarse es gconf.

Antes dije lo de zypper, bueno, y es que hasta ahora no lo he visto en ninguna
dependencia, en particular porque zypper es una aplicación en modo comando.

Vale que tenía que haberse fijado en lo que hacía antes de darle a
aceptar, pero paquetes como zypper deberían preguntar hasta 5 veces
anets de eliminarse y advertir al usuario de lo que se le puede venir
encima si continua.

Pero eso no es problema de gnome ni kde. Es un problema básico de diseño
de zypper y YaST, y mira que se les ha dicho, que hay una serie de
paquetes "cruciales" cuya desintalación debería exigir confirmación con
contraseña.
<modo broma ON>
Igual que rm, chown, chgrp,... vamos, la solución del vista: "ha elegido
encender el computador, ¿está seguro?
<modo broma OFF>

Hay muchas consideraciones de seguridad posibles (muchas de ellas no hace
tanto que se trataron en la lista), pero controlar los comandos que ejecuta
root creo que es excesivo.

Si borras un paquete cualquiera, zypper te informa. Por cierto, YAST usa
zypper y no hace nada que no haga zypper (bueno, el "volver atrás" y eso). Los
fallos de libzypp afectarán al instalador de software de YAST de forma
necesaria.
Creo que uso yast y luego intentó instalar el zypper original desde el
DVD.

Tanto no recuerdo.

Respecto a que yo tengo más experiencia, pues sí, ahora la tengo, pero
al principio era un novato como todos, y sin lista de correo de ayuda. Y
puse todos los entornos, en cuanto me enteré que existían, para probar a
ver cual me gustaba más. Y nunca he tenido problemas por ese
"detallico".
Puedes poner y quitar tantos como quieras.... hay matices, pero nada de
gravedad.
Es que los tiempos de antes no son los de ahora >:-). Ahora reina el
caos y cualquier tontería te deja con un sistema que funciona a medio
gas y si no das con el problema, ahí te quedas.

Ya...

Por ejemplo, los usuarios de kde4 con el repo de las qt4.5. Anda que no
ha dado problemas.

Recuerda que mi recomendación es no actualizar paquetes desde
repositorios de cosas como el gnome o kde.
Cuando se informa de una actualización y se pone en los repositorios,
deberíamos documentarnos más antes de hacer nada. El caso de KDE 4 y QT 4.5
estaba documentado en la web, o al menos cuando lo consulté yo estaba. Por
supuesto, en el caso de la documentación de opensuse.org hay que tener cuidado
con las posibles diferencias entre la versión española y la inglesa.

Por ejemplo, no hace mucho había un problema al actualizar códecs y demás a
partir de Videolan (ya que la prioridad de un repositorio por defecto es
siempre la misma)... hay opciones para obligar a libzypp a informar del cambio
de procesión y la mayor parte de cambios en las versiones 11 y 11.1 de
openSUSE giran alrededor de esto.

Así que la regla es "usar los repositorios con mesura".

Eso funciona "out of the box".

Ja >:-)

Pruébalo >:-P

Crea una de tus máquinas virtuales que tanto te gustan, pon uno de los
entornos y añade otro como patrón en la pantalla de instalación.

Salud!!

--
O malo da relixión e a súa carenza de imaxinación
--
karl
--
Para dar de baja la suscripción, mande un mensaje a:
opensuse-es+unsubscribe@xxxxxxxxxxxx
Para obtener el resto de direcciones-comando, mande
un mensaje a:
opensuse-es+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups