Mailinglist Archive: opensuse-es (1326 mails)

< Previous Next >
RE: [opensuse-es] Miro player
  • From: Ryouga Hibiki <pchan_dwk@xxxxxxxxxxx>
  • Date: Fri, 2 Nov 2007 20:56:24 +0000
  • Message-id: <BAY108-W17E8CFEB5A7AB53684A04F9C8D0@xxxxxxx>

http://www.getmiro.com/download/> Hay posibilidad, pero no se menciona
openSuSE =/>> Asi que manos a la obra con el codigo fuente>
https://develop.participatoryculture.org/trac/democracy/wiki/GTKX11BuildDocs>>
Revisando eso.. que tampoco la pone muy facil, hay que ver los requerimientos
(para fedora):
subversion
xine-lib-devel
gnome-python2-gtkmozembed
libfame-devel
Pyrex
gnome-python2-gconf
pygtk2-devel
gstreamer
gstreamer-python
gstreamer-plugins-base


JO, mas diversion:
luego de instalar pyrex 0.9.4.1-25
y aplicar ./run.sh

me salio
[..]
Can't find xulrunner-xpcom, mozilla-xpcom or firefox-xpcom

por lo que procedo a instalar: mozilla-xulrunner181-devel 1.8.1.4-6.1-i586 y
otros paquetes mas (se autoinstalaron):
mozilla-nspr-devel 4.6.7-2.1
mozilla-nss 3.11.3-10
mozilla-nss-devel 3.11.7-7.1

luego salio:
Traceback (most recent call last):
File "setup.py", line 244, in
"gtk+-2.0 glib-2.0 pygtk-2.0 %s %s" % (gtkmozembed, xpcom))
File "setup.py", line 194, in parsePkgConfig
output = getCommandOutput(commandLine).strip()
File "setup.py", line 165, in getCommandOutput
(cmd, stderr))
RuntimeError: pkg-config --cflags --libs gtk+-2.0 glib-2.0 pygtk-2.0
xulrunner-gtkmozembed xulrunner-xpcom outputted the following error:
Package pygtk-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `pygtk-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'pygtk-2.0' found

Por lo que procedo a instalar python-gtk 2.10.3-11-i586 y python-gtk-devel
2.10.3-11-i586 y se autoinstalaron:
python-cairo-devel 1.2.2-18
python-devel 2.5-19.4
python-gobject2-devel 2.12.2-11

luego salio:
Traceback (most recent call last):
File "setup.py", line 340, in
raise RuntimeError("xine_extractor compilation failed. Possibly missing
libxine, gdk-pixbuf-2.0, or glib-2.0.")
RuntimeError: xine_extractor compilation failed. Possibly missing libxine,
gdk-pixbuf-2.0, or glib-2.0.

por lo que siguio la instalacion de xine-devel 1.1.2-40.1-i586
lo que pidio aun mas autoinstalacion. =/ y ahi me desanime. Tengo muy poco
espacio =(
Voy a proceder a instalar la version para Fedora core 7, a ver que tal va. =/
aunque creo que voy a tener problemas. Algunas sugerencia?

Carlos A.
_________________________________________________________________
Discover the new Windows Vista
http://search.msn.com/results.aspx?q=windows+vista&mkt=en-US&form=QBRE
---------------------------------------------------------------------
Para dar de baja la suscripci坦n, mande un mensaje a:
opensuse-es+unsubscribe@xxxxxxxxxxxx
Para obtener el resto de direcciones-comando, mande
un mensaje a:
opensuse-es+help@xxxxxxxxxxxx

< Previous Next >
References