Mailinglist Archive: opensuse-es (2081 mails)

< Previous Next >
Re: [suse-linux-s] no funciona yast despues de actualización en línea
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Fri, 10 Nov 2006 00:26:36 +0000 (UTC)
  • Message-id: <Pine.LNX.4.64.0611100118580.4080@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


El 2006-11-09 a las 17:41 -0600, Hector Alfredo Alvarez Contrer escribió:

> Bueno pues eso, despues de una actualización, me apareció una leyenda
> que el yast se actualizó y que los cambios se verian cuando se volviera
> a cargar. Luego lanzo yast, y se abre pero no puedo abrir ningún módulo
> en ninguna sección.
> Intenté lanzarlo desde una consola y esto es lo que salió:
>
> Error loading language plugin /usr/lib/YaST2/plugin/libpy2lang_perl.so:
> libzypp.so.1: cannot open shared object file: No such file or directory
> No such client module sw_single
>
> Bueno, lo que no se es cómo lo arreglo. ¿Tengo que instalar la
> biblioteca libzypp.so.1 de nuevo, la ruta ha cambiado?
>
> Si intento lanzar el yast en modo ncurses dice:
>
> Exserver:/home/nsialfred # yast
> warning: the ncurses frontend is installed but does not work
> You need to install yast2-ncurses to use the YaST2 text mode interface
>
> Como dije, antes de la actualización funcionaba el yast, yast2 y también
> podía lanzar algunos módulos desde el centro de control Gnome.


Me da la impresión que te ha hecho una actualización a medias e
inconsistente.

Prueba esto:

cer@nimrodel:~/bin> rpm -q -a | grep -i yast2

te debe contestar esto:

yast2-ldap-2.13.4-8
yast2-nis-server-2.13.3-8
yast2-powertweak-2.13.5-14
autoyast2-utils-2.13.69-0.3
yast2-repair-2.13.7-0.3
yast2-packager-2.13.139.3-0.2
yast2-country-2.13.23-5
yast2-x11-2.13.6-38
yast2-mail-2.13.3-12
yast2-2.13.64.3-0.2
yast2-trans-stats-2.11.0-21
yast2-bluetooth-2.13.3-8
yast2-support-2.13.2-12
yast2-ntp-client-2.13.8-5
yast2-restore-2.13.1-12
yast2-runlevel-2.13.7-8
yast2-ldap-client-2.13.13-6
yast2-users-2.13.16-10
yast2-online-update-frontend-2.13.43.2-0.2
yast2-transfer-2.13.3-12
yast2-control-center-2.13.2-13
yast2-tune-2.13.4-14
yast2-inetd-2.13.2-12
yast2-network-2.13.48-5
yast2-installation-2.13.132.9-0.2
yast2-trans-en_GB-2.13.6-6
yast2-sound-2.13.9-12
yast2-nis-client-2.13.3-8
yast2-schema-2.13.2-13
yast2-mail-aliases-2.13.3-12
yast2-firewall-2.13.7-9
yast2-xml-2.13.1-13
yast2-kerberos-client-2.13.4-7
yast2-update-2.13.26-3
yast2-phone-services-2.13.1-12
yast2-trans-es-2.13.24-0.2
yast2-perl-bindings-2.13.5-1.4
autoyast2-2.13.69-0.3
yast2-online-update-2.13.43.2-0.2
yast2-storage-lib-2.13.58-3
yast2-theme-SuSELinux-2.13.7-6
yast2-bootloader-2.13.56-3
yast2-tftp-server-2.13.3-12
yast2-nfs-server-2.13.3-12
yast2-printer-2.13.19-1.3
yast2-trans-en_US-2.13.5-6
yast2-hardware-detection-2.13.3-13
yast2-scanner-2.13.16-9
yast2-sysconfig-2.13.5-14
yast2-apparmor-2.0-27.5


En concreto, el error que te dio del
/usr/lib/YaST2/plugin/libpy2lang_perl.so, viene en el rpm
"yast2-perl-bindings-2.13.5-1.4".

Si tienes diferencias en el listado, yo bajaría los rpms a mano y los
instalaría a mano con rpm.

- --
Saludos
Carlos E. R.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Made with pgp4pine 1.76

iD8DBQFFU8cxtTMYHG2NR9URAu82AJ9RaFjYp83AnQ1WD6LzziBp/Cx1XwCgkAdX
4Q9gARjdPoVRC4plI4YYhjU=
=x/5e
-----END PGP SIGNATURE-----
< Previous Next >