Mailinglist Archive: opensuse-es (1469 mails)

< Previous Next >
Re: [suse-linux-s] Auxilio con sonido Intel 82801 ICH6 High Definition Audio Controler
  • From: "Juan Erbes" <jerbes@xxxxxxxxx>
  • Date: Mon, 2 Oct 2006 15:24:24 +0000 (UTC)
  • Message-id: <61ec494a0610020824g5bc1204j497abcd83c3f0c93@xxxxxxxxxxxxxx>
Aparentemente es bastante comun ese problema, y se debería a que
distintos fabricantes que usan el mismo chip, lo conectan de manera
distinta. Estube buscando en los viejos links que tenía sobre alsa,
pero no encontré nada, así que probé con Google, y salió esto:
Yup, compiling alsa 1.0.13rc2 solved the problem. Yippiiee!
Now the mixer is not a mess anymore and it has a bunch of slider.
The only "little" remaining problem is that Kmix slider for,
suppossedly, master, is not master but... *no clue which* (haven't
been trying, tho).
So it doesn't change the volume at all. To do that opening the mixer
is necessary and then moving PCM or Front sliders.
Well, I guess that updating alsa to 1.0.13 when it becomes stable will
solve that.
http://forums.suselinuxsupport.de/index.php?s=fae00aae4f9218d065df01e22a4505dd&showtopic=43533&pid=192224&st=0&#entry192224

Traducción, debes desacrgarte los drivers alsa 1.0.13rc2 y compilarlos
tu mismo, para lo cual, necesitas los fuentes del kernel instalados,
compilador, etc.

Salu2

2006/10/2, Julio Añez <janez0266@xxxxxxxxx>:
Ok, para que todos tengan una idea de lo que me pasa, les indico las
caracteristicas del sonido que me arroja el YAST.

16: PCI 1b.0: 0403 Audio device
[Created at pci.300]
UDI: /org/freedesktop/Hal/devices/pci_8086_2668
Unique ID: u1Nb.2HWUYaI85QD
SysFS ID: /devices/pci0000:00/0000:00:1b.0
SysFS BusID: 0000:00:1b.0
Hardware Class: sound
Model: "Hewlett-Packard Company 82801FB/FBM/FR/FW/FRW (ICH6 Family) High
Definition Audio Controller"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x2668 "82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition
Audio Controller"
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x2a29
Revision: 0x04
Driver: "HDA Intel"
Memory Range: 0xffa3c000-0xffa3ffff (rw,non-prefetchable)
IRQ: 209 (28808790 events)
Module Alias: "pci:v00008086d00002668sv0000103Csd00002A29bc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=yes, avail=yes, need=no, active=unknown


Sin embargo, cuando inicio el equipo con Windows XP (Dual boot con grub) me
detecta una "Realtek ALC 880". Pueden ver en el detalle anterior que se
utiliza el driver "snd-hda-intel" y no presenta por ninguna parte errores de

ningún tipo.... no se que pasará.

Ya utilicé el ALSACONF y aparentemente todo sale bien, pero con el mismo
resultado -sin audio-

Julio...
___________________________________

El Viernes, 29 de Septiembre de 2006 5:27 AM, Rafa Grimán escribió:
> Hola :)
>
> El Viernes, 29 de Septiembre de 2006 10:52, Camaleón escribió:
> > 2006/9/29, Rafa Grim??n:
> > > Eso mismo pensaba yo, pero no he tenido tiempo para meterle mano y ver
> > > qué pasa.
> >
> > Bueno, he metido la gamba :-P.
>
> Bien venida al club ;)
>
> > El equipo con ICH6 tiene una tarjeta de sonido "Realtek ALC658 5.1
> > channel audio", por algún motivo me carga el controlador de Intel
> > "snd-intel8x0" y me la idetinfica como tal.
> >
> > Y la placa con ICH7 también lleva "Realtek AC`97 Audio", y carga el
> > mismo controlador "snd-intel8x0" y me la identifica también como
> > Intel.
> >
> > En ambos casos se trata de una tarjeta integrada en la placa, por eso
> > pensaba que los chipset de la misma familia (ICHx) montaban el mismo
> > modelo. O quizás se identifica como Intel pero en realidad es
> > Realtek... hum, qué lío.
>
> Curioso ... el otro día me preguntaba un amigo que por qué no me gustaban
> los chips (VGA, audio, Ethernet, ...) en placa ;)
>
> De todas maneras, comprobaré los módulos y usaré el alsaconf (pasando del
> YaST) a ver si pilla la tarjeta, revisaré los logs y ... os contaré lo que
> encuentre :)
>
> Gracias !!!
>
> Rafa
>
> --
> "Even paranoids have enemies."
>
> Rafa Grimán
> Systems Engineer
>
> Silicon Graphics Spain
> Santa Engracia, 120 - Planta Baja
> 28003 Madrid
> Spain
>
> Tel: +34 91 3984200
> Tel: +34 91 3984201
> Móvil: +34 628 117 940
>
> http://www.sgi.com
>
> OpenWengo: rgriman
> Skype: rgriman



< Previous Next >
References