Mailinglist Archive: opensuse-es (1601 mails)

< Previous Next >
Problema con resolución de nombres y servicios
  • From: "Camaleón" <noelamac@xxxxxxxxx>
  • Date: Fri, 22 Sep 2006 09:48:24 +0000 (UTC)
  • Message-id: <b23e69e70609220248h5d767819y3553ba01c39f85df@xxxxxxxxxxxxxx>
Hola,

Al final decidí instalar Bind9 en un servidor local, con la idea de
que se encargara de resolver las direcciones locales de la red y para
acelerar las peticiones de salida a Internet.

De momento todo va bien, el único problema que tengo es que de vez en
cuando (de forma aleatoria, días sí, día no, día no, día sí...) deja
de resolver (aparentemente, ahora lo explico) sólo en la red interna.

Los equipos clientes (clientes con XP) están configurados para
utilizar los siguientes datos:

Servidor DNS: 192.168.0.1 << servidor con bind9

Si ejecuto en una estación cliente:
nslookup dominio.local

Recibo:
host not found

Pero si desde la misma estación cliente ejecuto:
nslookup google.com

Resuelve correctamente, a través de bind9

Problema: el servicio de correo, ftp... deja de reponder:

smtp.dominio.local
pop3.dominio.local
ftp.dominio.local

(host not found)

En el registro no veo ningún error relacionado con ésto. Y los
servicios están funcionando, porque si desde el equipo cliente
ejecuto:

telnet 192.168.0.1 25

Me responden Postfix, Cyrus o Vsftp según el puerto.

Notas:

- En el mismo servidor resuelve correctamente
- Al cabo de x tiempo, sin hacer nada, vuelve a funcionar en el equipo cliente
- Reiniciando named no se resuelve el problema
- Ocurre de vez en cuando (no siempre)

¿Alguna idea? ¿Estará actualizando algún dato y por eso da ese error aleatorio?

Saludos,

--
Camaleón

< Previous Next >