Mailinglist Archive: opensuse-es (1477 mails)

< Previous Next >
Re: [suse-linux-s] Problemas al instalar aMule
  • From: Guillermo Ballester Valor <gbv@xxxxxxxxxxxx>
  • Date: Tue, 28 Dec 2004 20:27:19 +0100
  • Message-id: <200412282027.27370.gbv@xxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hola,

Por lo que veo, has instalado amule-2.0.0rc8 . Desde luego no es el rpm de mi
repositorio, o tu sistema no es SuSE 9.1. Me explico:

Como no tengo ahora mismo acceso a un SuSE 9.1, desde hace algún tiempo
solamente construyo rpms para SuSE 8.2, 9.0 y 9.2. Ayer construí los rpm de
la 2.0.0rc8 para la SuSE 8.2 y 9.2. Para la SuSE 9.0 me llevará algunos
días. Así que la última version disponible para la 9.0 y 9.1 es la 2.0.0rc7.

Si instalas las rpms del sitio de amule necesitas instalar las librerias que
allí te indican, pero eso puede crearte problemas con dependencias de otros
paquetes. Si instalas las rpm de mi repositorio, debes instalar las librerias
de ese repositorio, donde me he cuidado de que no interfieran con las del
sistema.

Por cierto, para la SuSE 9.2 solamente se necesitan las librerias originales
que trae la SuSE. Para conseguir esto tuve que meter un pequeño parche en
amule.

Espero que esto os aclare un poco el lío de las librerías.

Guillermo

El Martes, 28 de Diciembre de 2004 18:49, Harry Mason escribió:
> Disculpen, pero instale los 6 paquetes y un par mas que me pidio, pero
> ahora dice que le faltan las siguientes dependencias:
> error: Failed dependencies:
> libgd.so.2 is needed by aMule-2.0.0rc8-1
> libwx_base-2.4.so is needed by aMule-2.0.0rc8-1
> libwx_base-2.4.so(WXBASE_2.4) is needed by aMule-2.0.0rc8-1
>
> :/
>
> On Tue, 28 Dec 2004 00:17:51 +0100, antonio-bravo(abs)
>
> <antonio-bravo@xxxxxxxxxxxxxx> wrote:
> > El Lunes, 27 de Diciembre de 2004 16:27, Angel Martinez Cavero escribió:
> > > En primer lugar me gustaría saludar a toda la lista, pues éste es el
> > > primer mensaje que envio ya que soy un recien llegado al mundo del
> > > software libre. :-)
> > > Mi duda viene al tratar de instalar aMule en mi SuSE 9.1. Descargué el
> > > paquete rpm (http://suserpm.webcindario.com/) junto con todas las
> > > dependencias que aparecen en dicha web ( wxGTK, wxBase, etc).
> > > Aparentemente todo se instala sin problemas pero cuando desde la línea
> > > de comandos pretendo arrancarlo el error que devuelve es el siguiente:
> > > /
> > > amule: error while loading shared libraries: libwx_gtk-2.4.so: cannot
> > > open shared object file: No such file or directory
> > >
> > > /Agradezco cualquier sugerencia.
> > > Saludos.
> >
> > Para el amule usa las wxgtk1 y wxbase (las originales modifikadas)
> > para ello descarga los 6 archivos de
> > ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.1-i386/RPMS.suser-gbv/
> >
> > y metelos en una carpeta para luego en consola hacer como root:
> >
> > rpm -Uvh *.rpm
> >
> > dentro de esa carpeta.
> >
> > --
> > Para dar de baja la suscripción, mande un mensaje a:
> > suse-linux-s-unsubscribe@xxxxxxxx
> > Para obtener el resto de direcciones-comando, mande
> > un mensaje a:
> > suse-linux-s-help@xxxxxxxx
>
> --
> Me rindo, al final la respuesta era la que todos conocemos:
> http://www.umsl.edu/~altmanc/holographic.html

- --
Guillermo Ballester Valor
gbv@xxxxxxxxxxxx
Ogijares, Granada SPAIN
Linux user #117181. See http://counter.li.org/
Public GPG KEY http://www.oxixares.com/~gbv/pubgpg.html


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFB0bOfOA2UfsyErNQRAmnTAKCiCnFZkAyPqVwuo9Xtig2BrU9FAwCfXrUq
Ju9oIIRMxdf6Ua3FN5nasBQ=
=5V2g
-----END PGP SIGNATURE-----

< Previous Next >
Follow Ups