Mailinglist Archive: opensuse-es (1643 mails)

< Previous Next >
Re: [suse-linux-s] Fetchmail
  • From: Camaleón <noelamac@xxxxxxxxxxxxxx>
  • Date: Mon, 3 May 2004 20:00:26 +0200
  • Message-id: <200405032000.27297.noelamac@xxxxxxxxxxxxxx>
El Lunes, 3 de Mayo de 2004 19:13, José Rodríguez S. escribió:

> Hola, ya estoy de nuevo con el fetchmail.
>
> La cuestión es que instalo el fetchmail y me hago el .fetchmailrc, lo
> ejecuto como usuario de la siguiente manera:
>
> fetchmail -v -c -p POP3 -u usuario_remoto servidor_pop
>
> y me sale toda la negociación y que tengo dos mensajes.
>
> Ahora hago fetchmail -q para pararlo y recoger los mensajes así:
>
> fetchmail -v -p POP3 -u usuario_remoto servidor_pop
>
> y me devuelve el control de la consola sin mensajes y por más que hago
> mail no tengo mensajes.
>
> Pues esto mismo hago en el portátil, que lo enruta el que tiene
> problemas con el fetchmail, y todo sale de maravilla. De hecho el
> .fetchmailrc es el mismo ya que me lo pasé por ftp en la LAN.
>
> El asunto es muy raro y no creo ya que sea culpa del fetchmail.
>
> El firewall no puede ser porque con evolution bajo bien los correos
> desde la máquina que tiene problemas con fetchmail.
>
> A alguien se le ocurre algo?
>
> Gracias.

Saludos de nuevo,

Pues a mi no se me ocurre nada más de lo que te comenté. Además, no me
acordaba de que yo no utilizo la carpeta /var/mail/usuario pues tengo
configurado un servidor POP3 para tal efecto, por lo que Postfix me lo envía
a otro lado.

Si ejecutas fetchmail en los dos equipo, cuando el portátil se baja los
correos, éstos se borran del servidor, si lo has configurado así, quizá te
esté dando datos correctos. prueba a enviarte un correo y no ejecutar
Fetchmail en el portátil (asegúrate de que no está iniciándose como demonio).

También puedes verificar que la configuración de Postfix es la misma en ambos
equipos (como root #postconf -n), pues se supone que la secuencia de
ejecución es ésta:

Fetchmail > Postfix / Procmail > /var/mail/usuario

Puede ser que Postfix / Procmail no esté enrutando bien el correo o que bien
no haya mensajes.

Saludos,


--
Camaleón

< Previous Next >
This Thread
References