Mailinglist Archive: opensuse-es (1026 mails)

< Previous Next >
Re: [suse-linux-s] No me aclaro con vmware y gcc distinto...
  • From: Pablo Cardozo <pmarmol@xxxxxxxxxxxxxxx>
  • Date: Sat, 03 Apr 2004 00:21:03 -0300
  • Message-id: <406E2D9F.2030602@xxxxxxxxxxxxxxx>
Si no me equivoco, con la letra "q" (sin las comillas) vas hasta el final de la licencia o lo que sea en la consola, y ahí te debe aparecer lo de aceptar o no....

Saludos!!!!

Ian Enrique Najar Perez wrote:

Oye, yo tambien necesito ayuda al respecto, aprovechando el mail, yo tengo un problema: Ya de haber supuestamente haber instalado el RPM de vmware adecuadamente (creo), necesito cofigurarlo ejecutanto vmware-config.pl. Eso hago, despues aparece en la consola que debo leer la licencia, y que oprima Enter para leerla....

Oprimo Enter, y leo toda la licencia.... OOps! ¿como rayos puedo continuar? no aparece nada despues, ni hasta abajo, ni siquiera el "acepto" y el "no acepto" y termino por cerrar la consola a fuerza... ¿Que tecla debo de oprimir? disculpen, a lo mejor es tonta mi pregunta...
"José_Rodríguez S." <telecopower@xxxxxxxxxxxxxx> wrote:
Instala el gcc que necesitas donde quieras.

Luego ve a /usr/bin y cambia el nombre de un archivo que se llama gcc,
que es el que en realidad usa tu máquina, por, por ejemplo, gcc1 y haz
un link con ln -s llamado gcc que apunta hacia el fichero llamado gcc
que acabas de instalar.

Instala el vmware y deshaces lo que hiciste en /usr/bin.


El vie, 02-04-2004 a las 00:10, Alberto escribió:

Aún intentando seguir el hilo que había sobre el vmware y el problema de las distintas versiones de gcc, no me aclaro y no consigo que ande. Resumiendo, he instalado via paquete rpm la última versión de vmware, intento ejecutar vmware-config.pl y me sale lo siguiente:

"Making sure VMware Workstation's services are stopped.

/etc/init.d/vmware: line 339: /sbin/lsmod: No existe el fichero o el directorio
Stopping VMware services:
Virtual machine monitor done

Trying to find a suitable vmmon module for your running kernel.

None of VMware Workstation's pre-built vmmon modules is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

Your kernel was built with "gcc" version "3.3.1", while you are trying to use
"/usr/bin/gcc" version "3.3.2". This configuration is not recommended and VMware
Workstation may crash if you'll continue. Please try to use exactly same
compiler as one used for building your kernel. Do you want to go with compiler
"/usr/bin/gcc" version "3.3.2" anyway? [no] yes

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux-2.4.21-199/include] /usr/src/linux/include

Extracting the sources of the vmmon module.

Building the vmmon module.

Using standalone build system.
make: Entering directory `/tmp/vmware-config7/vmmon-only'
make[1]: Entering directory `/tmp/vmware-config7/vmmon-only'
make[2]: Entering directory `/tmp/vmware-config7/vmmon-only/driver-2.4.21-199-athlon'
make[2]: Leaving directory `/tmp/vmware-config7/vmmon-only/driver-2.4.21-199-athlon'
make[2]: Entering directory `/tmp/vmware-config7/vmmon-only/driver-2.4.21-199-athlon'
make[2]: Leaving directory `/tmp/vmware-config7/vmmon-only/driver-2.4.21-199-athlon'
make[1]: Leaving directory `/tmp/vmware-config7/vmmon-only'
make: Leaving directory `/tmp/vmware-config7/vmmon-only'
Unable to make a vmmon module that can be loaded in the running kernel:
/tmp/vmware-config7/vmmon.o: couldn't find the kernel version the module was compiled for
There is probably a slight difference in the kernel configuration between the
set of C header files you specified and your running kernel. You may want to
rebuild a kernel based on that directory, or specify another directory.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html"; and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html";.

Execution aborted."

Siento todo el rollo pero ahora no se como seguir intento cambiar el gcc pero no tengo idea, si alguien me puede explicar en 2 o 3 pasos (los que sean necesarios) de forma clara para novatos se lo agradecería, e igual que yo otros con el mismo problema ahora o en el futuro.

Por cierto en el apt-get he visto un paquete km_vmware que dice que es para compilar el nucleo o algo asi para vmware lo instalo pero me sigue saliendo lo mismo.

Gracias a todos.






--
Usuario GNU/Linux Nº 276.696
Machine GNU/Linux Nº 243.255
http://counter.li.org/



Nueva forma de conectarse a internet en URUGUAY
------------- Cuanto gasta hoy ? --------------
Tel. 0909.20.30 => Acceso 100% digital 56K!
Promocion lanzamiento: $0,10 mas IVA el minuto.
===============================================
http://www.internet.com.uy - Internet en serio.





< Previous Next >