Mailinglist Archive: opensuse-es (1156 mails)

< Previous Next >
Re: [suse-linux-s] Problemas para montar unidad DVD
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Tue, 30 Dec 2003 00:56:37 +0100 (CET)
  • Message-id: <Pine.LNX.4.53.0312292338410.11680@xxxxxxxxxxxxxxxx>

El 2003-12-29 a las 21:00 +0100, Delta99 escribió:

> Hola Carlos,
>
> El Lunes, 29 de Diciembre de 2003 04:06, Carlos E. R. escribió:
>
> > > # mount /dev/dvd /media/dvd/
> >
> > Debiera ser simplemente "mount /media/dvd".
>
> Tampoco va. El mensaje es:
>
> mount: no se ha podido determinar el tipo de sistema de ficheros y no se ha
> especificado ninguno


Mmm, has puesto casi todos los datos, y no veo errores. A ver, se me
ocurren dos cosas:

¿Has probado con otro DVD? Para empezar, pon el dvd de datos del propio
SuSE, a ver si lo monta. Si lo hace, entonces lo que dice es cierto, que
no le vale el sistema de ficheros del otro dvd.

Si no lo monta, entonces tenemos un problema (Houston... ;-) )

Bueno, en ese caso lo único que no has puesto es el contenido del arranque
del sistema - no todo, sino parte. A ver, las lineas que contengan "dvd" o
parecido:

<4>Kernel command line: splash=silent root=/dev/hdb6 hdc=ide-scsi ...

<4>hdc: IDE DVD-ROM 16X, ATAPI CD/DVD-ROM drive

<4>hdc: attached ide-scsi driver.
<4>hdd: attached ide-scsi driver.
<6>scsi0 : SCSI host adapter emulation for IDE ATAPI devices
<4> Vendor: IDE Model: DVD-ROM 16X Rev: 1.06
<4> Type: CD-ROM ANSI SCSI revision: 02
<4> Vendor: MITSUMI Model: CR-48X8TE Rev: 1.1E
<4> Type: CD-ROM ANSI SCSI revision: 02


Por ahí podremos averiguar si la emulación ide-scsi se está activando o
no.


Reviso tus datos...

> Aquí va el contenido de fstab:
>
> /dev/cdrecorder /media/cdrecorder auto rw,noauto,user,exec 0 0

Debería ser "ro": ten en cuenta que en realidad no se puede escribir en él
por metodos "normales". Mmm, muy curioso, el error que te da al montar el
dvd lo entendería si te da con la grabadora. ¿Podrían estar cruzados?

> /dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
> /dev/dvd /media/dvd auto ro,noauto,user,exec 0 0

Los directorios existen...

Dispositivos en dev parecen OK...

(enlace dvd --> /dev/dvd, etc)

> lrwxrwxrwx 1 root root 3 2003-12-26 11:31 cdrecorder -> sr2
> lrwxrwxrwx 1 root root 3 2003-08-29 00:34 cdrom -> sr0
> lrwxrwxrwx 1 root root 3 2003-12-26 11:31 dvd -> sr1
>
> brw------- 1 delta99 cdrecording 11, 0 2003-03-14 14:07 sr0
> brw------- 1 delta99 cdrecording 11, 1 2003-03-14 14:07 sr1
> brw------- 1 delta99 cdrecording 11, 2 2003-03-14 14:07 sr2

Bueno, yo lo tengo con los "scd0", 1, etc. Nunca recuerdo las diferencias.

>
> Respecto al arranque, en /boot/grub/menu.lst
>
> title linux
> kernel (hd1,1)/boot/vmlinuz root=/dev/hdb2 vga=791 splash=verbose 5
> hdc=ide-scsi hdd=ide-scsi showopts
> initrd (hd1,1)/boot/initrd


Ah, ahí si que veo algo. Tienes tres dispositivos "cederos", pero ahí
arriba sólo veo dos. Espera, no, que dijiste que tenías uno que era SCSI
de verdad:


> 1 unidad CD SCSI
> 1 DVD IDE
> 1 regrabadora IDE


Bueno, razón de más para fijarse en el log del arranque, a ver con que
dispositivos se está reconociendo cada uno.


> No sé si me olvida algo más. Como ves, le he estado dando vueltas. Lo mismo es
> la cosa más tonta del mundo, pero no doy con ella :(

Suele ocurrir :-)

Ah, otra idea: usa "cdrecord -scanbus", a ver que dispositivos scsi lista.
me parece recordar que hay otra herramienta para mirar el bus scsi, quizás
relacionada con el scanner, pero no la recuerdo. Quizás
"sane-find-scanner", pero eso no nos vale.


> ----- Frase del día --------------------------------------------------
> (Sobre Spock)
> McCoy: No se si usted se da cuenta que a ese hombre
> no le funcionan todos los impulsores.
> Kirk: Ya la funcionarán
> McCoy: ¿Está seguro?
> Kirk: ...
> McCoy: Me lo figuraba...
> Star Trek 4: Misión salvar la Tierra

¿De donde las has sacado "en cristiano"?

--
Saludos
Carlos Robinson


< Previous Next >
Follow Ups