Mailinglist Archive: opensuse-es (762 mails)

< Previous Next >
Re: [suse-linux-s] Problemas luego del Update del kernel en Yast-Online?????
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Tue, 19 Aug 2003 01:26:26 +0200 (CEST)
  • Message-id: <Pine.LNX.4.53.0308190111560.3892@xxxxxxxxxxxxxxxx>

El 2003-08-18 a las 07:17, Jordi Rubió escribió:

> los de SuSE pusieron el kernel compilado modificado pero no añaden las source
> con las cabeceras/incudes etc.. correctos al intentar compilar o instalar

Si, si están. Ten en cuenta que los includes son los mismos para todas las
versiones binarias del mismo kernel, es decir, smp, deflt, athlon, etc. La
diferencia está en el "config".

> algo ve que tienes un tal 2.4.20.athlon i lo busca
> i ve las fuentes de 2.4.20 y no lo da por valido

El problema es del programa instalador de nvidia que no es capaz de
detectarlo bien, y si ve alguna diferencia, protesta - unas veces con
razón y otras no. El problema es que el kernel y el driver deben ajustarse
exactamente, hasta en la versión del compilador. Si el driver lo han
preparado para el pentium, y el kernel para el athlon, no vale, y te dice
que tienes que recompilar - con razón. En muchos casos el propio
instalador de Nvidia lo resuelve, pero otras veces te dice que tienes que
recompilar el kernel - por ejemplo si la versión del gcc no coincide, o si
cree que no coincide.

Si Nvidia proporcionara drivers de codigo abierto, no existiría problema
alguno para actualizar.


--
Saludos
Carlos Robinson


< Previous Next >
References