Mailinglist Archive: opensuse-es (399 mails)

< Previous Next >
Re: [suse-linux-s] [ Y sigue ---> XP en hda1 y Linux en hdb1 ]
  • From: Daniel Rs <danes16subscrip@xxxxxx>
  • Date: Tue, 18 Mar 2003 00:25:30 +0100
  • Message-id: <200303180025.30283.danes16subscrip@xxxxxx>
El Lun 17 Mar 2003 11:56, iphase escribió:
> Vamo a vé...
> Tengo en hda1 xp ( Primer disco ) y en el segundo ( hdb1 ) linux...
> Entro al linux mediante disquette , me logeo como root y hago :
>
> dd if=/dev/hdb1 of =/bootsect.lnx bs=512 count=1
>
> y copio /bootsec.lnx a un disquette...
>
> arranco otra vez y booteo en xp ( formateado con NTFS !!!! )....
>
> edito el boot.ini y añado :
>
> c:\bootsec.lnx=Linux
>
> Vuelvo a arrancar y el boot loader del xp me ofrece el arrancar desde
> linux, pero me sale
> el tipico error del lilo ( todo 000000000000000000000000000 ) ...
>
> El lilo esta instalado en la particion raiz de linux ( no en el MBR )
>
> El lilo.conf parece estar bien
>
> Que puñetas pasaa !!!!!!!
>
> Aprovecho para agradecer a todos las respuestas obtenidas tanto en la lista
> como al mail particular.
>
> Un saludo !
>
> -iphase.

A ver, no tengo apenas conocimientos en Linux (aún), eso vaya por delante, y
en mi vida he usado el Windows Xp (ni pienso), así que toma estos apuntes
como meras ideas o sugerencias (porque algo de inteligencia sí que presumo
tener), estoy en plena migración entre plataformas (así que como pájaro
cambiando plumaje o cangrejo ermitaño buscando nueva concha...), ojeo listas,
tutoriales y artículos en los pocos ratos que tengo, así que aprendiendo a
arrancar, poco puedo aportar, pero intuitivamente...(que no técnicamente,
repito):
1-Si llevas varios días con este problemilla, ¿estás seguro de que has hecho
algo más que enviar correos a esta lista para intentar enterarte? ¿has ojeado
algún how-to (aunque breve) sobre arranque dual, Lilo, etc? Hay mogollón de
info por ahí.
2- Si algo no da resultado, no reincidas obstinadamente en ello, cambia el
planteamiento, parte de cero de nuevo, o repasa los pasos que has dado si
estás seguro que debería funcionar (eso requiere algunos conocimientos
técnicos mayormente, no una chuleta de la que copiar las instrucciones).
Incluso, pongamos, siguiendo los pasos desde una chuleta o algo así, ¿lo has
repasado concienzudamente? A veces los fallos están en errores muy muy tontos
(una letra, ...)
3- Instalando Wxp primero (no hay otra opción), y tras él Linux, creo que el
gestor de arranque de éste te da opciones sobre dónde debe colocarse, si
eliges que en el MBR y lo sobreescriba (guarda una copia, tranqui), ¿qué
problema hay? El resultado sería un arranque dual sencillo, gestionado por
Lilo. Eso es lo que a mi me parece que debería suceder, repito que no he
instalado jamás xp y tampoco dices creo qué distro de Linux andas colocando.
4-Si prefieres que el arranque no sea gestionado por Linux, puedes evitar eso
que intentas hacer funcionar sirviéndote del Boot magic (que instalas en
Wxp), en este caso Lilo tendrás que retrasarlo hasta la propia partición
Linux. Supongo que has oido hablar de él, es una pieza indepependiente que
viene con Partition Magic. También hay otros gestores de arranque que no son
de pago (para windows), por si tienes dificultad para hacerte con éste. La
ventaja de Boot Magic es que permite, no sólo un arranque dual, sino
múltiple, reconoce todo tipo de particiones (sistemas de ficheros fat(32),
ntsf, ext(2,3)) y es fácil de manejar (supongo que si quieres aprender y
tienes tiempo, puedes conseguir similares resultados con cuatro líneas bien
puestas en el mbr, si ese es el camino que pretendes (por prurito y demás)
olvida este rollo sin más.
5-El que Linux quieras colocarlo en un hd 2 creo que debería ser indiferente
tratándose de Linux, pero no estoy seguro. Cerciórate de esto.
6-Poco más se me ocurre así a bote pronto, pero he visto en otras ocasiones
mucha info por ahí colgada al respecto de estos temas

Saludos,

< Previous Next >