Mailinglist Archive: opensuse-de (743 mails)

< Previous Next >
Re: Bekomme für Samsung SyncMaster S24A350H nur 800x600: Garfikkarte ist Nvidia N520GT - kein X mehr :-(
  • From: Alexander Beck-Ratzka <alexander.beck-ratzka@xxxxxxxxxx>
  • Date: Sun, 18 Mar 2012 18:52:37 +0100
  • Message-id: <4F6620E5.4090102@aei.mpg.de>
Am 15.03.2012 18:34, schrieb Dieter Klünter:
Am Thu, 15 Mar 2012 13:42:03 +0100
schrieb Alexander Beck-Ratzka<alexander.beck-ratzka@xxxxxxxxxx>:

On Thursday 15 March 2012 11:25:26 Dieter Klünter wrote:
Am Thu, 15 Mar 2012 09:54 +0100

schrieb Alexander Beck-Ratzka<alexander.beck-ratzka@xxxxxxxxxx>:
Hallo Liste,

noch ein wichtiger Nachtrag: Ich habe die Grafikkarte Nvidia
N520GT. Gibt es dafür irgenwelche Treiber? Wie kann ich diese
generische ansteuern?

Hallo Liste,

ich habe mir einen Samsung SyncMaster S24A350H Monitor gekauft -
ein LED Monitor. Dieser kann mit einer Auflösung von 1920x1080
gefahren werden, aber ich kann bei Yast nur die Auflösung
800x600 auswählen.

Ich benutze OpenSuSE 12.1, 64Bit-Version.

Welche / wer weiß Rat?
Nimm NVIDIA in die Software Repositories auf, über Hinzufügen -->
Community/Gemeinschafts-Rositories

und dann erstmal installieren nehme ich an?!? Brauche ich da nicht
eine genaue Adresse des Software Repositories? Ich kenne das nur über
ftp- oder http- Adressen...
In der Liste der Community Repositories ist auch nvidia enthalten, mußt
du nur aktivieren.

Schön wäre es ja gewesen, wenn es gleich gelöappt hätte, es hat aber nicht funktioniert.

Ich hatte nach Installatio (gab gleich einen neuen Kernel und dem Hinzufügen der Zeilen kein X mehr starten können. Ich musste OpenSuSE neu installieren, um wieder eine X-Oberfläche zu haben.

Nun habe ich noch eine andere Variante versucht, und zwar über die URL

http://en.opensuse.org/SDB:NVIDIA_drivers

habe ich "For Geforce FX cards (5xxx) click here: "

versucht, denn ich habe ja die GeForce GT 520.

Ohne ändern von xorg.conf hatte sich nichts geändert. Dann habe ich in einer Datei namens

xorg.conf.install in /etc/X11 Deine Zeilen:

[snip]
Identifier "Device0"
Driver "nvidia"
VenodrName "NVIDIA Cooperation"
EndSection

Section "Screen"
Identifier "Sreen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
SubSection Display
Depth 24
EndSubSection
EndSection
[snip]

hinuzgefügt. Leider konnte ich in der Folge kein X mehr starten. Das geht auch nicht mehr, wenn ich meine ursprüngliche xorg.conf.install in /etc/X11 herstelle (ich sehe dort übrigens kein xorg.conf in diesem Verzeichnis).

Der log vom xstart, sowie meine beiden xorgs im Attachment.

Liebe Grüße

Alexander

P.S. Wie kann ich mein X wenigstens in 800x600 wieder starten??


Section "Device"
Identifier "vboxvideo"
Driver "vboxvideo"
EndSection

Section "Screen"
Identifier "vboxvideo"
Device "vboxvideo"
EndSection


Section "Device"
Identifier "vmware"
Driver "vmware"
EndSection

Section "Screen"
Identifier "vmware"
Device "vmware"
EndSection


Section "Device"
Identifier "cirrus"
Driver "cirrus"
EndSection
Section "Screen"
Identifier "cirrus"
Device "cirrus"
EndSection


Section "Device"
Identifier "fbdev"
Driver "fbdev"
EndSection
Section "Screen"
Identifier "fbdev"
Device "fbdev"
EndSection


Section "Device"
Identifier "vesa"
Driver "vesa"
EndSection

Section "Screen"
Identifier "vesa"
Device "vesa"
EndSection


Section "ServerLayout"
Identifier "Layout"
Screen "vboxvideo"
Screen "vmware"
Screen "cirrus"
Screen "fbdev"
Screen "vesa"
EndSection
Section "Device"
Identifier "vboxvideo"
Driver "vboxvideo"
EndSection

Section "Screen"
Identifier "vboxvideo"
Device "vboxvideo"
EndSection


Section "Device"
Identifier "vmware"
Driver "vmware"
EndSection

Section "Screen"
Identifier "vmware"
Device "vmware"
EndSection


Section "Device"
Identifier "cirrus"
Driver "cirrus"
EndSection
Section "Screen"
Identifier "cirrus"
Device "cirrus"
EndSection


Section "Device"
Identifier "fbdev"
Driver "fbdev"
EndSection
Section "Screen"
Identifier "fbdev"
Device "fbdev"
EndSection


Section "Device"
Identifier "vesa"
Driver "vesa"
EndSection

Section "Screen"
Identifier "vesa"
Device "vesa"
EndSection


Section "Device"
Identifier "Device0"
Driver "nvidia"
VenodrName "NVIDIA Cooperation"
EndSection

Section "Screen"
Identifier "Sreen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
SubSection Display
Depth 24
EndSubSection
EndSection


Section "ServerLayout"
Identifier "Layout"
Screen "vboxvideo"
Screen "vmware"
Screen "cirrus"
Screen "fbdev"
Screen "vesa"
EndSection
[ 55.084]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[ 55.084] X Protocol Version 11, Revision 0
[ 55.084] Build Operating System: openSUSE SUSE LINUX
[ 55.084] Current Operating System: Linux linux-3gwi 3.1.0-1.2-desktop #1
SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64
[ 55.084] Kernel command line:
root=/dev/disk/by-id/ata-ST500DM002-1BD142_Z2AJNLPZ-part6
resume=/dev/disk/by-id/ata-ST500DM002-1BD142_Z2AJNLPZ-part5 splash=silent quiet
vga=0x314
[ 55.084] Build Date: 10 November 2011 03:34:36PM
[ 55.084]
[ 55.084] Current version of pixman: 0.22.0
[ 55.084] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 55.084] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 55.084] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar 18 18:27:20
2012
[ 55.084] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 55.084] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 55.085] (==) No Layout section. Using the first Screen section.
[ 55.085] (==) No screen section available. Using defaults.
[ 55.085] (**) |-->Screen "Default Screen Section" (0)
[ 55.085] (**) | |-->Monitor "<default monitor>"
[ 55.085] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 55.085] (==) Automatically adding devices
[ 55.085] (==) Automatically enabling devices
[ 55.085] (==) FontPath set to:
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/URW/,
/usr/share/fonts/cyrillic:unscaled,
/usr/share/fonts/truetype/,
built-ins
[ 55.085] (==) ModulePath set to
"/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
[ 55.085] (II) The server relies on udev to provide the list of input
devices.
If no devices become available, reconfigure udev or disable
AutoAddDevices.
[ 55.085] (II) Loader magic: 0x7d9140
[ 55.085] (II) Module ABI versions:
[ 55.085] X.Org ANSI C Emulation: 0.4
[ 55.085] X.Org Video Driver: 10.0
[ 55.085] X.Org XInput driver : 12.2
[ 55.085] X.Org Server Extension : 5.0
[ 55.086] (--) PCI:*(0:1:0:0) 10de:1040:1462:2630 rev 161, Mem @
0xfa000000/16777216, 0xe8000000/134217728, 0xf0000000/33554432, I/O @
0x0000e000/128, BIOS @ 0x????????/524288
[ 55.086] (II) Open ACPI successful (/var/run/acpid.socket)
[ 55.086] (II) LoadModule: "extmod"
[ 55.087] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[ 55.087] (II) Module extmod: vendor="X.Org Foundation"
[ 55.087] compiled for 1.10.4, module version = 1.0.0
[ 55.087] Module class: X.Org Server Extension
[ 55.087] ABI class: X.Org Server Extension, version 5.0
[ 55.087] (II) Loading extension MIT-SCREEN-SAVER
[ 55.087] (II) Loading extension XFree86-VidModeExtension
[ 55.087] (II) Loading extension XFree86-DGA
[ 55.087] (II) Loading extension DPMS
[ 55.087] (II) Loading extension XVideo
[ 55.087] (II) Loading extension XVideo-MotionCompensation
[ 55.087] (II) Loading extension X-Resource
[ 55.087] (II) LoadModule: "dbe"
[ 55.088] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[ 55.088] (II) Module dbe: vendor="X.Org Foundation"
[ 55.088] compiled for 1.10.4, module version = 1.0.0
[ 55.088] Module class: X.Org Server Extension
[ 55.088] ABI class: X.Org Server Extension, version 5.0
[ 55.088] (II) Loading extension DOUBLE-BUFFER
[ 55.088] (II) LoadModule: "glx"
[ 55.088] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
[ 55.093] (II) Module glx: vendor="NVIDIA Corporation"
[ 55.093] compiled for 4.0.2, module version = 1.0.0
[ 55.093] Module class: X.Org Server Extension
[ 55.093] (II) NVIDIA GLX Module 173.14.31 Tue Jul 12 09:59:52 PDT 2011
[ 55.093] (II) Loading extension GLX
[ 55.093] (II) LoadModule: "record"
[ 55.094] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[ 55.094] (II) Module record: vendor="X.Org Foundation"
[ 55.094] compiled for 1.10.4, module version = 1.13.0
[ 55.094] Module class: X.Org Server Extension
[ 55.094] ABI class: X.Org Server Extension, version 5.0
[ 55.094] (II) Loading extension RECORD
[ 55.094] (II) LoadModule: "dri"
[ 55.094] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[ 55.094] (II) Module dri: vendor="X.Org Foundation"
[ 55.094] compiled for 1.10.4, module version = 1.0.0
[ 55.094] ABI class: X.Org Server Extension, version 5.0
[ 55.094] (II) Loading extension XFree86-DRI
[ 55.094] (II) LoadModule: "dri2"
[ 55.095] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[ 55.095] (II) Module dri2: vendor="X.Org Foundation"
[ 55.095] compiled for 1.10.4, module version = 1.2.0
[ 55.095] ABI class: X.Org Server Extension, version 5.0
[ 55.095] (II) Loading extension DRI2
[ 55.095] (==) Matched nvidia as autoconfigured driver 0
[ 55.095] (==) Matched nouveau as autoconfigured driver 1
[ 55.095] (==) Matched nv as autoconfigured driver 2
[ 55.095] (==) Matched fbdev as autoconfigured driver 3
[ 55.095] (==) Matched vesa as autoconfigured driver 4
[ 55.095] (==) Assigned the driver to the xf86ConfigLayout
[ 55.095] (II) LoadModule: "nvidia"
[ 55.095] (II) Loading /usr/lib64/xorg/modules/updates/drivers/nvidia_drv.so
[ 55.095] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 55.095] compiled for 4.0.2, module version = 1.0.0
[ 55.095] Module class: X.Org Video Driver
[ 55.095] (II) LoadModule: "nouveau"
[ 55.095] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[ 55.096] (II) Module nouveau: vendor="X.Org Foundation"
[ 55.096] compiled for 1.10.4, module version = 0.0.16
[ 55.096] Module class: X.Org Video Driver
[ 55.096] ABI class: X.Org Video Driver, version 10.0
[ 55.096] (II) LoadModule: "nv"
[ 55.096] (II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
[ 55.096] (II) Module nv: vendor="X.Org Foundation"
[ 55.096] compiled for 1.10.4, module version = 2.1.18
[ 55.096] Module class: X.Org Video Driver
[ 55.096] ABI class: X.Org Video Driver, version 10.0
[ 55.096] (II) LoadModule: "fbdev"
[ 55.096] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 55.096] (II) Module fbdev: vendor="X.Org Foundation"
[ 55.096] compiled for 1.10.4, module version = 0.4.2
[ 55.096] ABI class: X.Org Video Driver, version 10.0
[ 55.096] (II) LoadModule: "vesa"
[ 55.097] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 55.097] (II) Module vesa: vendor="X.Org Foundation"
[ 55.097] compiled for 1.10.4, module version = 2.3.0
[ 55.097] Module class: X.Org Video Driver
[ 55.097] ABI class: X.Org Video Driver, version 10.0
[ 55.097] (II) NVIDIA dlloader X Driver 173.14.31 Tue Jul 12 09:41:01 PDT
2011
[ 55.097] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 55.097] (II) NOUVEAU driver
[ 55.097] (II) NOUVEAU driver for NVIDIA chipset families :
[ 55.097] RIVA TNT (NV04)
[ 55.097] RIVA TNT2 (NV05)
[ 55.097] GeForce 256 (NV10)
[ 55.097] GeForce 2 (NV11, NV15)
[ 55.097] GeForce 4MX (NV17, NV18)
[ 55.097] GeForce 3 (NV20)
[ 55.097] GeForce 4Ti (NV25, NV28)
[ 55.097] GeForce FX (NV3x)
[ 55.097] GeForce 6 (NV4x)
[ 55.097] GeForce 7 (G7x)
[ 55.097] GeForce 8 (G8x)
[ 55.097] GeForce GTX 200 (NVA0)
[ 55.097] GeForce GTX 400 (NVC0)
[ 55.097] (II) NOUVEAU driver
[ 55.097] (II) NOUVEAU driver for NVIDIA chipset families :
[ 55.097] RIVA TNT (NV04)
[ 55.097] RIVA TNT2 (NV05)
[ 55.097] GeForce 256 (NV10)
[ 55.097] GeForce 2 (NV11, NV15)
[ 55.097] GeForce 4MX (NV17, NV18)
[ 55.097] GeForce 3 (NV20)
[ 55.097] GeForce 4Ti (NV25, NV28)
[ 55.097] GeForce FX (NV3x)
[ 55.097] GeForce 6 (NV4x)
[ 55.097] GeForce 7 (G7x)
[ 55.097] GeForce 8 (G8x)
[ 55.097] GeForce GTX 200 (NVA0)
[ 55.097] GeForce GTX 400 (NVC0)
[ 55.097] (II) FBDEV: driver for framebuffer: fbdev
[ 55.097] (II) VESA: driver for VESA chipsets: vesa
[ 55.097] (--) using VT number 2

[ 55.107] (II) Loading sub module "fb"
[ 55.107] (II) LoadModule: "fb"
[ 55.107] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 55.108] (II) Module fb: vendor="X.Org Foundation"
[ 55.108] compiled for 1.10.4, module version = 1.0.0
[ 55.108] ABI class: X.Org ANSI C Emulation, version 0.4
[ 55.108] (II) Loading sub module "wfb"
[ 55.108] (II) LoadModule: "wfb"
[ 55.108] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 55.108] (II) Module wfb: vendor="X.Org Foundation"
[ 55.108] compiled for 1.10.4, module version = 1.0.0
[ 55.108] ABI class: X.Org ANSI C Emulation, version 0.4
[ 55.108] (II) Loading sub module "ramdac"
[ 55.108] (II) LoadModule: "ramdac"
[ 55.108] (II) Module "ramdac" already built-in
[ 55.108] (II) Loading /usr/lib64/xorg/modules/updates/drivers/nvidia_drv.so
[ 55.108] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 55.108] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 55.108] (WW) Falling back to old probe method for fbdev
[ 55.108] (II) Loading sub module "fbdevhw"
[ 55.108] (II) LoadModule: "fbdevhw"
[ 55.108] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 55.108] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 55.108] compiled for 1.10.4, module version = 0.0.2
[ 55.108] ABI class: X.Org Video Driver, version 10.0
[ 55.108] (WW) Falling back to old probe method for vesa
[ 55.108] (II) NVIDIA(0): Creating default Display subsection in Screen
section
"Default Screen Section" for depth/fbbpp 24/32
[ 55.108] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 55.108] (==) NVIDIA(0): RGB weight 888
[ 55.108] (==) NVIDIA(0): Default visual is TrueColor
[ 55.108] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 55.108] (**) NVIDIA(0): Enabling RENDER acceleration
[ 55.108] (II) NVIDIA(0): Support for GLX with the Damage and Composite X
extensions is
[ 55.108] (II) NVIDIA(0): enabled.
[ 55.112] (EE) NVIDIA(0): The NVIDIA GPU at PCI:1:0:0 is not supported by
the 173.14.31
[ 55.112] (EE) NVIDIA(0): NVIDIA driver.
[ 55.112] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
[ 55.112] (II) UnloadModule: "nvidia"
[ 55.112] (II) Unloading nvidia
[ 55.112] (II) UnloadModule: "wfb"
[ 55.112] (II) Unloading wfb
[ 55.112] (II) UnloadModule: "fb"
[ 55.112] (II) Unloading fb
[ 55.112] (EE) Screen(s) found, but none have a usable configuration.
[ 55.112]
Fatal server error:
[ 55.112] no screens found
[ 55.112]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 55.112] Please also check the log file at "/var/log/Xorg.0.log" for
additional information.
[ 55.112]
< Previous Next >