Mailinglist Archive: opensuse-de (871 mails)

< Previous Next >
Re: mein gateway routed nicht :-(
  • From: Martin Deppe <Martin.Deppe@xxxxxx>
  • Date: Wed, 15 Jun 2011 19:04:43 +0200
  • Message-id: <4DF8E62B.6060101@web.de>
Am 15.06.2011 06:44, schrieb Kyek, Andreas, VF-DE:
Martin.Deppe@xxxxxx wrote:
[...]

ich habe jetzt mal auf gw2 eine route wie folgt eingerichtet:

Warum auf gw2? Der hat doch ein Interface für das 3er Segment, oder?
Damit brauchst hier IMO du keine extra Route einzurichten.

IIRC sind das deine Rechner/IPs:
NB (wlan:192.168.3.50)
gw2 (wlan1:192.168.3.1, eth0:192.168.1.2, eth1:not configured),
gw (eth0:192.168.1.1)

Hast du die route für das 3er Segment auf deinem gw eingerichtet?
Dieser Eintrag:
192.168.3.0 192.168.1.2 255.255.255.0 UG ... eth0
gehört IMO bei gw eingerichtet

[...]

Also, es geht jetzt so ziemlich alles, was soll, nachdem ich die
Verbindung vom Notebook nochmal neu aufgebaut und den
DHCP-Server bezgl.
DNS und Default-GW korrekt eingestellt habe, außer daß ich
vom Notebook
keine Namensauflösung bekomme. Es geht sogar ein "ping 195.135.220.3"
(www.suse.de), nicht allerdings "ping www.suse.de". Vom
gateway2 aber schon.

Ich denke, daß hängt damit zusammen, daß ich mein DNS noch
nicht richtig konfiguriert habe.

Entweder DNS oder Routing


Bisher hatte ich nur ein Netzwerksegment (192.168.1.*) und
jetzt sind es zwei (192.168.3.*). Alle gültigen Adressen für
beide Segmente sind in der Datei "master/my.site.zone" definiert.
Das ist wahrscheinlich so falsch oder nicht ausreichend.
Hättest Du da vielleicht adhoc einen Tipp?
Ansonsten muß ich jetzt da mal auf die Suche gehen.

Ähnliches habe ich zu Hause auch laufen:
bei mir sind es
EINE Datei für "domain_name".zone mit ALLEN Hosts
ZWEI Dateien für die Segmente 0.168.192.zone und 128.168.192.zone
für die Reverse Auflösung.

Das müsste also gehen. Wenn du auf gw oder gw2 ALLE deine Hosts im
DNS vorwärts und rückwärts auflösen kannst ist das nicht der Fehler.

Hast du deinem DNS auch gesagt, das PCs aus dem 3er Segment abfragen
dürfen? Bir mir in /etc/named.conf unter "allow-query", falls du hier
Einschränkungen konfiguriert hattest?

Ansonsten zeig doch nochmal (unter der Annahme, das die IPs oben richtig
sind) die folgenden Ausgaben:
a) gw: route -n
b) gw2: route -n

Andreas

Hallo Andreas,

die Routen sind derzeit wie folgt gesetzt:

gateway:~ # netstat -r
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt
Iface
lo1.br04.acham. * 255.255.255.255 UH 0 0 0
dsl0
192.168.3.0 * 255.255.255.0 U 0 0 0
eth0
192.168.1.0 * 255.255.255.0 U 0 0 0
eth0
192.168.0.0 * 255.255.255.0 U 0 0 0
eth1
loopback * 255.0.0.0 U 0 0 0 lo
default * 0.0.0.0 U 0 0 0
dsl0
gateway:~ #

gateway2:~ # netstat -r
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt
Iface
192.168.1.0 * 255.255.255.0 U 0 0 0
eth0
loopback * 255.0.0.0 U 0 0 0 lo
default 192.168.1.1 0.0.0.0 UG 0 0 0
eth0
gateway2:~ #

Tja, und jetzt geht wieder weniger - Mist.

Ich bekomme jetzt allerdings die Namensauflösung im Intra-Net hin (habe
anfragen aus dem 3er-Netz erlaubt).

Danke Dir
Martin
--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >