Mailinglist Archive: opensuse-de (871 mails)

< Previous Next >
Re: mein gateway routed nicht :-(
Am Mittwoch, 8. Juni 2011 21:09 schrieb Martin Deppe:
Am 07.06.2011 06:47, schrieb Kyek, Andreas, VF-DE:
Ralf Arndt wrote:

Hallo Martin,
bist du sicher, das er nicht weiter routet?

Oder kann es nicht sein, das dein eigentlicher gateway mit der
IP 192.168.1.1 nur einfach nicht weiss, wohin er die Antwort
schicken soll?
[...]
Die Rückroute muss konfiguriert sein!
(beliebter Fehler bei neuen Segmentierungen hinter Routern)

Andreas

Hallo Andreas, hallo Ralf,

danke für eure Antwort,

damit bin ich schon mal einen Schritt weiter gekommen.

Immerhin hat mein Gateway1 schon mal bis zum Notebook zurück
geantwortet, in's Internet bin ich allerdings noch nicht
gekommen. Danach geht jetzt allerdings auch das wieder nicht und
ich weiß nicht, was ich jetzt gemacht habe. Es ist zum verrückt
werden. Ich befürchte allerdings, daß ich mich geirrt habe, es
ging gar nicht und ich habe mich nur verguckt.

Ok! Ich habe jetzt wenigstens über Samba das Home-Laufwerk von
Gateway2 an das Notebook erfolgreich angebunden. Desgleichen
kann ich vom Notebook auch meinen Webserver auf Gateway2
erreichen. Schritt für Schritt kommt man sich näher (der
Webserver ging allerdings schon am Montag).

Klar, die beiden haben auch "direkten" Kontakt und kenne die
gegenseitigen IP Adesssen im gemeinsamen 3'er Subnetz.

@Ralf

1. Benötigst Du denn 2 verschiedene Subnets (192.168.1.0 und
192.168.3.0)?

Ich denke schon, es sei denn, ich kann wlan1 und eth0 auf
demselben Rechner in dasselbe Subnetz packen. Meines Wissens
geht das nicht, aber es könnte die Sache vereinfachen. Wenn ich
es mir so überlege, sollte es gehen, wenn zwischen eth0 und
wlan1 eine Bridge existiert, richtig? Und wie richte ich die
dann ein?

Genau das meine ich, gateway2 bridged zwischen wlan und lan. Ich
habe allerdings noch nie einen AP auf einem Rechner eingerichtet. Da
sollte jemand anderes helfen. Das sollte aber nicht so schwierig
sein.

Andererseits stellt sich mir die Frage, ob es sich nicht lohnt einen
"dedicated" AP zu kaufen. Ich schätze mal die Kosten liegen irgendwo
zwischen 10,- und 30,- €. Der Vorteil liegt alleine schon im
Stromverbrauch, Dein Linux Rechner muss nicht ständig an sein. Mein
alter Netgear AP hat jedenfalls out-of-the-box gebridged.

2. Wie sind die Netzwerkeinstellungen des Windows Client
konfiguriert

(statisch oder dynamisch)?

Ausgabe auf Windows Client von "ipconfig /all"

[...]
Ethernetadapter Drahtlose Netzwerkverbindung:
Verbindungsspezifisches DNS-Suffix: my.site
Beschreibung. . . . . . . . . . . : Intel(R) PRO/Wireless
3945ABG Network Connection
Physikalische Adresse . . . . . . : XX-XX-XX-XX-XX-XX
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
IP-Adresse. . . . . . . . . . . . : 192.168.3.50
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.1.1
DHCP-Server . . . . . . . . . . . : 192.168.3.1
DNS-Server. . . . . . . . . . . . : 192.168.3.1
Lease erhalten. . . . . . . . . . : Mittwoch, 8. Juni
2011 20:43:48 Lease läuft ab. . . . . . . . . . : Donnerstag, 9.
Juni 2011 00:43:48

Der Client im 3'er Netz und sein Standardgateway im 1'er Netz. Das
kann nicht funktionieren.

Hier ist der DNS-Server auch noch falsch eingestellt. Ich hatte
ihn allerdings (gateway2-seitig) auf 192.168.1.1 gesetzt und er
wurde jetzt auf obige Adresse umgestellt - keine Ahnung wodurch.

Ja vermutlich für gateway2 als Client. Aber liefert gateway2 das als
DHCP Server an seine Clients weiter? Ich vermute nicht!

3. Falls dynamisch:
Wer liefert DHCP?

Für das wlan ist es gateway2

Wer liefert DNS?

DNS soll eigentlich gateway1 liefern, da das Routing z.Z. nicht
geht, geht natürlich auch das nicht!

Das sind multiple Fehler. Den Widerspruch kannst Du bereits oben
sehen. Für Deinen Windows Rechner müssen:

1. Das Standardgateway im selben Subnetz liegen (also 192.168.3.0)

2. Der DNS Server (bei Dir gateway2 192.168.3.1) auch DNS liefern.

4. Hast Du auf dem gateway2 routing aktiviert?
Hab ich noch nicht benötigt, aber IIRC gibt es da eine
Einstellung in

yast.
ja, gibt es und ich dachte die nötigen Einstellungen auch gemacht
zu haben, aber irgendwo hakts halt.

s.o.
Dazu kommt der Einwand von Andreas:
Wenn Du mehrere Subnetze aufteilst müssen die anderen Rechner auch
wissen, wie sie in das 3'er Netz kommen. Das kannst Du evtl. noch
zentral gerade biegen, indem Du auf deren Defaultgateway (vermutlich
192.168.1.1) gateway2 als Router in das 3'er Subnetz einträgst.

Ich stelle gerade fest, daß ich es mir wahrscheinlich unnötig
schwer mache, dadurch, daß ich mir bisher gateway2 nicht als
einziges Gateway eingerichtet habe (so soll es sein, wenn alles
funktioniert, um das Alte abzulösen). Es muß aber auch so gehen
und ich will es endlich ausreichend verstehen. Ich dachte
allerdings, daß würde ich schon!

Siehe oben, wie wäre es mit einem fertigen AP

Schlaft gut
Ralf

--
Antworten bitte nur in die Mailingliste!
PMs bitte an: listpm (@) arndt-de (.) eu
--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >