Mailinglist Archive: opensuse-de (1283 mails)

< Previous Next >
gesamter Rehner plötzlich extrem lahm
  • From: Norbert Zawodsky <norbert@xxxxxxxxxxx>
  • Date: Sun, 01 Aug 2010 03:19:07 +0200
  • Message-id: <4C54CB8B.2060002@xxxxxxxxxxx>
Hallo ML!

Ich wende mich heute mit einem Problem an Euch bei dem ich einfach nicht
mehr weiter weiß:

Hier läuft ein SuSE 11.2, 64bit auf einem Intel Core i7 PC mit 4GB Ram.
Grafikkartre ist eine Nvidia.

Ich verwende den Rechner als meinen persönlichen Arbeitsplatz und "ganz
nebenbei" ist er auch server für die restliche Firma (apache (nur
intern), mySQL, IMAP, SAMBA, NFS, CUPS, ..... das "Übliche" sozusagen)
Der Rechner hat so viel power dass er das alles "mit Links" erledigt und
ich am Desktop (KDE 4) immer noch eine tolle performance habe.

Meine "Standardprogramme" bei der Arbeit sind Thunderbird, Firefox und
OpenOffice die auch immer alle gleichzeitig geöffnet sind. Der
Donnervogel ist zum cyrus@localhost verbunden. Im Firefox habe ich
meistens 7-8 Tabs offen, die alle etwas vom lokalen Indianer wollen.
Meistens über phpMyAdmin -> mySQL.
Und im Openoffice sind meistens 1-2 große calc-sheets offen, die
ihrerseits intensiv über OpenOffice->JDBC->mysql mit der Firmendatenbank
plaudern.
Ach ja, ein vmware mit XP als Gast läuft auch immer. (Natürlich im
"unity" mode)

Alles kein problem und blitzschnell.

Aber manchmal passiert es dass der gesmate Rechner plötzlich extrem lahm
wird. Ein klick auf irgend einen Button brauch oft 1-2 Minuten bis eine
Reaktion sichtbar wird. Aber es ist nicht nur mein Desktop betroffen.
Auch Anfragen über's LAN die sonst im ms-Bereich beantwortet werden
brauchen oft mehrere Minuten.

Das Eigenartige ist nun, dass dass immer nur dann passiert, wenn die 3
genannten Standardprogramme (thunderbird, Firefox + OO) gleichzeitig
laufen. Ich hatte zu Testzwecken den TB schon mal mehrere Tage alleine
(ohne die anderen beiden) offen, und das problem trat nicht auf.
Gleiches habe ich auch mit OO probiert. Ebenfalls kein Problem.

Heute, als es wieder mal passierte habe ich mir die Zeit genommen und
die "systemüberwachung" gestartet. (Es hat eh nur 4 Minuten gedauert bis
das Programm da war).
Es zeigte CPU 6 auf permanent 100%, alle anderen 7 CPUs "langweilten"
sich mit <1% Last. Ein klick auf die Prozessliste (2 minuten) und dann
sortiert nach CPU-Last (wieder einige Minuten) ergab nur 3-4 Prozesse,
die abwechselnd im 1% Bereich die Liste "anführten". Meine 3 programme
waren jedoch NIE dabei.

Dann sortiert nach Speicher (wieder einge MInuten warten...) ergab
ebenfalls absolut nichts auffäliges. KEIN Prozess, der durchgedreht
hätte und wie verrückt Speicher anfordert... Alle brav und ruhig.

Nachdem ich schon öfters in dieser Situation war habe ich schon
verschiedene Strategien versucht. Ein beenden von OpenOfice bringt
meistens etwas entspannung. Das System wird etwas schneller und reagiert
wieder so halbwegs.
Ein beenden von Thunderbird bewirkt meistens eine signifikante
Verbesserung. Aber nur wenn ich alle 3 Programme beende läuft wieder
alles auf Vollgas.

Was ich nicht verstehe: Oft arbeite ich stundenlang mit den 3 Programmen
und nichts passiert. Und dann ist das Problem plötzlich da.
Und wie kann 1 Userspace-Prozess das gesamte System derart lahm legen,
wenn gleichzeitig 7 von 8 CPUs "nichts zu tun haben"?

Gibt es ein tool dass ich in der Situation (mit viel Geduld) aufrufen
könnte, das mir etwas mehr Information liefert? Die Übilchen (z.B.
"top") liefern rein gar nichts aussagekräftiges...

Ein hardware-problem kanns nicht sein. Sonst wäre es nicht so
ausnahmslos an diese 3 Programme gebunden.

Ich bin völlig ratlos WO ich zu forschen beginnen soll....

Grüße,
Norbert

--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >
List Navigation