Mailinglist Archive: opensuse-de (977 mails)

< Previous Next >
gelöst Re: Apache macht mich wahns innig
  • From: Bodo Wlaka <admin@xxxxxxxxxx>
  • Date: Tue, 27 Oct 2009 17:00:10 +0100
  • Message-id: <4AE7190A.7010005@xxxxxxxxxx>
Hallo Philipp, Marcus und Markus

Hab das jetzt gelöst bekommen.
Wundern tut mich trotzdem warum das alles so kompliziert war.
Ich hatte den gesamten Apache-Kram ins neue kopiert und vorher lief es
damit.

Ok, der Hinweis mit php5 hab ich zwischenzeitlich auch rausgefunden.

Ich hab allerdings den Eintrag php5 in der Mime.types hinzugepackt.

Jedoch kam zusätzlich noch der Suhosin-Patch ins Spiel, denn er wollte
mir immer noch nicht die index.php öffnen, sondern bot sie mir zum
Speichern an.
Ich hatte zwischenzeitlich aber auch noch Änderungen an der httpd.conf
gemacht, nämlich

AddHandler application/x-httpd-php .php
AddHandler application/x-httpd-php-source .phps

<Directory /srv/www/htdocs/openTimetool>
Options +Indexes +FollowSymLinks
DirectoryIndex index.php
AllowOverride All
</Directory>

Das brauchte ich bei der SLE nicht. Warum jetzt? Keinen Schimmer.

Der Suhosin-Patch war es schlussendlich auch, der mich nicht tief genug
in die Verzeichnisse lassen wollte.
Nun hab ich den Wert für max.exeutor.depth von 1 auf 0 also disabled und
nun können wir wieder unsere Zeiten erfassen.

Nebenbei bemerkt, das Tool OpenTimetool ist zwar recht nett, aber wie
Philipp schon schrieb etwas unsicher bzw. mit div. Unzulänglichkeiten
programmiert.
An irgendeiner Stelle (weiß jetzt nicht genau wo) schreibt der Schöpfer
auch etwas von wegen er wisse nicht genau warum das ist und wieso es
passiert aber es müsse dieser würgaround genommen werden.
Ebenso passiert es, das man irgendwann keine Einträge mehr machen kann
und muß dann die entsprechenden Daten in der DB touchen.
Offensichtlich wurden die Daten in der DB zu lange nicht verändert und
dann kann man auch nix neu hinzufügen. Ein touch reicht.

Also noch etwas buggy das Teil, aber für uns tut es das, was es muß.

Markus Heinze schrieb:
Moin moin,

Der Migrationspfad von SLES10SP1 zu openSuSE 11.1 is schon komisch ...

Wie meinst Du das?



Dies liegt wahrscheinlich daran das php nicht aktiviert ist, editiere
mal in der /etc/sysconfig/apache2 die Variable APACHE_MODULES und füge
'php5' hinzu, rcapache restart und alles sollte im grünen Bereich sein ;)

Also Danke an alle für die Tips, es läuft jetzt. ;-)

Jetzt kommt noch Samba dran.

Gruß
Bodo
--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups