Mailinglist Archive: opensuse-de (977 mails)

< Previous Next >
Re: HD lt. smartctl ok, badblocks meckert gewaltig, manchmal im Bios nicht erkannt
  • From: Al Bogner <suse-linux@xxxxxxxxxxxxxxxxxxxx>
  • Date: Tue, 6 Oct 2009 11:59:50 +0200
  • Message-id: <200910061159.50390.suse-linux@xxxxxxxxxxxxxxxxxxxx>
Am Dienstag 06 Oktober 2009 04:23:46 schrieb David Haller:

Hallo David,

Am Die, 06 Okt 2009, Al Bogner schrieb:
Ich frage mich gerade was es sein könnte, bzw. wie ich eine HD reklamieren
soll.

Die HD wird im Bios meistens nicht erkannt, manchmal aber schon. badblocks
-svw bringt im 1. Durchgang von 4 keine Probleme, im 2. "rauschen" die
Badblocks nach einiger Zeit nur so vorbei und dieses Verhalten gibt es in
2 Rechnern.

Du hast die eine Platte in 2 Rechnern getestet?

Ja im alten Server, bei dem ich den Verdacht habe, dass das Mobo ein Problem
haben könnte.

Interessanterweise läuft im neuen Rechner eine 200GB SATA Maxtor aus dem alten
Rechner nun völlig problemlos. Installieren konnte ich anfangs nicht,
ähnliches Problem wie für die 1 TB-HD beschrieben, d.h. Neuinstallation kommt
nicht bis zur Partitionierung. Mit der Maxtor konnte ich das Rescue-System
aber nach langer Zeit bis zum Login hochzufahren und seit einem schreibenden
badblocks ist alles ok. Daher mein Verdacht, ich brauche auch bei der TB-HD
ein badblocks, aber das lief nie komplett durch, weder am alten noch am neuen
Rechner. Die SATA-Kabel bei den 1TB-HDs wurden vom alten Rechner mitgenommen,
die Maxtor erhielt ein neues SATA-Kabel.

Merkwürdig finde ich, dass badblocks stundenlang auf beiden PCs schreibend
läuft und jedesmal im 2. Durchgang hängen bleibt. Ich habe mittlerweile
herausgefunden, dass die HD dann nicht mehr ansprechbar ist, wenn die
Fehlermeldungen kommen, d.h. ein fdisk -l findet die HD nicht mehr, smartctl
auch nicht.

Welche Fehlermeldungen (ein Beispiel je Fehlertyp reicht) finden sich
im syslog (/v/l/m, dmesg)?

Ich habe vom Rescue-System gestartet, mache aber badblocks demnächst vom
normalen System, kaufe mir vorher zur Vorsicht andere Kabel. Die Tests wurden
alle bei offenem Rechner gemacht, d.h. das Kabel ist beim Test sicher nicht
abgeknickt.

Braucht man für SATA-300 unbedingt andere SATA-Kabel als für SATA-150? Beim
Casetek-Gehäuse öffnet der 3.5"-Käfig zur Seitenwand und ein gerader Stecker
ist da ziemlich knapp. Mit Winkelstecker haber ich aber nur SATA-150-Kabel
gefunden.

/usr/sbin/smartctl -s on -t long /dev/sdb ist noch nicht ganz durch,
"short hat aber keine Probleme gemeldet.

-t long sollte schon mal durchlaufen.

Was ist wenn der SATA-Stecker an der HD einen Defekt (Kontaktfehler) hat?
Würde da nicht smartctl ohne Fehler durchlaufen?

Und zeig anschließend die Ausgabe von 'smartctl -A /dev/sdX' der
Platte (und evtl. den Selftest bezogenen Teil am Ende der Ausgabe von
'smartctl -a /dev/sdX'.

Folgt. Ich mache gerade einen RAM-Test von der 11.1-Installations-DVD (seit
ca. 12h). Für Videos ist das System noch zu problematisch. Wie lange sollte
man 2x2GB testen? Bis jetzt gab es keine Fehler. 1 Riegel war bei den
Kontakten mit einem Aufkleber überklebt. Beim Hochfahren des Boards macht der
Speicher bei ca. 3GB eine kurze Pause, bis bis 4GB weitergezählt wird.

Die SATA-Kabel habe ich bereits vertauscht.

Zufällig noch ein drittes verfügbar?

Wird heute gekauft.

Wenn ich den Rechner mit 11.1 neu installieren will oder das Rescue-System
starte, dauert es _sehr_ lange bis es manchmal weiter geht, Minuten länger
wie normal.

Wenn ich Pech habe, komme ich bei einer Neuinstallation gar nicht bis zur
Partitionierung. Ziehe ich das 1 SATA-Kabel ab, dann ist alles gewohnt
schnell.

Hm? Was willst du uns damit sagen? Wenn du die problematische Platte
abklemmst geht alles flott? Oder was?

Genau. Eine von den 2 1TB-HDs weg und keine Probleme. Also insgesamt sind da
2x1TB und 1x200GB verbaut.

Nachdem ich das SATA-Kabel bereits vertauscht habe und sich nichts
ändert, sobald 3 SATA-HDs angeschlossen sind,

3 beliebige? (du hast nur 3 Platten da, nehme ich an)

Die 200GB-HD ist am neuen Kabel angeschlossen, das beim Mobo dabei war.

d.h. meistens gibt es
Probleme und bei 2 nicht, schließe ich auf die HD?

Gibt's die Probleme auch nicht mehr wenn du eine der anderen Platten
abklemmst? Was wenn du nur die vermutete Problemplatte und eine der
anderen dranhast?

Mittlerweile war die 2. TB-HD, die noch nie Probleme machte nach Kabeltausch
auch nicht ansprechbar. Ich denke ich brauche unbedingt andere SATA-Kabel zum
Testen.

Nur wie kann ich nachweisen, dass die HD Fehler macht. Sie wurde vor ca. 1
Monat gekauft und fast nicht verwendet. 1TB mit badblocks testen dauert ja
eine ganze Weile, soll ich mal nicht abbrechnen, wenn die vielen Fehler
kommen?

Letztlich bestehen die Plattenhersteller gerne darauf, daß man die
Platte mit dem eigenen Tool überprüft (URLs kann ich raussuchen). Auf
ner c't-CD/DVD waren die auch neulich mal fast komplett versammelt.

Noch habe ich Händlergarantie.

Die Tools machen aber i.d.R. auch nix anderes als den SMART-Status
abzufragen und ggfs. ein badblocks (u.U. auch schreibend) + erneutes
Status abfragen. Sowohl Hersteller als auch Händler sollten da mit
sich reden lassen.

Ja eben und wenn smartctl keinen Fehler zeigt, ist das schwierig.

Ich würde an deiner Stelle (nachdem obige Fragen von mir und evtl. von
anderen geklärt sind), das badblocks durchlaufen lassen,

So sehe ich das auch, nur muss ich erst einmal dahinter kommen, warum das nach
Stunden Fehler bringt bzw. die HD nicht mehr erkannt wird. Komisch, dass das
eventuell defekte Kabel > 3h keine Fehler bringt. Der Rechner wird dabei nicht
angerührt oder bewegt. Ich werde mir das nächste Mal das syslog anschauen.

'smartctl -a'
ausdrucken und damit zum Händler (Anhand der Seriennummer auf dem LW
und in der smartctl Ausgabe gibt's ja ne Zuordnung). I.d.R. sollten
die badblocks und smartctl kennen ... Aber gucken wir uns doch erstmal
die Ausgabe von smartctl an ;)

Ist aber sinnlos, wenn smartctl- keine Fehler zeigt. Damit widerspreche ich ja
gerade meiner Reklamation. Wenn da ein Kontaktfehler beim Kabelanschluss ist,
dürfte mir smartctl nicht helfen.

Al
--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >
References