Mailinglist Archive: opensuse-de (696 mails)

< Previous Next >
Update von KDE 4.2.4 auf KDE 4.3
  • From: Herbert Albert <h.albert@xxxxxx>
  • Date: Sat, 15 Aug 2009 19:10:58 +0200
  • Message-id: <200908151910.58353.h.albert@xxxxxx>
Hallo Liste,

hat jemand ein Kochrezept für das stressfreie Update von KDE 4.2.4
aktuelle Repos:
http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.1/

http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42/
auf KDE 4.3.

Mein OS ist 11.1 x86_64.

Neben KDE 4.3 möchte ich auch mein KDE 4.1.3 behalten um
a) eine Not- bzw. Rückfalllösung zu haben, wenn mal KDE 4.3 nicht will z.B.
Anmeldung via kdm und ganz wichtig
b) bestimmte Funktion aus 4.1.3er-Paketen zu nutzen, die es unter der
höheren Version bisher nicht gab. Ich denke da nur an die Möglichkeit
des Broschürendrucks mit kprinter via Filter und psutils & Co, den ich
häufig brauche.

Google hat mir teils widersprüchlich Aussagen geliefert, vor allem was qt
angeht. Mal ist in den Anleitungen von qt überhaupt keine Rede, dann wird ein
Update auf qt4.5 obligatorisch. Was nun?
Ich habe bezüglich qt i.M. folgendes installiert:
zypper se 'qt*' | grep "i |"
i | qt3 | A library for developing applications with
graphical user interfaces | Paket
i | qt3-32bit | A library for developing applications with
graphical user interfaces | Paket
i | qt3-devel | Include Files and Libraries mandatory for
Development | Paket
i | qtiplot | Data analysis and scientific plotting. (Free
clone of Origin) | Paket
zypper se 'libqt*' | grep "i |"
i | libQtWebKit-devel | libqt4: collective bug fix update

| Patch
i | libQtWebKit4 | C++ Program Library, Core Components

| Paket
i | libqt4 | C++ Program Library, Core Components

| Paket
i | libqt4-32bit | C++ Program Library, Core Components

| Paket
i | libqt4-qt3support | C++ Program Library, Core Components

| Paket
i | libqt4-qt3support-32bit | C++ Program Library, Core Components

| Paket
i | libqt4-sql | Qt 4 SQL related libraries

| Paket
i | libqt4-sql-32bit | Qt 4 SQL related libraries

| Paket
i | libqt4-sql-mysql | Qt 4 MySQL support

| Paket
i | libqt4-sql-sqlite | Qt 4 sqlite plugin

| Paket
i | libqt4-x11 | Qt 4 GUI related libraries

| Paket
i | libqt4-x11-32bit | Qt 4 GUI related libraries

| Paket

Wird es also reichen, die o.g. KDE 4.2.4-repos in den Software-Repositories
auszukommentieren und dafür die Repos:
http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1/
http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop/
aufzunehmen und mich die Abhängigkeitskonflikte in YaST Stück für Stück lösen
oder muss ich noch qt 4.5 aus
http://download.opensuse.org/repositories/KDE:/Qt45/openSUSE_11.1/
hinzunehmen?

Wie gesagt, die KDE 4.1.3er-Pakete will ich behalten.

Gruß

Herbert

--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >