Mailinglist Archive: opensuse-de (864 mails)

< Previous Next >
Re: SATA-Wechselrahmen
  • From: Volker Kuhlmann <list0570@xxxxxxxxxxxxxxx>
  • Date: Wed, 08 Jul 2009 13:59:26 +1200
  • Message-id: <20090708015926.GA16720@xxxxxxxxxxxxxxx>
On Wed 08 Jul 2009 04:07:04 NZST +1200, Volker Fervers wrote:

Dann sollte sich das Problem also mit dem Einbau einer hot-swap-fähigen
Controllerkarte, deren Linux-Gerätetreiber ebenfalls Hot-Swap
unterstützt, lösen lassen.

Theoretisch ja. Die SATA Hardware ist immer hotswap fähig. Ich habe
schon problemlos des öfteren bei laufendem Betrieb das SATA Kabel vom
Brett abgezogen. Das macht alles gar nichts (und das sollte man bei
allen anderen Steckern, außer vielleicht USB oder IEEE1394, UNBEDINGT
unterlassen).

Erfolgsmeldungen - für interne Wechselrahmen, nicht für externe Gehäuse
- fand ich nur eine:
http://www.linuxquestions.org/questions/linux-hardware-18/hot-plug-for-
onboard-sata-how-to-enable-653728/

Das ist doch alles Software-Pallaver. Jeder interne SATA Wechselrahmen
ist immer hotswap-fähig - das ist ja Sinn der Sache. Sieh Dir doch mal
die Dinger an - da ist noch nicht mal Elektronik drauf, nur 2 Stecker an
der richtigen Stelle, und dann hängen 2 Kabel raus. Bei solcher Hardware
lassen sich sogar Hersteller dazu herab, "geht mit Linux" auf die
Packung zu schreiben - HA HA HA HA HA. Es geht wenn schon um die Treiber
(und dementsprechend, Chips), und denen ist das egal, welchen Rahmen du
anklemmst.

Sind das die maßgebenden Informationen für die Hot-Swap-Unterstützung?
http://ata.wiki.kernel.org/index.php/SATA_hardware_features
http://linux-ata.org/driver-status.html

Sieht so aus - Danke! :)

Ich habe sowas mit 3 verschiedenen SATA Kontrollern getestet, nur einer
lief: nforce4. Da geht das dann auch wie ein USB Stöpsel (bis auf LUKS,
das kriegen LDE & Co nicht gebacken), so wie man das erwartet. Der Intel
IHC6 lief nicht - habe aber noch nicht mit ahci getestet. Warmplug geht
- man nehme rescan-scsi-bus.sh (sg3_utils), insbesondere mit --remove,
und möglichst mit Bus-Angabe, sonst hast Du Zeit für einen Kaffee. Eine
billig-Karte lief auch nur mit warmplug, und dann auch nur mit brechen
und biegen - VIA 642x (Modul entladen wahrscheinlich nötig! Geht aber
nicht wenn Du noch ne andere Platte dran hast.).

Kann ich im BIOS ohne weiteres von "Legacy IDE" o.ä. auf "AHCI"
umschalten?

Warum fragst Du, anstatt openSUSE Live reinzuwerfen? ;)

Ich vermute mal, Du kannst nichts kaputt machen. Schlimmstenfalls sind
Deine /dev/sdX vertauscht. Oder beim Booten wird das falsche Modul
geladen (/etc/sysconfig/kernel).

Volker

--
Volker Kuhlmann is list0570 with the domain in header
http://volker.dnsalias.net/ Please do not CC list postings to me.
--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >