Mailinglist Archive: opensuse-de (990 mails)

< Previous Next >
Re: libffmpeg-devel-0.5-0.pm.3 und picard (64bit!)
  • From: Al Bogner <suse-linux@xxxxxxxxxxxxxxxxxxxx>
  • Date: Sat, 27 Jun 2009 22:01:12 +0200
  • Message-id: <200906272201.12823.suse-linux@xxxxxxxxxxxxxxxxxxxx>
Am Samstag 27 Juni 2009 19:11:18 schrieb David Haller:

Hallo David,

# zypper install libxvidcore-devel

[..]

Nothing to do.

Komisch. Mit Yast2?

Nein, in der Shell, genauso wie angeführt.

Ich meinte, ob du mit Yast2 das gleiche Verhalten hast?

Staun, es wurde mit Yast installiert.

rpm -q libxvidcore-devel
libxvidcore-devel-1.2.2-0.pm.0


Aber leider habe ich noch immer:
No decoders found! Fingerprinting will be disabled.

python -c 'import picard.tagger, picard.musicdns.avcodec'
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "picard/tagger.py", line 55, in <module>
from picard.album import Album
File "picard/album.py", line 23, in <module>
from picard.metadata import Metadata, run_album_metadata_processors,
run_track_metadata_processors
File "picard/metadata.py", line 23, in <module>
from picard.similarity import similarity, similarity2
File "picard/similarity.py", line 22, in <module>
from picard.util.astrcmp import astrcmp
ImportError: No module named astrcmp


[..]

[100%] file /usr/include/xvid.h from install of libxvidcore-
devel-1.2.2-0.pm.0.i586 conflicts with file from package libxvidcore-
api-1.2.1-4.1.x86_64

Da fehlt wohl ein Provides: oder Conflicts: beim -devel Paket.

Du koenntest alle (lib)xvid* Pakete deinstallieren und dann die 3
x86_64 Pakete von Packman und bei Bedarf noch die (lib)xvidcore i586
(aber nicht das -devel). Das sollte auch per Yast/zypper klappen.

Ich hoffe, dass das Paket von Manfred bei Packman aktualisiert wird. Mit
Deinstallieren ist das so eine Sache, da sind x-Abhängigkeiten, die dann
auch entfernt würden.

Äh, aus welchem Repo ist xvidcore-api eigentlich? home:saschpe:picard?

Name: libxvidcore-api
Version: 1.2.1-4.1
Arch: x86_64
Vendor: openSUSE Build Service
Installed: Yes

Am 32bit-PC, wo fingerprinting mit 11.1 funktioniert, habe ich nur das
installiert, also kein "api":
rpm -q libxvidcore-devel libxvidcore4 xvidcore
libxvidcore-devel-1.2.2-0.pm.0
libxvidcore4-1.2.2-0.pm.0
xvidcore-1.2.2-0.pm.0


Ansonsten: suche in 'yast2 online_update' nach 'xvid', selektiere
libxvidcore-api zum entfernen, und bei (lib)xvidcore* explizit die
Versionen aus dem Packman-Repo, so daß diese Pakete das "Update"
Symbol erhalten. Dann sollte es klappen.

Am 10.3-Rechner habe ich auch schon ziemlich rumprobiert und komme mit den
benötigten Paketen zum Kompilieren von picard nicht zurecht.

Das Paket aus o.g. Repo tut nicht?

Unter 10.3 noch nicht probiert, da mit dem fertigen Paket unter 11.1
fingerprinting nicht funktioniert, sonst wäre ich gar nicht auf die Idee
gekommen selber zu kompilieren.

Oops, da gibt es gewaltige Versionsprobleme:
Problem: picard kann aufgrund fehlender Abhängigkeiten nicht installiert
werden
Es sind keine installierbaren Anbieter von libpython2_6-1_0 verfügbar für
picard-0.11-5.1.i586[Picard_saschpe]

=== picard-0.11-5.1.i586[Picard_saschpe] ===

picard-0.11-5.1.i586[Picard_saschpe] wird vom Benutzer installiert.

libfaad0-2.6.1-8.1.i686 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libfaad0 == 2.6.1-8.1)

glibc-2.6.1-18.3.i686 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (glibc == 2.6.1-18.3)

python-mutagen-1.15-0.pm.1.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (python-mutagen == 1.15-0.pm.1)

libvorbis-1.2.0-11.2.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libvorbis == 1.2.0-11.2)

zlib-1.2.3-75.i586 wird benötigt von picard-0.11-5.1.i586[Picard_saschpe]
(zlib == 1.2.3-75)

libtheora0-1.0.final-0.pm.0.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libtheora0 == 1.0.final-0.pm.0)

libstdc++42-4.2.1_20070724-17.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libstdc++.so.6)

python-2.5.1-39.8.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (python == 2.5.1-39.8)

libmp3lame0-3.98.2-0.pm.4.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libmp3lame0 == 3.98.2-0.pm.4)

libavcodec52-0.5-0.pm.3.i686 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libavcodec52 == 0.5-0.pm.3)

libxvidcore4-1.2.1-1.1.i686 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libxvidcore4 == 1.2.1-1.1)

liba52-0-0.7.4-9.3.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (liba52-0 == 0.7.4-9.3)

libamrnb3-7.0.0.2-0.pm.0.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libamrnb3 == 7.0.0.2-0.pm.0)

libamrwb3-7.0.0.3-0.pm.0.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libamrwb3 == 7.0.0.3-0.pm.0)

libfaac0-1.28-0.pm.0.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libfaac0 == 1.28-0.pm.0)

libx264-65-0.65-11.1.i686 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libx264-65 == 0.65-11.1)
libavutil49-0.5-0.pm.3.i686 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libavutil49 == 0.5-0.pm.3)
libavformat52-0.5-0.pm.3.i686 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libavformat52 == 0.5-0.pm.3)
xorg-x11-libXext-7.2-65.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (xorg-x11-libXext == 7.2-65)
xorg-x11-libX11-7.2-75.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (xorg-x11-libX11 == 7.2-75)
libdc1394_control12-1.2.2-1.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libdc1394_control12 == 1.2.2-1)
libraw1394-8-1.2.1-64.i586 wird benötigt von
picard-0.11-5.1.i586[Picard_saschpe] (libraw1394-8 == 1.2.1-64)
picard-0.11-5.1.i586[Picard_saschpe] wird benötigt von picard-
lang-0.11-5.1.i586[Picard_saschpe] (picard == 0.11-5.1)
picard-lang-0.11-5.1.i586[Picard_saschpe] wird zur Installation in
Betracht gezogen (als Ergänzung) von picard-0.11-5.1.i586[Picard_saschpe]
(picard == 0.11-5.1)
python-
qt4-4.3-19.i586[http://download.opensuse.org/repositories/openSUSE:10.3/standard/]

wird benötigt von picard-0.11-5.1.i586[Picard_saschpe] (python-qt4)

Lösung 1: picard nicht installieren
picard-0.11-5.1.i586[Picard_saschpe] nicht installieren
Lösung 2: Anforderung nur hier ignorieren
Zahl eingeben, (w)iederholen oder (a)bbrechen>

Ein paar Pakete, die installiert sind.
libfaad0-2.6.1-8.1
glibc-2.6.1-18.3
python-mutagen-1.15-0.pm.1
libvorbis-1.2.0-11.2
libtheora0-1.0.final-0.pm.0
libstdc++42-4.2.1_20070724-17
python-2.5.1-39.8
libmp3lame0-3.98.2-0.pm.4
libavcodec52-0.5-0.pm.3
libxvidcore4-1.2.1-1.1

zB:
zypper install libdca-devel
...
Problem: libdca-devel kann aufgrund fehlender Abhängigkeiten nicht
installiert werden
Es sind keine installierbaren Anbieter von libdca0 == 0.0.5 verfügbar
für libdca-devel-0.0.5-3.i586[Packman-RPMs]

Versuch's auch mit yast, da hab ich hier keine Probleme die
Packman-Versionen einzuspielen. Achso, den Autocheck dazu besser
abstellen.

Da wird gemeckert, dass libgcc43 nicht installiert werden kann.

Al


--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups