Mailinglist Archive: opensuse-de (1280 mails)

< Previous Next >
Canon EOS D40 an oss 11.1
  • From: Michael Eschweiler <michael.eschweiler@xxxxxxxxxxx>
  • Date: Fri, 20 Mar 2009 23:51:33 +0100
  • Message-id: <200903202351.33519.michael.eschweiler@xxxxxxxxxxx>
Hallo Listenleser,

ich habe auf meinem Rechner von oss 10.2 auf 11.1 mit KDE 3.5 (und einigen
Anwendungen von KDE 4.1) migriert. Unter 10.2 war es kein Problem, meine
Kamera über usb anzusprechen, Bilder herunterzuladen und auf der Kamera zu
löschen. Das Auswahlmenü popte auf und ich konnte die gewünschte Anwendung
(digikam o. a.) auswählen und der Zugriff klappte. Wenn ich das gleiche jetzt
mache, bekomme ich zunächst eine nur noch eingeschränkte Auswahl der
Anwendungen, konkret nur noch eine - gwenview - obwohl auch digikam
installiert ist. Wähle ich nun gwenview aus, erhalte ich die Meldung:

Prozess Aufruf des Ein-/Ausgabemoduls nicht möglich.
klauncher meldet: Unbekanntes Protokoll "camera".
kann nicht gestartet werden

Ich habe dann mal unter dmesg nachgeschaut; nach der dortigen Meldung wird die
Verbindung zur Kamera einfach dreist wieder geschlossen (s. letzte Zeile):
usb 4-5: new high speed USB device using ehci_hcd and address 3
usb 4-5: configuration #1 chosen from 1 choice
usb 4-5: New USB device found, idVendor=04a9, idProduct=3146
usb 4-5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 4-5: Product: Canon Digital Camera
usb 4-5: Manufacturer: Canon Inc.
usb 4-5: USB disconnect, address 3

Mit hwinfo bekomme ich folgendes raus:
mymachine:~ # hwinfo --camera
05: USB 00.0: 10f01 WebCam
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_4a9_3146_noserial_if0
Unique ID: 94tr.hfCpTmVISdA
Parent ID: zPk0.9T1GDCLyFd9
SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb4/4-5/4-5:1.0
SysFS BusID: 4-5:1.0
Hardware Class: camera
Model: "Canon Digital Camera"
Hotplug: USB
Vendor: usb 0x04a9 "Canon"
Device: usb 0x3146 "Canon Digital Camera"
Revision: "0.02"
Speed: 480 Mbps
Module Alias: "usb:v04A9p3146d0002dc00dsc00dp00ic06isc01ip01"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #4 (Hub)

Kann es sein, dass die Kamera fälschlich als webcam identifiziert wird?
Was kann ich tun? (Die Kamera über digikam im PTP mode anzusprechen ist keine
Lösung, denn digikam lädt zwar die Bilder herunter, sagt mir dann aber, dass
es die Bilder auf der Kamera nicht löschen kann.)
Wäre für Hilfe sehr dankbar!
Gruß
Michael


--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >