Mailinglist Archive: opensuse-de (1081 mails)

< Previous Next >
Re: Thunderbird - Fehlerhafte DNS-Auflösung
  • From: Fred Ockert <m.ockert@xxxxxxxxxxxxxxx>
  • Date: Thu, 17 Jul 2008 10:02:48 +0200
  • Message-id: <487EFCA8.3050600@xxxxxxxxxxxxxxx>
Sebastian Siebert schrieb:
Hallo Fred,

Fred Ockert schrieb:
Sebastian Siebert schrieb:
Hallo,

ich habe hier ein sehr merkwürdiges Phänomen mit dem Mailclient Thunderbird mit openSUSE 10.3.

Jedes mal, wenn ich Thunderbird starte, wird mir das 1. Konto, dass per POP abgerufen wird, strikt verweigert.
Mit der Begründung das die Zugangsdaten nicht stimmen, obwohl es 100% stimmt.

Als ich dann aber mal ein Ping auf die Mail-Domain machte, stellte ich

wie jetzt ? Mail-Domain ?

Ich hatte extra ne Subdomain auf den Mailserver eingerichtet und
funktioniert wunderbar. Nur jetzt gibt es Probleme auf meiner
openSUSE-10.3-Maschine zu Hause.


na gut ... Maildomain ist aber nicht unbedingt die Domain, wo dein POP-Server liegt (kann sein ..muss nicht)...
- nächste Frage: was für Zugangsdaten ? wer muss sich da wo + wie authentifizieren ?

- Mailserver und POP/IMAP-Server benutzen leicht (!) unterschiedliche Namensauflösungen ( Mail = SMTP schaut auf MX-Record, POP schaut auf A-Record, sollte zueinander passen)


fest, dass es Probleme
gibt mit der DNS-Auflösung. Anstatt die IP meines Server korrekt von der Domain aufzuschlüsseln, wird
eine ganz andere Domain/IP aufgelöst und gespeichert. Aus Sicherheitsgründen habe ich im nachfolgenden
Konsolenausgabe meine richtige Domain als mail.example.com maskiert.


das mit den "Sicherheitsgründen" verstehe ich nicht - es handelt sich als hier um *keine* öffentliche Addresse ! hmm... wenn es eine öffentliche Addresse sein sollte, darfst du dir sicher sein, dass alle Portscanner das schneller herausfinden werden, wo ein Mailserver läuft, als du dir denken kannst...

Sicher, dass es irgendwann einer rausfindet. Aber man muss es nicht provisieren. ;-)


wenn dir Geheimhaltung lieber ist als Fehlerananlyse - dann ja...

na ja ..logisch, wenn der Webserver und der Mailserver auf ganz anderen Maschinen arbeiten....dafür gibts es ja A-record und MX-record (z.B.)

Wie gesagt, DNS-Einträge sind okay und es hat bisher einwandfrei geklappt.


bisher ist nicht das Mass der Dinge - und wenn o.k. -> dann die Frage, woher das Problem ?


# ping mail.example.com
PING mail.example.com (63.245.213.11) 56(84) bytes of data.
64 bytes from de.www.mozilla.com (63.245.213.11): icmp_seq=1 ttl=247 time=34.4 ms
64 bytes from de.www.mozilla.com (63.245.213.11): icmp_seq=2 ttl=247 time=33.9 ms

wozu Ping ?? nslookup, dig , host stellen dir das etwas ausführlicher dar...

Jepp, nur das Tool Ping ist mir just eingefallen und daher fiel mir das darin schon auf,
dass da was verkehrt läuft.

Falls das Problem nochmal auftritt, werde ich nslookup nochmal prüfen und hier posten.

wenn einmal ein Problem war...ist es oft klüger diesem auf den Grund zu gehen...und sei es mal einen Cache löschen zu müssen...oder eben einen Tag warten..)

Die Datei /etc/resolv.conf:
search home
nameserver 192.168.1.1

das sagt uns nur, dass du einen lokalen DNS-Server betreibst... du verrätst aber nicht, was der tut....


Die Datei /etc/hosts:
nur lokale Angaben...

Irgendwelche Ideen?

doch ...eben Namensauflösung prüfen.. mit Tools, die etwas mehr sagen...

Völlig unabhängig davon - wenn Namensauflösung funtioniert - kannst du den Rest testen... (oder vorher, indem du dem Mailclient statt mit einem Namen mit einer IP-Nummer ausstattest...dann brauchts kein DNS mehr...)

Gruß
Sebastian


Fred

--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups