Mailinglist Archive: opensuse-de (1512 mails)

< Previous Next >
Re: Linux "verliert" USB-Festplatte
Am Sonntag, 22. Juli 2007 11:58 schrieb Thomas Hertweck:
nach einer gewissen Zeit die USB-Festplatte. Dies äußert sich darin, dass
die Platte dann nicht mehr gemountet ist und ab da das Anlegen von
Dateien logischerweise schief geht.

Was sagen die Log-Files, z.B. /var/log/messages?

Jul 22 18:27:19 majestix kernel: usb 1-6: reset high speed USB device using
ehci_hcd and address 47
Jul 22 18:27:21 majestix kernel: sd 43:0:0:0: scsi: Device offlined - not
ready after error recovery
Jul 22 18:27:21 majestix kernel: usb 1-6: USB disconnect, address 47
Jul 22 18:27:21 majestix kernel: sd 43:0:0:0: SCSI error: return code =
0x00050000
Jul 22 18:27:21 majestix kernel: end_request: I/O error, dev sdb, sector
154097143
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262135
Jul 22 18:27:21 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262136
Jul 22 18:27:21 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262137
Jul 22 18:27:21 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262138
Jul 22 18:27:21 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262139
Jul 22 18:27:21 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262140
Jul 22 18:27:21 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262141
Jul 22 18:27:21 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262142
Jul 22 18:27:21 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262143
Jul 22 18:27:21 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:21 majestix kernel: Buffer I/O error on device sdb1, logical
block 19262144
Jul 22 18:27:22 majestix kernel: lost page write due to I/O error on sdb1
Jul 22 18:27:22 majestix kernel: sd 43:0:0:0: rejecting I/O to offline device
Jul 22 18:27:22 majestix kernel: sd 43:0:0:0: rejecting I/O to offline device
Jul 22 18:27:22 majestix kernel: sd 43:0:0:0: rejecting I/O to device being
removed
Jul 22 18:27:22 majestix kernel: sd 43:0:0:0: SCSI error: return code =
0x00010000
Jul 22 18:27:22 majestix kernel: end_request: I/O error, dev sdb, sector
154097383
Jul 22 18:27:22 majestix kernel: EXT3-fs error (device sdb1):
read_block_bitmap: Cannot read block b
itmap - block_group = 589, block_bitmap = 19300352
Jul 22 18:27:22 majestix kernel: Aborting journal on device sdb1.
Jul 22 18:27:22 majestix kernel: ext3_abort called.
Jul 22 18:27:22 majestix kernel: EXT3-fs error (device sdb1):
ext3_journal_start_sb: Detected aborte
d journal
Jul 22 18:27:22 majestix kernel: Remounting filesystem read-only
Jul 22 18:27:22 majestix kernel: sd 43:0:0:0: rejecting I/O to device being
removed

Die letzte Meldung erscheint dann SEHR oft. Ich vermute mal, die vorletzte
Meldung erklärt, warum nichts mehr geschrieben werden kann.

Aber warum?

Kann mir jemand einen Tipp geben, wie ich die Daten gesichert kriege?

IMO gibt es mehrere Moeglichkeiten, was schief laeuft: 1) die Hardware
(sprich: z.B. Festplatte oder USB-Port) hat einen Defekt; 2) die externe
Backup-Platte hat kein eigenstaendiges Netzteil und zieht einfach zu
viel Strom ueber den USB Port;

Also, es ist eine 2,5"-Platte ohne Netzteil. Kann es denn sein, dass so ein
Problem (zieht zu viel Strom) erst nach ca. 10 Minuten auftritt?

3) das Filesystem ist fehlerhaft und fuehrt zu einem Abbruch der
Kopieraktion;

Das müsste doch dann aber gleich am Anfang auftreten, oder?

Moegliche Tests/Aktionen: auf alle Faelle Log-Files
ueberpruefen; andere USB-Platte verwenden und schauen, ob es dann geht;

Also, ich hatte vorher eine 3,5"-Platte mit externem Netzteil, da ging es ohne
Probleme. Ich habe leider keine andere Platte, die ich probieren könnte.

Filesystem ueberpruefen; verwende einen anderen USB-Port; schliesse die

Einen anderen Port habe ich probiert, bringt aber nichts.

Viele Grüße,
Ralf.
--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >