Mailinglist Archive: opensuse-de (1579 mails)

< Previous Next >
Re: Bootloader defekt nach Win Installation
Am Montag 14 Mai 2007 19:26:22 schrieb Harry Konietzke:
Hallo,

Teja Philipp schrieb:
Hallo,

bist du des englischen mächtig?

Zum Verstehn reicht es ;-)

http://blog.shevin.info/2007/04/messed-up-boot-loader-dont-worry.html
das hilft dir (hoffentlich) weiter.

Na wat 'n Glück das da noch ne Ubuntu-Live-CD bei mir rumliegt. Werde
ich gleich mal testen.

also ich hab ne knoppix benutzt.
auch möglich ist es mit der suse install cd - installation -> anderes ->
vorhandenes system starten.
und dann dort machen.

viel erfolg, teja

Danke für den Tipp.

Grüße

Harry

wenn nicht, lass nen schrei.
grüße, Teja

Am Montag 14 Mai 2007 17:40:30 schrieb Harry Konietzke:
Hallo alle zusammen,

bin kurz vor der Verzweiflung. Ich bekomme den Bootloader Grub nicht
installiert.

Aber erst mal zum System. Ich habe zwei Festplatten, hda - Windows und
hdb - OpenSuSE 10.2. Windows hat 3 Partitionen und Linux hat hdb1
(swap), hdb2 (root), und hdb3 (home). Das ganze System lief bis jetzt
sorgenfrei. Leider musste ich Windows neuinstallieren und somit wurde
der Bootloader gelöscht. Meine Versuche mit der OS10.2 DVD den
Bootloader wieder herzustellen schlug bisher fehl.

Ich habe gebootet mit der DVD, dann Installation ausgewählt und auf
Deutsch umgestellt. Hier die Lizenzvereinbarung bestätigt, Modus Weiter
Optionen ausgewählt und dann Reparatur des installierten Systems
bestätigt. Im folgenden Menü habe ich Expertenwerkzeuge angeklickt und
Neuen Bootloader installieren genommen. Dan Grub einen neuen Vorschlag
machen lassen und das ganze in den MBR schreiben lassen. ABER hier kommt
dann der Fehler.

Minimal BASH-like line editing is supported. For the first word, TAB
lists possible command completions. Anywere else TAB lists the possible
completions of a device/filname.
grub> setup --stage2=/boot/grub/stage2 (hd0) (hd1,1)

Error 21: Selected disk does not exist
grub> quit

Na lecker, welche disk existiert denn hier angeblich nicht? Gehe ich zum
Partitionierer, sind alle Partitionen aufgelistet. Ich weiß leider nicht
was ich hier noch machen kann. Ich hoffe, mir kann jemand weiterhelfen.
Ach so, Lilo geht auch nicht, Lilo sagt mir das es /sbin/lilo nicht
gibt. Eine Installation des Bootloaders, egal ob Grub oder Lilo auf
Diskette funktioniert auch nicht, meine Diskettenlaufwerk wird nicht
gefunden.

Kann es sein, das es durch das Kernel Update nicht mehr mit der Original
DVD funktioniert?

Hilfe, Ich will wieder an mein Linux :-((((

Grüße
Harry


< Previous Next >