Mailinglist Archive: opensuse-de (1402 mails)

< Previous Next >
Re: privoxy-surfen als root?
  • From: Siegfrid Brandstätter <garafrut@xxxxxx>
  • Date: Sun, 15 Apr 2007 17:10:08 +0100
  • Message-id: <200704151710.08378.garafrut@xxxxxx>
Am Sonntag 15 April 2007 schrieb Siegfrid Brandstätter:
> Hallo Volker, hallo Liste,
>
> Am Sonntag 15 April 2007 schrieb Volker Kuhlmann:
> > On Sun 15 Apr 2007 13:15:42 NZST +1200, Siegfrid Brandstätter wrote:
> > > Das beruhigt mich. Danke! Habe nun mit Yast-Runlevel Editor privoxy
> > > aktiviert.
> > >
> > > linux-sy54:/home/sigi # chkconfig -a privoxy
> > > privoxy                   0:off  1:off  2:off  3:on   4:off  5:on  
> > > 6:off
> >
> > chkconfig -a aktiviert auch, aber mehrmalige Aktivierung richtet halt
> > keinen Schaden an.
> >
> > > Aber nun nach einem Neustart, wurde zwar der "privoxy" automatisch
> > > gestartet. aber danach konnte ich erst nach einem "rcprivoxy stop" und
> > > "rcprivoxy start" wieder surfen.
> >
> > Funktioniert bei mir. Moment, hast Du Dialup-Internet?
>
> Durch den ADSL Anschluß -Router wird das beim booten gestartet.
>
> > Wenn privoxy
> > started, kann er nur auf den Netwerkschnittstellen starten, die zu dem
> > Zeitpunkt schon existieren. Wenn Du Dich dann einwählst, ist das eine
> > neue Schnittstelle (modem0 oder so, siehe ifconfig) von dem Privoxy
> > nichts weiß. Da hilft nur privoxy-Neustart (rcprivoxy restart).
>
>  ifconfig
> eth0      Protokoll:Ethernet  Hardware Adresse 00:06:4F:38:46:1A
>           inet Adresse:192.168.1.2  Bcast:192.168.1.255 
> Maske:255.255.255.0 UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500 
> Metric:1 RX packets:2650 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:3058 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 Sendewarteschlangenlänge:1000
>           RX bytes:2243359 (2.1 Mb)  TX bytes:430684 (420.5 Kb)
>           Interrupt:11 Basisadresse:0x2000
>
> lo        Protokoll:Lokale Schleife
>           inet Adresse:127.0.0.1  Maske:255.0.0.0
>           UP LOOPBACK RUNNING  MTU:16436  Metric:1
>           RX packets:502 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:502 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 Sendewarteschlangenlänge:0
>           RX bytes:174869 (170.7 Kb)  TX bytes:174869 (170.7 Kb)
>
> > openSUSE hat einen Mechanismus, mit dem man Systemdienste neu starten
> > kann, wenn neue Netzwerkschnittstellen hochkommen oder verschwinden. Ich
> > weiß aber nicht genau auswendig, wie das geht. Der NTP daemon zB muß
> > auch neu gestartet werden.
>
> Das wäre wahrscheinlich das was hier fehlt. ;-)
>
> > Wenn es sich um ppp handelt,
>
> Wie stelle ich fest ob es ppp ist?
>
> > kannst Du einen 2-Zeiler
> > /etc/ppp/ip-up.local anlegen und dort privoxy neu starten. Dito für
> > /etc/ppp/ip-down.local damit ordentlich aufgeräumt wird. Kannst Du
> > mittels Symlink auf ein Skript begrenzen. zB:
> >
> > cat <<EOF >/etc/ppp/ip-up.local
> > #!/bin/sh
> > /etc/init.d/privoxy status && /etc/init.d/privoxy restart &
> > EOF
> >
> > chmod 700 /etc/ppp/ip-up.local
> > ln -s /etc/ppp/ip-up.local /etc/ppp/ip-down.local
>
> Das habe ich nun gemacht, war aber anscheinend nicht das richtige.
> Geht weiterhin nur erst mit "rcprivoxy restart"
>
> Nun zickt leider Tor auch noch rum, bisher war Tor beim Start im Firefox 
> im Switch Proxy automatisch aktiv, Seit dem ich den Runlevel in Yast
> umgestellt habe ist er nun immer ausgeschaltet. Der Runlevel Editor sagt
> aber:
>
> Dienst      Läuft
>  tor            Nein   3 5   Start the tor daemon
>  Wenn ich dann  im Yast das änden will erhalte ich:
>
> "/etc/init.d/tor start gab 7 (Programm wird nicht ausgeführt) zurück:
> Starting tor daemon
> /usr/bin/torctl start: tor (pid 3838) already running"
>
> läuft aber im Firefox nicht, erst wenn ich im Switch Proxy händisch Tor
> aktiviere.
> Kann leider keinen Fehler finden, die Einstellungen für Tor sind meiner
> Meinung so wie am Anfang.

Nach einem Neustart wird Tor nun wieder von alleine als aktiv im Switch Proxy 
angezeigt. Aber trotz mehrmaligem "rcprivoxy restart" oder "rcprivoxy stop 
und start" werden die Seiten erst geladen wenn der Tor auch noch aus und 
eingeschaltet werden. Irgendwie etwas eigenartig, erst nach einigenmalen 
start-stop geht es. Selbst bei Opera das gleiche.


 Gruß Sigi


--
Um die Liste abzubestellen, schicken Sie eine Mail an:
    opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >