Mailinglist Archive: opensuse-de (2154 mails)

< Previous Next >
Re: Installationszwang brechen, aber wie?
  • From: David Haller <lists@xxxxxxxxxx>
  • Date: Wed, 28 Feb 2007 09:33:22 +0100
  • Message-id: <20070228083322.GA4849@xxxxxxxxxxxxxxxxxx>
Hallo,

Am Mit, 28 Feb 2007, Hannes Vogelmann schrieb:
>Yast sagt:
>
>Fehlende Abhängigkeiten von product:openSUSE-DVD5-download-10.2.i686
>Fehlende Abhängigkeiten von pattern:kde-10.2-145.i586
[..]
>Fehlende Abhängigkeiten von pattern:games-10.2-145.i586
>Fehlende Abhängigkeiten von evms-gui-2.5.5-67.i586
>Fehlende Abhängigkeiten von yast2-storage-evms-2.14.18-3.i586
>
>rpm -e evms sagt:
>
>stuiben:/home/vogelmann # rpm -e evms-2.5.5-67
>error: Failed dependencies:
> libevms-2.5.so.0 is needed by (installed) evms-gui-2.5.5-67.i586
> libevms-2.5.so.0 is needed by (installed) yast2-storage-evms-2.14.18-3.i586
> libevms-2.5.so.0(EVMS) is needed by (installed) evms-gui-2.5.5-67.i586
> libevms-2.5.so.0(EVMS) is needed by (installed) yast2-storage-evms-2.14.18-3.i586
> evms = 2.5.5 is needed by (installed) evms-gui-2.5.5-67.i586
>
>Warum jetzt rpm weniger Abhängigkeiten findet als der Yast, weiß der
>Geier, wüsste ich auch gerne...

Völlig normal, die 'pattern' heißen im deutschen Yast "Schemata",
d.h. Zusammenstellungen verschiedener Pakete, die durchaus auch oft
gleiche Pakete enthalten. EVMS ist eben in vielen enthalten.

Deinstallieren mußt du nur die von RPM genannten, die sind ja nur GUIs
zu evms.

In yast: deaktiviere evms-gui, yast2-storage-evms, und dann erst evms,
dann sollte es klappen.

Alternativ: rpm --test -e evms-gui yast2-storage-evms evms

-dnh

--
Grundsätzlich finde ich es begrüßenswert, wenn Attentäter mit dem Zug zum
Attentat fahren. Ich meine, wo kann man sicherer sein, daß sie zu spät kommen?
-- Dieter Nuhr, Nuhr 2006
--
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@xxxxxxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@xxxxxxxxxxxx

< Previous Next >