Mailinglist Archive: opensuse-de (1798 mails)

< Previous Next >
Re: Drucken unter SuSE 10.1.....Druckt nicht :)
  • From: Johannes Meixner <jsmeix@xxxxxxx>
  • Date: Mon, 4 Sep 2006 12:39:16 +0000 (UTC)
  • Message-id: <Pine.LNX.4.64.0609041419340.30052@xxxxxxxxxxxxx>

Hallo,

On Sep 4 13:05 Daniel Spannbauer wrote (shortened):
> ich hab ein Problem mit dem Drucken unter SUSE 10.1
> Installiert ist ein Standard-SuSe, also keine Updates o.ä.
>
> Eingerichtet ist ein Kyocera 1010 an einem Printserver über den ich
> drucken kann.
> Als Treiber wird der hp-laserjet 5 (HP-LaserJet_5-hpijs.ppd.gz) genommen.

Was genau ist ein "Kyocera 1010"?
Es ist nicht hilfreich, wenn man das Modell raten muß.
Es gibt sowohl einen "Kyocera F-1010" als auch einen "Kyocera FS-1010"
und die sind in YaST auch so auswählbar mit folgenden PPD-Dateien:
/usr/share/cups/model/manufacturer-PPDs/kyocera/Kyocera_Mita_FS-1010_en.ppd.gz
/usr/share/cups/model/Kyocera/F-1010-gimp-print.ppd.gz
/usr/share/cups/model/Kyocera/F-1010-laserjet.ppd.gz
/usr/share/cups/model/Kyocera/F-1010-ljetplus.ppd.gz
/usr/share/cups/model/Kyocera/FS-1010-Postscript.ppd.gz
/usr/share/cups/model/Kyocera/FS-1010-gimp-print.ppd.gz
/usr/share/cups/model/Kyocera/FS-1010-lj4dith.ppd.gz
/usr/share/cups/model/Kyocera/FS-1010-lj5gray.ppd.gz
/usr/share/cups/model/Kyocera/FS-1010-ljet4.ppd.gz
/usr/share/cups/model/Kyocera/FS-1010-ljet4d.ppd.gz
/usr/share/cups/model/Kyocera/FS-1010-pxlmono.ppd.gz

Warum also dann eine PPD-Datei für einen HP LaserJet 5 nehmen
mit einem Treiber "hpijs", der ganz speziell für HP Drucker ist?

Bei einem "Kyocera FS-1010" PostScript Drucker ist die
originale PPD-Datei vom Hersteller
/usr/share/cups/model/manufacturer-PPDs/kyocera/Kyocera_Mita_FS-1010_en.ppd.gz
in Zweifelsfall immer die beste Wahl, siehe unsere Doku:
http://de.opensuse.org/SDB:Drucker_einrichten_ab_SUSE_LINUX_9.1
"Allgemeine Hinweise zum Einrichten von PostScript Druckern"


> Ich hänge hier ... mal die error.log des Cups an.

Darin findet sich:
-------------------------------------------------------------------
I ... Started filter /usr/lib/cups/filter/foomatic-rip
(PID 21363) for job 63.
...
D ... Process dying with "The renderer command line returned
an unrecognized error code 135.", exit stat: 1
...
E ... PID 21363 stopped with status 1!
-------------------------------------------------------------------

Das hilft noch nicht wirklich weiter.

Also in /usr/lib/cups/filter/foomatic-rip (ein Link auf
/usr/bin/foomatic-rip) das Debugging einschalten, dazu die Zeile

my $debug = 0;

in

my $debug = 1;

ändern und dann nach genau einem erneuten (Fehl)-Versuch in
/tmp/foomatic-rip.log nachschauen, ob sich da nun erhellende
Informationen finden.


Gruss
Johannes Meixner
--
SUSE LINUX Products GmbH, Maxfeldstrasse 5 Mail: jsmeix@xxxxxxx
90409 Nuernberg, Germany WWW: http://www.suse.de/
< Previous Next >
Follow Ups
References