Mailinglist Archive: opensuse-de (1798 mails)

< Previous Next >
Re: Wie krieg ich "apt" auf die Platte
  • From: Werner Flamme <werner.flamme@xxxxxx>
  • Date: Fri, 22 Sep 2006 12:24:50 +0000 (UTC)
  • Message-id: <4513D60A.4040604@xxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Steffen Hanne schrieb am 22.09.2006 13:30:
> Am Freitag, 22. September 2006 12:03 schrieb Werner Flamme:
>> Ich bevorzuge übrigens apt gegenüber smart - mir erscheint a) die grafische
>> Oberfläche synaptic übersichtlicher als "smart --gui" und zum anderen habe
>> ich bei smart den Schalter, der "apt upgrade -s" entspricht, noch nicht
>> gefunden.
> Hallo Werner,
>
> "smart upgrade --check" Prüfen lt. Onlinehilfe, nur, ob es Upgrades gibt.
> Ansonsten wird beim Upgrade üblicherweise eine Liste der zu aktualisierenden
> Pakete angezeigt und eine Bestätigung angefordert. Da kann man immer noch
> prüfen, ob man diese Aktualisierung ausführen will.
> Hier noch mal alle Optionen für smart upgrade:
>
> Optionen:
> -h, --help Zeige diese hilfe und beende
> --stepped Ausführung in einzelschritte aufteilen
> --urls Dumpe benötigte urls und führe keine funktion aus
> --download Herunterladen der pakete und keine funktion ausführen
> --update Update channel informationen vor dem upgrade
> --check Nur prüfen, ob es upgrades gibt
> --check-update Prüfe, ob upgrades vorhanden sind und update die vorhandenen
> --explain Füge zusätzliche informationen über ãnderungen ein, wenn
> möglich
> -y, --yes Frage nicht nach bestätigung
>
> Viele Grüße
>
> Steffen
>
>
>
>
Hallo Steffen,

danke für den Hinweis. Bisher gab mir smart (smart-0.42-12.guru.suse100)
aus, dass Pakete zum Update bereitstehen, aber nicht, welche das wohl sein
könnten:

rz36:~ # smart upgrade --check
Loading cache...
Updating cache...
#################################################################################
[100%]

Computing transaction...
There are new upgrades available!
rz36:~ #

Sehr witzig :-(

Ich suche wirklich den Schalter, der wie bei "apt upgrade -s" anzeigt
*welche* Software aktualisiert werden soll. --stepped kommt dem sehr nahe,
aber ich muss mit "n" abbrechen, apt hört hier automatisch auf. --explain
erklärt mir gar nix :-(

Gruß
Werner

- --
Werner Flamme, Abt. WKDV
UFZ Umweltforschungszentrum Leipzig-Halle GmbH,
Permoserstr. 15 - 04318 Leipzig
Tel.: (0341) 235-3921 - Fax (0341) 235-453921
http://www.ufz.de - eMail: werner.flamme@xxxxxx




-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org

iD8DBQFFE9YKk33Krq8b42MRAhIpAKCDjoS97JKU4VJeKPgX81u8J3VYlgCfcXZS
YDgKpkEMKVQe9K+WMv8l5d4=
=SWmo
-----END PGP SIGNATURE-----

< Previous Next >