Mailinglist Archive: opensuse-de (1612 mails)

< Previous Next >
Problem mit koffice-wordprocessing-1.5.2-4.1 und libgsf-1.so.1
  • From: Werner Flamme <werner.flamme@xxxxxx>
  • Date: Mon, 24 Jul 2006 12:42:40 +0200
  • Message-id: <44C4A420.1040000@ufz.de>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hallo Liste,

ich setze SUSE 10.0 x86_64 ein und versuche, aus der "Backports"-Quelle
KOffice zu aktualisieren. Es scheitert an:

warning: koffice-1.5.2-4.1.x86_64.rpm: V3 DSA signature: NOKEY, key ID 6b9d6523
error: Failed dependencies:
libgsf-1.so.1()(64bit) is needed by koffice-wordprocessing-1.5.2-4.1

Nun gehört die angeblich fehlende Lib eigentlich zum Paket
libgsf-1.13.99-15, aber "irgendwie" ;-) reicht das nicht.

rz36:~ # ldconfig -p | grep gsf
libgsfglue.so (libc6,x86-64) => /usr/lib64/libgsfglue.so
libgsf-1.so.113 (libc6,x86-64) => /usr/lib64/libgsf-1.so.113
libgsf-1.so.113 (libc6,x86-64) => /opt/gnome/lib64/libgsf-1.so.113
libgsf-1.so.1 (libc6) => /opt/gnome/lib/libgsf-1.so.1
libgsf-gnome-1.so.113 (libc6,x86-64) =>
/usr/lib64/libgsf-gnome-1.so.113
libgsf-gnome-1.so.113 (libc6,x86-64) =>
/opt/gnome/lib64/libgsf-gnome-1.so.113

Im Paket ist die /opt/gnome/lib64/libgsf-1.so.113; man kann sie
versymlinken (sowohl unter /usr/lib64 als auch unter /opt/gnome/lib64) als
libgsf-1.so.1 und sehr oft ldconfig aufrufen, aber nix is, es wird immer
nur die 32bit-Version unter /opt/gnome/lib/ bzw. die ".113" statt ".1"
gefunden.

Was mache ich flasch? Oder reicht es einfach, mit --nodeps zu installieren?
Aber ldconfig findet die Bibliothek ja auch nicht...

Gruß
Werner

- --
Werner Flamme, Abt. WKDV
UFZ Umweltforschungszentrum Leipzig-Halle GmbH,
Permoserstr. 15 - 04318 Leipzig
Tel.: (0341) 235-3921 - Fax (0341) 235-453921
http://www.ufz.de - eMail: werner.flamme@xxxxxx




-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org

iD8DBQFExKQgk33Krq8b42MRAgjRAJ9t2VnDNWm1vqpH7zlH7Ewtr8YuVwCdGE9+
0+jwi+ISVuLIja+NjOwt/F0=
=Zzqr
-----END PGP SIGNATURE-----

--
Um die Liste abzubestellen, schicken Sie eine Mail an:
suse-linux-unsubscribe@xxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: suse-linux-help@xxxxxxxx

< Previous Next >