Mailinglist Archive: opensuse-de (2226 mails)

< Previous Next >
Re: Einbindung amavis in postfix
  • From: Michael Schueller <schueller-berlin@xxxxxx>
  • Date: Wed, 7 Jun 2006 21:25:56 +0200
  • Message-id: <200606072125.57237.schueller-berlin@xxxxxx>
Am Dienstag, 6. Juni 2006 15:45 schrieb Martin Zambo:
> Hallo Sandy,
>
> Am Dienstag, 6. Juni 2006 15:06 schrieb Sandy Drobic:
> > AAARGH!! AppArmor!!!
> >
> > Sandy
>
> Und da gibt es keine Lösung?
>
> Martin

Hallo Martin,
ich glaube ich kann Dir jetzt in der Frage weiterhelfen, versuch mal
folgendes...

Ich gehe davon aus das Du amavis installiert hast, und AppArmor
deaktiviert ist.
Aktiviere AppArmor über das Yast Modul "AppArmor Kontrollleiste"
Wechsel nun in das Modul "Assistent zum aktualisieren von Profilen"

Dort quittierst Du mit ENTER alle neuen Einträge (die Vorschläge
können übernommen werden)

Und nun wird´s interessant, möglicherweise finden wir jetzt die
eigentliche Ursache des Problems.

Wechsel nun in das Modul Profil bearbeiten
Klicke auf das Profil "usr/lib/postfix/smtpd , und auf weiter...
(bitte beachte es gibt smtp und smtpd, gehe in letzteres)

Scroll durch die Liste zum Eintrag
/var/spol/postfix/pid/inet[127.0.0.1]:10025

Ich hab jetzt bei mir zwei Einträge
Einmal mit Klammer, und einmal ohne
In der /etc/postfix/master.cf steht der Eintrag bei mir ohne Klammer
Ich weiß leider nicht ob der Eintrag ohne auch schon vor der
aktualisierung der Profile da war, ich kann mir aber nicht
vorstellen das beide Einträge nötig sind.
Meine Vermutung ist das einer der Einträge demzufolge falsch ist.

Wie auch immer.
Wenn Du hierdurch amavis mit AppArmor zum laufen bringst könnte ich
auf Bugzilla die notwendigen Hinweise zur Lösung des Problems
geben.
Wäre also schön wenn Du die Schritte mal nachvollziehen könntest.

Gruß
Micha

--
Um die Liste abzubestellen, schicken Sie eine Mail an:
suse-linux-unsubscribe@xxxxxxxx
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: suse-linux-help@xxxxxxxx

< Previous Next >